NKH.MindSqualls Namespace

[image]

MindSqualls v2.0 documentation
NKH.MindSqualls Namespace
Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Contains classes for communicating with a LEGO MINDSTORMS NXT robot; bluetooth connection, the brick itself, motors and sensors.

Classes

 | Class | Description
Public class | HiTechnicAccelerationSensor | Class representing the Acceleration / Tilt Sensor sensor from HiTechnic: http://www.hitechnic.com
Public class | HiTechnicColorSensor | Class representing the Color sensor from HiTechnic: http://www.hitechnic.com
Public class | HiTechnicCompassSensor | Class representing the Compass sensor from HiTechnic: http://www.hitechnic.com
Public class | Nxt2ColorSensor | Class representing the NXT 2.0 color sensor.
Public class | NxtActiveSensor | Abstract class representing a Active Sensor.
Public class | NxtBluetoothConnection | Class representation communication over a Bluetooth connection.
Public class | NxtBrick | Class representing the NXT brick.
Public class | NxtCommunicationProtocol | Abstract class representing the NXT communication protocol.
Public class | NxtCommunicationProtocolException | Exception thrown when there is an error in the communication to the NXT brick.
Public class | NxtConnectionException | This exception is thrown when there is no connection to the NXT brick.
Public class | NxtDigitalSensor | Abstract class representing a Digital sensor, i.e. a sensor using the I2C protocol.
Public class | NxtException | Generic NXT exception.
Public class | NxtLightSensor | Class representing the Light sensor.
Public class | NxtMotor | Class representing a motor.
Public class | NxtMotorSync | Class representing a synchronized pair of motors.
Public class | NxtNoSensor | Class representing a port with no sensor attached.
Public class | NxtPassiveSensor | Abstract class representing a Passive Sensor.
Public class | NxtPollable | Abstract class used as superclass for the NxtMotor and NxtSensor classes.
Public class | NxtSensor | Superclass representing a generic sensor.
Public class | NxtSoundSensor | Class representing the Sound sensor.
Public class | NxtTouchSensor | Class representing the Touch sensor.
Public class | NxtUltrasonicSensor | Class representing the Ultrasonic sensor.
Public class | NxtUsbConnection | Class representing communication over an USB connection.

Structures

 | Structure | Description
Public structure | NxtFindFileReply | Reply type for the FindFirst() and FindNext() functions.
Public structure | NxtGetDeviceInfoReply | Reply type for the GetDeviceInfo() function.
Public structure | NxtGetFirmwareVersionReply | Reply type for the GetFirmwareVersion() function.
Public structure | NxtGetInputValuesReply | Reply type for the GetInputValues() function.
Public structure | NxtGetOutputStateReply | Reply type for the GetOutputState() function.
Public structure | NxtOpenAppendDataReply | Reply type for the OpenAppendData() function.
Public structure | NxtOpenReadReply | Reply type for the OpenRead() function.
Public structure | NxtRequestModuleReply | Reply type for the RequestFirstModule() and RequestNextModule() functions.

Delegates

 | Delegate | Description
Public delegate | NxtMotorEvent | Delegate used for the NXT-G like events implemented in the motor.
Public delegate | NxtSensorEvent | Delegate used for the NXT-G like events implemented in the various sensors.
Public delegate | Polled | Delegate used when a motor or sensor is polled.

Enumerations

 | Enumeration | Description
Public enumeration | Nxt2Color | Color-values for the NXT 2.0 Color sensor.
Public enumeration | Nxt2ColorSensorMode | Sensor-modes for the NXT 2.0 color sensor.
Public enumeration | NxtCommand | Commands to the NXT brick.
Public enumeration | NxtCommLinkType | Types of communication links usable for the NXT brick.
Public enumeration | NxtErrorMessage | ERROR MESSAGE BACK TO THE HOST
Public enumeration | NxtMailbox | Reference: BDK, Appendix 2, p. 9.
Public enumeration | NxtMailbox2 | Reference: BDK, Appendix 2, p. 9. Reference: BDK, Appendix 2, p. 11. (see MessageRead() function).
Public enumeration | NxtMotorMode | Reference: BDK, Appendix 2, p. 6.
Public enumeration | NxtMotorPort | Reference: BDK, Appendix 2, p. 6.
Public enumeration | NxtMotorRegulationMode | Reference: BDK, Appendix 2, p. 6.
Public enumeration | NxtMotorRunState | Reference: BDK, Appendix 2, p. 6.
Public enumeration | NxtSensorMode | Reference: BDK, Appendix 2, p. 7.
Public enumeration | NxtSensorPort | Reference: BDK, Appendix 2, p. 7.
Public enumeration | NxtSensorType | Reference: BDK, Appendix 2, p. 7.

Send comments on this topic to niels@mindsqualls.net

The legal stuff


HiTechnicAccelerationSensor Class

[image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Class representing the Acceleration / Tilt Sensor sensor from HiTechnic: http://www.hitechnic.com

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class HiTechnicAccelerationSensor : NxtDigitalSensor
Visual Basic
Public Class HiTechnicAccelerationSensor _
    Inherits NxtDigitalSensor
Visual C++
public ref class HiTechnicAccelerationSensor : public NxtDigitalSensor

Remarks

A special thanks to the people at HiTechnic for providing me with the necessary technical information.

Also a special thanks to Ronny H. for providing me with qualified implementation details on the acceleration sensor before I had purchased my own copy.

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtPollable
NKH.MindSqualls..::..NxtSensor
NKH.MindSqualls..::..NxtDigitalSensor
NKH.MindSqualls..::..HiTechnicAccelerationSensor

See Also

HiTechnicAccelerationSensor Members
NKH.MindSqualls Namespace


HiTechnicAccelerationSensor Members

[image] [image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor Members
HiTechnicAccelerationSensor Class Constructors Methods Fields Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The HiTechnicAccelerationSensor type exposes the following members.

Constructors

 | Name | Description
Public method | HiTechnicAccelerationSensor | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Poll the sensor (Inherited from NxtSensor.)
Public method | ReadProductId | Returns the name of the manufacturer, e.g. "LEGO". (Inherited from NxtDigitalSensor.)
Public method | ReadSensorType | Returns the sensor type, e.g. "Sonar". (Inherited from NxtDigitalSensor.)
Public method | ReadVersion | Returns the version of the sensor. (Inherited from NxtDigitalSensor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | XAxisAcceleration | Acceleration coordinate of the X-axis.
Public method | XAxisLower2Bits | X axis lower 2 bits
Public method | XAxisUpper8Bits | X axis upper 8 bits
Public method | YAxisAcceleration | Acceleration coordinate of the Y-axis.
Public method | YAxisLower2Bits | Y axis lower 2 bits
Public method | YAxisUpper8Bits | Y axis upper 8 bits
Public method | ZAxisAcceleration | Acceleration coordinate of the Z-axis.
Public method | ZAxisLower2Bits | Z axis lower 2 bits
Public method | ZAxisUpper8Bits | Z axis upper 8 bits

Fields

Name Description
Public field scalíng

Change this value, to finetune the value of the acceleration sensor.

The current value, = 9.82/206.3, is the best fit for my own sensor.

Remarks

The component used in the sensor is only guaranteed to be accurate to +/- 10%.

Protected field sensorPort

The port the sensor is attached to.

(Inherited from NxtSensor.)
Protected field sensorType

The type of the sensor.

(Inherited from NxtSensor.)

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

HiTechnicAccelerationSensor Class


HiTechnicAccelerationSensor Constructor

[image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor Constructor
HiTechnicAccelerationSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public HiTechnicAccelerationSensor()
Visual Basic
Public Sub New
Visual C++
public:
HiTechnicAccelerationSensor()

See Also

HiTechnicAccelerationSensor Class


HiTechnicAccelerationSensor Fields

[image] [image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor Fields
HiTechnicAccelerationSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The HiTechnicAccelerationSensor type exposes the following members.

Fields

Name Description
Public field scalíng

Change this value, to finetune the value of the acceleration sensor.

The current value, = 9.82/206.3, is the best fit for my own sensor.

Remarks

The component used in the sensor is only guaranteed to be accurate to +/- 10%.

Protected field sensorPort

The port the sensor is attached to.

(Inherited from NxtSensor.)
Protected field sensorType

The type of the sensor.

(Inherited from NxtSensor.)

See Also

HiTechnicAccelerationSensor Class


scalíng Field

[image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor..::..scalíng Field
HiTechnicAccelerationSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Change this value, to finetune the value of the acceleration sensor.

The current value, = 9.82/206.3, is the best fit for my own sensor.

Remarks

The component used in the sensor is only guaranteed to be accurate to +/- 10%.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double scalíng
Visual Basic
Public scalíng As Double
Visual C++
public:
double scalíng

See Also

HiTechnicAccelerationSensor Class


HiTechnicAccelerationSensor Methods

[image] [image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor Methods
HiTechnicAccelerationSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The HiTechnicAccelerationSensor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Poll the sensor (Inherited from NxtSensor.)
Public method | ReadProductId | Returns the name of the manufacturer, e.g. "LEGO". (Inherited from NxtDigitalSensor.)
Public method | ReadSensorType | Returns the sensor type, e.g. "Sonar". (Inherited from NxtDigitalSensor.)
Public method | ReadVersion | Returns the version of the sensor. (Inherited from NxtDigitalSensor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | XAxisAcceleration | Acceleration coordinate of the X-axis.
Public method | XAxisLower2Bits | X axis lower 2 bits
Public method | XAxisUpper8Bits | X axis upper 8 bits
Public method | YAxisAcceleration | Acceleration coordinate of the Y-axis.
Public method | YAxisLower2Bits | Y axis lower 2 bits
Public method | YAxisUpper8Bits | Y axis upper 8 bits
Public method | ZAxisAcceleration | Acceleration coordinate of the Z-axis.
Public method | ZAxisLower2Bits | Z axis lower 2 bits
Public method | ZAxisUpper8Bits | Z axis upper 8 bits

See Also

HiTechnicAccelerationSensor Class


XAxisAcceleration Method

[image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor..::..XAxisAcceleration Method
HiTechnicAccelerationSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Acceleration coordinate of the X-axis.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<double> XAxisAcceleration()
Visual Basic
Public Function XAxisAcceleration As Nullable(Of Double)
Visual C++
public:
Nullable<double> XAxisAcceleration()

Return Value

The acceleration coordinate

See Also

HiTechnicAccelerationSensor Class


XAxisLower2Bits Method

[image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor..::..XAxisLower2Bits Method
HiTechnicAccelerationSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

X axis lower 2 bits

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> XAxisLower2Bits()
Visual Basic
Public Function XAxisLower2Bits As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> XAxisLower2Bits()

Return Value

The lower 2 bits of the X-component of the acceleration vector

Remarks

Should only be used if the full precision is needed.

See Also

HiTechnicAccelerationSensor Class
NKH.MindSqualls Namespace
HiTechnicAccelerationSensor..::..XAxisUpper8Bits()()()()


XAxisUpper8Bits Method

[image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor..::..XAxisUpper8Bits Method
HiTechnicAccelerationSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

X axis upper 8 bits

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<sbyte> XAxisUpper8Bits()
Visual Basic
Public Function XAxisUpper8Bits As Nullable(Of SByte)
Visual C++
public:
Nullable<signed char> XAxisUpper8Bits()

Return Value

The X-component of the acceleration vector

See Also

HiTechnicAccelerationSensor Class
NKH.MindSqualls Namespace
HiTechnicAccelerationSensor..::..YAxisUpper8Bits()()()()
HiTechnicAccelerationSensor..::..ZAxisUpper8Bits()()()()
HiTechnicAccelerationSensor..::..XAxisLower2Bits()()()()


YAxisAcceleration Method

[image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor..::..YAxisAcceleration Method
HiTechnicAccelerationSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Acceleration coordinate of the Y-axis.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<double> YAxisAcceleration()
Visual Basic
Public Function YAxisAcceleration As Nullable(Of Double)
Visual C++
public:
Nullable<double> YAxisAcceleration()

Return Value

The acceleration coordinate

See Also

HiTechnicAccelerationSensor Class


YAxisLower2Bits Method

[image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor..::..YAxisLower2Bits Method
HiTechnicAccelerationSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Y axis lower 2 bits

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> YAxisLower2Bits()
Visual Basic
Public Function YAxisLower2Bits As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> YAxisLower2Bits()

Return Value

The lower 2 bits of the Y-component of the acceleration vector

Remarks

Should only be used if the full precision is needed.

See Also

HiTechnicAccelerationSensor Class
NKH.MindSqualls Namespace
HiTechnicAccelerationSensor..::..YAxisUpper8Bits()()()()


YAxisUpper8Bits Method

[image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor..::..YAxisUpper8Bits Method
HiTechnicAccelerationSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Y axis upper 8 bits

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<sbyte> YAxisUpper8Bits()
Visual Basic
Public Function YAxisUpper8Bits As Nullable(Of SByte)
Visual C++
public:
Nullable<signed char> YAxisUpper8Bits()

Return Value

The Y-component of the acceleration vector

See Also

HiTechnicAccelerationSensor Class
NKH.MindSqualls Namespace
HiTechnicAccelerationSensor..::..XAxisUpper8Bits()()()()
HiTechnicAccelerationSensor..::..ZAxisUpper8Bits()()()()
HiTechnicAccelerationSensor..::..YAxisLower2Bits()()()()


ZAxisAcceleration Method

[image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor..::..ZAxisAcceleration Method
HiTechnicAccelerationSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Acceleration coordinate of the Z-axis.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<double> ZAxisAcceleration()
Visual Basic
Public Function ZAxisAcceleration As Nullable(Of Double)
Visual C++
public:
Nullable<double> ZAxisAcceleration()

Return Value

The acceleration coordinate

See Also

HiTechnicAccelerationSensor Class


ZAxisLower2Bits Method

[image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor..::..ZAxisLower2Bits Method
HiTechnicAccelerationSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Z axis lower 2 bits

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> ZAxisLower2Bits()
Visual Basic
Public Function ZAxisLower2Bits As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> ZAxisLower2Bits()

Return Value

The lower 2 bits of the Z-component of the acceleration vector

Remarks

Should only be used if the full precision is needed.

See Also

HiTechnicAccelerationSensor Class
NKH.MindSqualls Namespace
HiTechnicAccelerationSensor..::..ZAxisUpper8Bits()()()()


ZAxisUpper8Bits Method

[image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor..::..ZAxisUpper8Bits Method
HiTechnicAccelerationSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Z axis upper 8 bits

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<sbyte> ZAxisUpper8Bits()
Visual Basic
Public Function ZAxisUpper8Bits As Nullable(Of SByte)
Visual C++
public:
Nullable<signed char> ZAxisUpper8Bits()

Return Value

The Z-component of the acceleration vector

See Also

HiTechnicAccelerationSensor Class
NKH.MindSqualls Namespace
HiTechnicAccelerationSensor..::..XAxisUpper8Bits()()()()
HiTechnicAccelerationSensor..::..YAxisUpper8Bits()()()()
HiTechnicAccelerationSensor..::..ZAxisLower2Bits()()()()


HiTechnicAccelerationSensor Properties

[image] [image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor Properties
HiTechnicAccelerationSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The HiTechnicAccelerationSensor type exposes the following members.

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

See Also

HiTechnicAccelerationSensor Class


HiTechnicAccelerationSensor Events

[image] [image]

MindSqualls v2.0 documentation
HiTechnicAccelerationSensor Events
HiTechnicAccelerationSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The HiTechnicAccelerationSensor type exposes the following members.

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

HiTechnicAccelerationSensor Class


HiTechnicColorSensor Class

[image]

MindSqualls v2.0 documentation
HiTechnicColorSensor Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Class representing the Color sensor from HiTechnic: http://www.hitechnic.com

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class HiTechnicColorSensor : NxtDigitalSensor
Visual Basic
Public Class HiTechnicColorSensor _
    Inherits NxtDigitalSensor
Visual C++
public ref class HiTechnicColorSensor : public NxtDigitalSensor

Remarks

The HiTechnic color sensor should not be confused with the NXT 2.0 color sensor.

A special thanks to the people at HiTechnic for providing me with the necessary technical information.

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtPollable
NKH.MindSqualls..::..NxtSensor
NKH.MindSqualls..::..NxtDigitalSensor
NKH.MindSqualls..::..HiTechnicColorSensor

See Also

HiTechnicColorSensor Members
NKH.MindSqualls Namespace
NKH.MindSqualls..::..Nxt2ColorSensor


HiTechnicColorSensor Members

[image] [image]

MindSqualls v2.0 documentation
HiTechnicColorSensor Members
HiTechnicColorSensor Class Constructors Methods Fields Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The HiTechnicColorSensor type exposes the following members.

Constructors

 | Name | Description
Public method | HiTechnicColorSensor | Constructor.

Methods

 | Name | Description
Public method | BlueReading | Returns the current detection level for the color blue.
Public method | ColorIndexNumber | Returns a single 6 bit number color index. Bits 5 and 4 encode the red signal level, bits 3 and 2 encode the green signal level and bits 1 and 0 encode the blue signal levels.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GreenReading | Returns the current detection level for the color green.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NormalizedBlueReading | Return the current relative level for the blue color component.
Public method | NormalizedGreenReading | Return the current relative level for the green color component.
Public method | NormalizedRedReading | Return the current relative level for the red color component.
Public method | Poll | Poll the sensor (Inherited from NxtSensor.)
Public method | RawBlueSensorReading | Returns the current sensor analog signal level for the color blue.
Public method | RawGreenSensorReading | Returns the current sensor analog signal level for the color green.
Public method | RawRedSensorReading | Returns the current sensor analog signal level for the color red.
Public method | ReadProductId | Returns the name of the manufacturer, e.g. "LEGO". (Inherited from NxtDigitalSensor.)
Public method | ReadSensorType | Returns the sensor type, e.g. "Sonar". (Inherited from NxtDigitalSensor.)
Public method | ReadVersion | Returns the version of the sensor. (Inherited from NxtDigitalSensor.)
Public method | RedReading | Returns the current detection level for the color red.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

Properties

 | Name | Description
Public property | ColorNumber | Returns a single number color estimate.
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

HiTechnicColorSensor Class


HiTechnicColorSensor Constructor

[image]

MindSqualls v2.0 documentation
HiTechnicColorSensor Constructor
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public HiTechnicColorSensor()
Visual Basic
Public Sub New
Visual C++
public:
HiTechnicColorSensor()

See Also

HiTechnicColorSensor Class


HiTechnicColorSensor Fields

[image] [image]

MindSqualls v2.0 documentation
HiTechnicColorSensor Fields
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The HiTechnicColorSensor type exposes the following members.

Fields

 | Name | Description
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

See Also

HiTechnicColorSensor Class


HiTechnicColorSensor Methods

[image] [image]

MindSqualls v2.0 documentation
HiTechnicColorSensor Methods
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The HiTechnicColorSensor type exposes the following members.

Methods

 | Name | Description
Public method | BlueReading | Returns the current detection level for the color blue.
Public method | ColorIndexNumber | Returns a single 6 bit number color index. Bits 5 and 4 encode the red signal level, bits 3 and 2 encode the green signal level and bits 1 and 0 encode the blue signal levels.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GreenReading | Returns the current detection level for the color green.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NormalizedBlueReading | Return the current relative level for the blue color component.
Public method | NormalizedGreenReading | Return the current relative level for the green color component.
Public method | NormalizedRedReading | Return the current relative level for the red color component.
Public method | Poll | Poll the sensor (Inherited from NxtSensor.)
Public method | RawBlueSensorReading | Returns the current sensor analog signal level for the color blue.
Public method | RawGreenSensorReading | Returns the current sensor analog signal level for the color green.
Public method | RawRedSensorReading | Returns the current sensor analog signal level for the color red.
Public method | ReadProductId | Returns the name of the manufacturer, e.g. "LEGO". (Inherited from NxtDigitalSensor.)
Public method | ReadSensorType | Returns the sensor type, e.g. "Sonar". (Inherited from NxtDigitalSensor.)
Public method | ReadVersion | Returns the version of the sensor. (Inherited from NxtDigitalSensor.)
Public method | RedReading | Returns the current detection level for the color red.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HiTechnicColorSensor Class


BlueReading Method

[image]

MindSqualls v2.0 documentation
HiTechnicColorSensor..::..BlueReading Method
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the current detection level for the color blue.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> BlueReading()
Visual Basic
Public Function BlueReading As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> BlueReading()

Return Value

... TBD ...

See Also

HiTechnicColorSensor Class


ColorIndexNumber Method

[image]

MindSqualls v2.0 documentation
HiTechnicColorSensor..::..ColorIndexNumber Method
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns a single 6 bit number color index. Bits 5 and 4 encode the red signal level, bits 3 and 2 encode the green signal level and bits 1 and 0 encode the blue signal levels.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> ColorIndexNumber()
Visual Basic
Public Function ColorIndexNumber As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> ColorIndexNumber()

Return Value

... TBD ...

See Also

HiTechnicColorSensor Class


GreenReading Method

[image]

MindSqualls v2.0 documentation
HiTechnicColorSensor..::..GreenReading Method
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the current detection level for the color green.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> GreenReading()
Visual Basic
Public Function GreenReading As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> GreenReading()

Return Value

... TBD ...

See Also

HiTechnicColorSensor Class


NormalizedBlueReading Method

[image]

MindSqualls v2.0 documentation
HiTechnicColorSensor..::..NormalizedBlueReading Method
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Return the current relative level for the blue color component.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> NormalizedBlueReading()
Visual Basic
Public Function NormalizedBlueReading As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> NormalizedBlueReading()

Return Value

... TBD ...

Remarks

The normalization sets the highest value of the three red, green and blue reading to 255 and adjusts the other two proportionately.

See Also

HiTechnicColorSensor Class


NormalizedGreenReading Method

[image]

MindSqualls v2.0 documentation
HiTechnicColorSensor..::..NormalizedGreenReading Method
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Return the current relative level for the green color component.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> NormalizedGreenReading()
Visual Basic
Public Function NormalizedGreenReading As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> NormalizedGreenReading()

Return Value

... TBD ...

Remarks

The normalization sets the highest value of the three red, green and blue reading to 255 and adjusts the other two proportionately.

See Also

HiTechnicColorSensor Class


NormalizedRedReading Method

[image]

MindSqualls v2.0 documentation
HiTechnicColorSensor..::..NormalizedRedReading Method
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Return the current relative level for the red color component.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> NormalizedRedReading()
Visual Basic
Public Function NormalizedRedReading As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> NormalizedRedReading()

Return Value

... TBD ...

Remarks

The normalization sets the highest value of the three red, green and blue reading to 255 and adjusts the other two proportionately.

See Also

HiTechnicColorSensor Class


RawBlueSensorReading Method

[image]

MindSqualls v2.0 documentation
HiTechnicColorSensor..::..RawBlueSensorReading Method
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the current sensor analog signal level for the color blue.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<ushort> RawBlueSensorReading()
Visual Basic
Public Function RawBlueSensorReading As Nullable(Of UShort)
Visual C++
public:
Nullable<unsigned short> RawBlueSensorReading()

Return Value

... TBD ...

See Also

HiTechnicColorSensor Class


RawGreenSensorReading Method

[image]

MindSqualls v2.0 documentation
HiTechnicColorSensor..::..RawGreenSensorReading Method
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the current sensor analog signal level for the color green.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<ushort> RawGreenSensorReading()
Visual Basic
Public Function RawGreenSensorReading As Nullable(Of UShort)
Visual C++
public:
Nullable<unsigned short> RawGreenSensorReading()

Return Value

... TBD ...

See Also

HiTechnicColorSensor Class


RawRedSensorReading Method

[image]

MindSqualls v2.0 documentation
HiTechnicColorSensor..::..RawRedSensorReading Method
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the current sensor analog signal level for the color red.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<ushort> RawRedSensorReading()
Visual Basic
Public Function RawRedSensorReading As Nullable(Of UShort)
Visual C++
public:
Nullable<unsigned short> RawRedSensorReading()

Return Value

... TBD ...

See Also

HiTechnicColorSensor Class


RedReading Method

[image]

MindSqualls v2.0 documentation
HiTechnicColorSensor..::..RedReading Method
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the current detection level for the color red.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> RedReading()
Visual Basic
Public Function RedReading As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> RedReading()

Return Value

... TBD ...

See Also

HiTechnicColorSensor Class


HiTechnicColorSensor Properties

[image] [image]

MindSqualls v2.0 documentation
HiTechnicColorSensor Properties
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The HiTechnicColorSensor type exposes the following members.

Properties

 | Name | Description
Public property | ColorNumber | Returns a single number color estimate.
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

See Also

HiTechnicColorSensor Class


ColorNumber Property

[image]

MindSqualls v2.0 documentation
HiTechnicColorSensor..::..ColorNumber Property
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns a single number color estimate.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> ColorNumber { get; }
Visual Basic
Public ReadOnly Property ColorNumber As Nullable(Of Byte)
    Get
Visual C++
public:
property Nullable<unsigned char> ColorNumber {
    Nullable<unsigned char> get ();
}

See Also

HiTechnicColorSensor Class


HiTechnicColorSensor Events

[image] [image]

MindSqualls v2.0 documentation
HiTechnicColorSensor Events
HiTechnicColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The HiTechnicColorSensor type exposes the following members.

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

HiTechnicColorSensor Class


HiTechnicCompassSensor Class

[image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Class representing the Compass sensor from HiTechnic: http://www.hitechnic.com

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class HiTechnicCompassSensor : NxtDigitalSensor
Visual Basic
Public Class HiTechnicCompassSensor _
    Inherits NxtDigitalSensor
Visual C++
public ref class HiTechnicCompassSensor : public NxtDigitalSensor

Remarks

A special thanks to the people at HiTechnic for providing me with the necessary technical information.

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtPollable
NKH.MindSqualls..::..NxtSensor
NKH.MindSqualls..::..NxtDigitalSensor
NKH.MindSqualls..::..HiTechnicCompassSensor

See Also

HiTechnicCompassSensor Members


HiTechnicCompassSensor Members

[image] [image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor Members
HiTechnicCompassSensor Class Constructors Methods Fields Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The HiTechnicCompassSensor type exposes the following members.

Constructors

 | Name | Description
Public method | HiTechnicCompassSensor | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ModeControl | Returns the current value of the mode control of the sensor.
Public method | OneDegreeAdder | Returns an 1-degree adder to use with the TwoDegreeHeading()-method.
Public method | Poll | Polls the sensor, and fires the NXT-G like events if appropriate. (Overrides NxtSensor..::..Poll()()()().)
Public method | ReadProductId | Returns the name of the manufacturer, e.g. "LEGO". (Inherited from NxtDigitalSensor.)
Public method | ReadSensorType | Returns the sensor type, e.g. "Sonar". (Inherited from NxtDigitalSensor.)
Public method | ReadVersion | Returns the version of the sensor. (Inherited from NxtDigitalSensor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TwoDegreeHeading | Returns the current heading to a 2-degree accuracy.

Fields

 | Name | Description
Protected field | pollData | The data from the previous poll of the sensor.
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

Properties

 | Name | Description
Public property | Heading | Heading
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)
Public property | RangeA | Lower boundary of the Range-interval.
Public property | RangeB | Upper boundary of the Range-interval.

Events

 | Name | Description
Public event | OnInsideRange | This event is fired when the Heading passes inside the Range-interval.
Public event | OnOutsideRange | This event is fired when the Heading passes outside the Range-interval.
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

HiTechnicCompassSensor Class


HiTechnicCompassSensor Constructor

[image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor Constructor
HiTechnicCompassSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public HiTechnicCompassSensor()
Visual Basic
Public Sub New
Visual C++
public:
HiTechnicCompassSensor()

See Also

HiTechnicCompassSensor Class


HiTechnicCompassSensor Fields

[image] [image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor Fields
HiTechnicCompassSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The HiTechnicCompassSensor type exposes the following members.

Fields

 | Name | Description
Protected field | pollData | The data from the previous poll of the sensor.
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

See Also

HiTechnicCompassSensor Class


pollData Field

[image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor..::..pollData Field
HiTechnicCompassSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The data from the previous poll of the sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected Nullable<byte> pollData
Visual Basic
Protected pollData As Nullable(Of Byte)
Visual C++
protected:
Nullable<unsigned char> pollData

See Also

HiTechnicCompassSensor Class
NKH.MindSqualls Namespace
HiTechnicCompassSensor..::..Poll()()()()


HiTechnicCompassSensor Methods

[image] [image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor Methods
HiTechnicCompassSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The HiTechnicCompassSensor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ModeControl | Returns the current value of the mode control of the sensor.
Public method | OneDegreeAdder | Returns an 1-degree adder to use with the TwoDegreeHeading()-method.
Public method | Poll | Polls the sensor, and fires the NXT-G like events if appropriate. (Overrides NxtSensor..::..Poll()()()().)
Public method | ReadProductId | Returns the name of the manufacturer, e.g. "LEGO". (Inherited from NxtDigitalSensor.)
Public method | ReadSensorType | Returns the sensor type, e.g. "Sonar". (Inherited from NxtDigitalSensor.)
Public method | ReadVersion | Returns the version of the sensor. (Inherited from NxtDigitalSensor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TwoDegreeHeading | Returns the current heading to a 2-degree accuracy.

See Also

HiTechnicCompassSensor Class


ModeControl Method

[image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor..::..ModeControl Method
HiTechnicCompassSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the current value of the mode control of the sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> ModeControl()
Visual Basic
Public Function ModeControl As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> ModeControl()

Return Value

The value of the mode control

See Also

HiTechnicCompassSensor Class


OneDegreeAdder Method

[image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor..::..OneDegreeAdder Method
HiTechnicCompassSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns an 1-degree adder to use with the TwoDegreeHeading()-method.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> OneDegreeAdder()
Visual Basic
Public Function OneDegreeAdder As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> OneDegreeAdder()

Return Value

The adder

See Also

HiTechnicCompassSensor Class


Poll Method

[image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor..::..Poll Method
HiTechnicCompassSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Polls the sensor, and fires the NXT-G like events if appropriate.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Poll()
Visual Basic
Public Overrides Sub Poll
Visual C++
public:
virtual void Poll() override

See Also

HiTechnicCompassSensor Class
NKH.MindSqualls Namespace
HiTechnicCompassSensor..::..RangeA
HiTechnicCompassSensor..::..RangeB
HiTechnicCompassSensor..::..OnInsideRange
HiTechnicCompassSensor..::..OnOutsideRange


TwoDegreeHeading Method

[image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor..::..TwoDegreeHeading Method
HiTechnicCompassSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the current heading to a 2-degree accuracy.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> TwoDegreeHeading()
Visual Basic
Public Function TwoDegreeHeading As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> TwoDegreeHeading()

Return Value

The heading

See Also

HiTechnicCompassSensor Class


HiTechnicCompassSensor Properties

[image] [image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor Properties
HiTechnicCompassSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The HiTechnicCompassSensor type exposes the following members.

Properties

 | Name | Description
Public property | Heading | Heading
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)
Public property | RangeA | Lower boundary of the Range-interval.
Public property | RangeB | Upper boundary of the Range-interval.

See Also

HiTechnicCompassSensor Class


Heading Property

[image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor..::..Heading Property
HiTechnicCompassSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Heading

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<ushort> Heading { get; }
Visual Basic
Public ReadOnly Property Heading As Nullable(Of UShort)
    Get
Visual C++
public:
property Nullable<unsigned short> Heading {
    Nullable<unsigned short> get ();
}

Return Value

See Also

HiTechnicCompassSensor Class


RangeA Property

[image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor..::..RangeA Property
HiTechnicCompassSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Lower boundary of the Range-interval.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ushort RangeA { get; set; }
Visual Basic
Public Property RangeA As UShort
    Get
    Set
Visual C++
public:
property unsigned short RangeA {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

HiTechnicCompassSensor Class
NKH.MindSqualls Namespace
HiTechnicCompassSensor..::..RangeB
HiTechnicCompassSensor..::..OnInsideRange
HiTechnicCompassSensor..::..OnOutsideRange
HiTechnicCompassSensor..::..Poll()()()()


RangeB Property

[image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor..::..RangeB Property
HiTechnicCompassSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Upper boundary of the Range-interval.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ushort RangeB { get; set; }
Visual Basic
Public Property RangeB As UShort
    Get
    Set
Visual C++
public:
property unsigned short RangeB {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

HiTechnicCompassSensor Class
NKH.MindSqualls Namespace
HiTechnicCompassSensor..::..RangeA
HiTechnicCompassSensor..::..OnInsideRange
HiTechnicCompassSensor..::..OnOutsideRange
HiTechnicCompassSensor..::..Poll()()()()


HiTechnicCompassSensor Events

[image] [image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor Events
HiTechnicCompassSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The HiTechnicCompassSensor type exposes the following members.

Events

 | Name | Description
Public event | OnInsideRange | This event is fired when the Heading passes inside the Range-interval.
Public event | OnOutsideRange | This event is fired when the Heading passes outside the Range-interval.
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

HiTechnicCompassSensor Class


OnInsideRange Event

[image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor..::..OnInsideRange Event
HiTechnicCompassSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired when the Heading passes inside the Range-interval.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event NxtSensorEvent OnInsideRange
Visual Basic
Public Event OnInsideRange As NxtSensorEvent
Visual C++
public:
 event NxtSensorEvent^ OnInsideRange {
    void add (NxtSensorEvent^ value);
    void remove (NxtSensorEvent^ value);
}

See Also

HiTechnicCompassSensor Class
NKH.MindSqualls Namespace
HiTechnicCompassSensor..::..RangeA
HiTechnicCompassSensor..::..RangeB
HiTechnicCompassSensor..::..OnOutsideRange
HiTechnicCompassSensor..::..Poll()()()()


OnOutsideRange Event

[image]

MindSqualls v2.0 documentation
HiTechnicCompassSensor..::..OnOutsideRange Event
HiTechnicCompassSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired when the Heading passes outside the Range-interval.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event NxtSensorEvent OnOutsideRange
Visual Basic
Public Event OnOutsideRange As NxtSensorEvent
Visual C++
public:
 event NxtSensorEvent^ OnOutsideRange {
    void add (NxtSensorEvent^ value);
    void remove (NxtSensorEvent^ value);
}

See Also

HiTechnicCompassSensor Class
NKH.MindSqualls Namespace
HiTechnicCompassSensor..::..RangeA
HiTechnicCompassSensor..::..RangeB
HiTechnicCompassSensor..::..OnInsideRange
HiTechnicCompassSensor..::..Poll()()()()


Nxt2Color Enumeration

[image]

MindSqualls v2.0 documentation
Nxt2Color Enumeration
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Color-values for the NXT 2.0 Color sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum Nxt2Color
Visual Basic
Public Enumeration Nxt2Color
Visual C++
public enum class Nxt2Color

Members

Member name | Value | Description
Black | 1 | Black
Blue | 2 | Blue
Green | 3 | Green
Yellow | 4 | Yellow
Red | 5 | Red
White | 6 | White

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


Nxt2ColorSensor Class

[image]

MindSqualls v2.0 documentation
Nxt2ColorSensor Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Class representing the NXT 2.0 color sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class Nxt2ColorSensor : NxtPassiveSensor
Visual Basic
Public Class Nxt2ColorSensor _
    Inherits NxtPassiveSensor
Visual C++
public ref class Nxt2ColorSensor : public NxtPassiveSensor

Remarks

The color sensor has two modes; it can act as a color detector and as a light sensor. In the last capacity it can be seen as a replacement for the NXT light sensor. The sensor can also act as a lamp.

The NXT 2.0 color sensor should not be confused with the HiTechnic color sensor.

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtPollable
NKH.MindSqualls..::..NxtSensor
NKH.MindSqualls..::..NxtPassiveSensor
NKH.MindSqualls..::..Nxt2ColorSensor

See Also

Nxt2ColorSensor Members
NKH.MindSqualls Namespace
NKH.MindSqualls..::..NxtLightSensor
NKH.MindSqualls..::..HiTechnicColorSensor


Nxt2ColorSensor Members

[image] [image]

MindSqualls v2.0 documentation
Nxt2ColorSensor Members
Nxt2ColorSensor Class Constructors Methods Fields Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The Nxt2ColorSensor type exposes the following members.

Constructors

 | Name | Description
Public method | Nxt2ColorSensor | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Polls the sensor, and fires the NXT-G like events if appropriate. (Overrides NxtPassiveSensor..::..Poll()()()().)
Public method | SetColorDetectorMode | Switches the sensor into color detector mode.
Public method | SetColorRange | Sets the minimum and the maximum of the color range.
Public method | SetLightSensorMode | Switches the sensor into light sensor mode.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | pollData | The data from the last poll of the sensor. (Inherited from NxtPassiveSensor.)
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

Properties

 | Name | Description
Public property | Color | Returns the color when the sensor is in color detector mode.
Public property | Intensity | Returns the light intensity when the sensor is in light detector mode.
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)
Public property | SensorMode | Returns the current mode of the sensor; color detector or light sensor mode.
Public property | TriggerIntensity | Trigger intensity.

Events

 | Name | Description
Public event | OnAboveIntensity | This event is fired whenever the measured light intensity passes above the trigger-intensity.
Public event | OnInsideRange | This event is fired whenever the detected color passes from outside of the color-range to inside.
Public event | OnOutsideRange | This event is fired whenever the detected color passes from inside of the color-range to outside.
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

Nxt2ColorSensor Class


Nxt2ColorSensor Constructor

[image]

MindSqualls v2.0 documentation
Nxt2ColorSensor Constructor
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nxt2ColorSensor()
Visual Basic
Public Sub New
Visual C++
public:
Nxt2ColorSensor()

See Also

Nxt2ColorSensor Class


Nxt2ColorSensor Fields

[image] [image]

MindSqualls v2.0 documentation
Nxt2ColorSensor Fields
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The Nxt2ColorSensor type exposes the following members.

Fields

 | Name | Description
Protected field | pollData | The data from the last poll of the sensor. (Inherited from NxtPassiveSensor.)
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

See Also

Nxt2ColorSensor Class


Nxt2ColorSensor Methods

[image] [image]

MindSqualls v2.0 documentation
Nxt2ColorSensor Methods
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The Nxt2ColorSensor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Polls the sensor, and fires the NXT-G like events if appropriate. (Overrides NxtPassiveSensor..::..Poll()()()().)
Public method | SetColorDetectorMode | Switches the sensor into color detector mode.
Public method | SetColorRange | Sets the minimum and the maximum of the color range.
Public method | SetLightSensorMode | Switches the sensor into light sensor mode.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Nxt2ColorSensor Class


Poll Method

[image]

MindSqualls v2.0 documentation
Nxt2ColorSensor..::..Poll Method
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Polls the sensor, and fires the NXT-G like events if appropriate.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Poll()
Visual Basic
Public Overrides Sub Poll
Visual C++
public:
virtual void Poll() override

See Also

Nxt2ColorSensor Class
NKH.MindSqualls Namespace
Nxt2ColorSensor..::..SetColorRange(Nxt2Color, Nxt2Color)
Nxt2ColorSensor..::..OnInsideRange
Nxt2ColorSensor..::..OnOutsideRange


SetColorDetectorMode Method

[image]

MindSqualls v2.0 documentation
Nxt2ColorSensor..::..SetColorDetectorMode Method
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Switches the sensor into color detector mode.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetColorDetectorMode()
Visual Basic
Public Sub SetColorDetectorMode
Visual C++
public:
void SetColorDetectorMode()

See Also

Nxt2ColorSensor Class


SetColorRange Method

[image]

MindSqualls v2.0 documentation
Nxt2ColorSensor..::..SetColorRange Method
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Sets the minimum and the maximum of the color range.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetColorRange(
    Nxt2Color minRange,
    Nxt2Color maxRange
)
Visual Basic
Public Sub SetColorRange ( _
    minRange As Nxt2Color, _
    maxRange As Nxt2Color _
)
Visual C++
public:
void SetColorRange(
    Nxt2Color minRange,
    Nxt2Color maxRange
)

Parameters

minRange
Type: NKH.MindSqualls..::..Nxt2Color
Minimum
maxRange
Type: NKH.MindSqualls..::..Nxt2Color
Maximum

See Also

Nxt2ColorSensor Class
NKH.MindSqualls Namespace
Nxt2ColorSensor..::..OnInsideRange
Nxt2ColorSensor..::..OnOutsideRange


SetLightSensorMode Method

[image]

MindSqualls v2.0 documentation
Nxt2ColorSensor..::..SetLightSensorMode Method
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Switches the sensor into light sensor mode.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetLightSensorMode(
    Nullable<Nxt2Color> color
)
Visual Basic
Public Sub SetLightSensorMode ( _
    color As Nullable(Of Nxt2Color) _
)
Visual C++
public:
void SetLightSensorMode(
    Nullable<Nxt2Color> color
)

Parameters

color
Type: System..::..Nullable <(Of <(<' Nxt2Color >)>)>
The floodlight color. The sensor will accept red, green and blue, or black and null for no floodlights.

See Also

Nxt2ColorSensor Class


Nxt2ColorSensor Properties

[image] [image]

MindSqualls v2.0 documentation
Nxt2ColorSensor Properties
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The Nxt2ColorSensor type exposes the following members.

Properties

 | Name | Description
Public property | Color | Returns the color when the sensor is in color detector mode.
Public property | Intensity | Returns the light intensity when the sensor is in light detector mode.
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)
Public property | SensorMode | Returns the current mode of the sensor; color detector or light sensor mode.
Public property | TriggerIntensity | Trigger intensity.

See Also

Nxt2ColorSensor Class


Color Property

[image]

MindSqualls v2.0 documentation
Nxt2ColorSensor..::..Color Property
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the color when the sensor is in color detector mode.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<Nxt2Color> Color { get; }
Visual Basic
Public ReadOnly Property Color As Nullable(Of Nxt2Color)
    Get
Visual C++
public:
property Nullable<Nxt2Color> Color {
    Nullable<Nxt2Color> get ();
}

See Also

Nxt2ColorSensor Class


Intensity Property

[image]

MindSqualls v2.0 documentation
Nxt2ColorSensor..::..Intensity Property
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the light intensity when the sensor is in light detector mode.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> Intensity { get; }
Visual Basic
Public ReadOnly Property Intensity As Nullable(Of Byte)
    Get
Visual C++
public:
property Nullable<unsigned char> Intensity {
    Nullable<unsigned char> get ();
}

See Also

Nxt2ColorSensor Class


SensorMode Property

[image]

MindSqualls v2.0 documentation
Nxt2ColorSensor..::..SensorMode Property
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the current mode of the sensor; color detector or light sensor mode.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nxt2ColorSensorMode SensorMode { get; }
Visual Basic
Public ReadOnly Property SensorMode As Nxt2ColorSensorMode
    Get
Visual C++
public:
property Nxt2ColorSensorMode SensorMode {
    Nxt2ColorSensorMode get ();
}

See Also

Nxt2ColorSensor Class


TriggerIntensity Property

[image]

MindSqualls v2.0 documentation
Nxt2ColorSensor..::..TriggerIntensity Property
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Trigger intensity.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte TriggerIntensity { get; set; }
Visual Basic
Public Property TriggerIntensity As Byte
    Get
    Set
Visual C++
public:
property unsigned char TriggerIntensity {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Nxt2ColorSensor Class
NKH.MindSqualls Namespace
Nxt2ColorSensor..::..OnAboveIntensity


Nxt2ColorSensor Events

[image] [image]

MindSqualls v2.0 documentation
Nxt2ColorSensor Events
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The Nxt2ColorSensor type exposes the following members.

Events

 | Name | Description
Public event | OnAboveIntensity | This event is fired whenever the measured light intensity passes above the trigger-intensity.
Public event | OnInsideRange | This event is fired whenever the detected color passes from outside of the color-range to inside.
Public event | OnOutsideRange | This event is fired whenever the detected color passes from inside of the color-range to outside.
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

Nxt2ColorSensor Class


OnAboveIntensity Event

[image]

MindSqualls v2.0 documentation
Nxt2ColorSensor..::..OnAboveIntensity Event
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired whenever the measured light intensity passes above the trigger-intensity.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event NxtSensorEvent OnAboveIntensity
Visual Basic
Public Event OnAboveIntensity As NxtSensorEvent
Visual C++
public:
 event NxtSensorEvent^ OnAboveIntensity {
    void add (NxtSensorEvent^ value);
    void remove (NxtSensorEvent^ value);
}

Remarks

The detector must be in light sensor mode for the event to fire.

See Also

Nxt2ColorSensor Class
NKH.MindSqualls Namespace
Nxt2ColorSensor..::..TriggerIntensity


OnInsideRange Event

[image]

MindSqualls v2.0 documentation
Nxt2ColorSensor..::..OnInsideRange Event
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired whenever the detected color passes from outside of the color-range to inside.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event NxtSensorEvent OnInsideRange
Visual Basic
Public Event OnInsideRange As NxtSensorEvent
Visual C++
public:
 event NxtSensorEvent^ OnInsideRange {
    void add (NxtSensorEvent^ value);
    void remove (NxtSensorEvent^ value);
}

Remarks

The detector must be in color detector mode for the event to fire.

See Also

Nxt2ColorSensor Class
NKH.MindSqualls Namespace
Nxt2ColorSensor..::..SetColorRange(Nxt2Color, Nxt2Color)
Nxt2ColorSensor..::..OnOutsideRange


OnOutsideRange Event

[image]

MindSqualls v2.0 documentation
Nxt2ColorSensor..::..OnOutsideRange Event
Nxt2ColorSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired whenever the detected color passes from inside of the color-range to outside.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event NxtSensorEvent OnOutsideRange
Visual Basic
Public Event OnOutsideRange As NxtSensorEvent
Visual C++
public:
 event NxtSensorEvent^ OnOutsideRange {
    void add (NxtSensorEvent^ value);
    void remove (NxtSensorEvent^ value);
}

Remarks

The detector must be in color detector mode for the event to fire.

See Also

Nxt2ColorSensor Class
NKH.MindSqualls Namespace
Nxt2ColorSensor..::..SetColorRange(Nxt2Color, Nxt2Color)
Nxt2ColorSensor..::..OnInsideRange


Nxt2ColorSensorMode Enumeration

[image]

MindSqualls v2.0 documentation
Nxt2ColorSensorMode Enumeration
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Sensor-modes for the NXT 2.0 color sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum Nxt2ColorSensorMode
Visual Basic
Public Enumeration Nxt2ColorSensorMode
Visual C++
public enum class Nxt2ColorSensorMode

Members

Member name | Value | Description
ColorDetector | 0 | Color detector mode with no light.
LightSensor | 1 | Light sensor mode with or without light.

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


NxtActiveSensor Class

[image]

MindSqualls v2.0 documentation
NxtActiveSensor Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Abstract class representing a Active Sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class NxtActiveSensor : NxtSensor
Visual Basic
Public MustInherit Class NxtActiveSensor _
    Inherits NxtSensor
Visual C++
public ref class NxtActiveSensor abstract : public NxtSensor

Remarks

According to the LEGO MINDSTORMS NXT Hardware Developer Kit p. 7, sensors is divided into three types: active sensors (e.g. Robotics Invention Systems sensors), passive sensors (e.g. the NXT touch, light, and sound sensors), and digital sensors (e.g. the NXT ultrasonic sensor and the HiTechnic compass sensor). The three abstract classes NxtActiveSensor, NxtPassiveSensor, and NxtDigitalSensor reflect this.

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtPollable
NKH.MindSqualls..::..NxtSensor
NKH.MindSqualls..::..NxtActiveSensor

See Also

NxtActiveSensor Members
NKH.MindSqualls Namespace
NKH.MindSqualls..::..NxtPassiveSensor
NKH.MindSqualls..::..NxtDigitalSensor


NxtActiveSensor Members

[image] [image]

MindSqualls v2.0 documentation
NxtActiveSensor Members
NxtActiveSensor Class Constructors Methods Fields Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtActiveSensor type exposes the following members.

Constructors

 | Name | Description
Public method | NxtActiveSensor | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Poll the sensor (Inherited from NxtSensor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtActiveSensor Class


NxtActiveSensor Constructor

[image]

MindSqualls v2.0 documentation
NxtActiveSensor Constructor
NxtActiveSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtActiveSensor(
    NxtSensorType sensorType,
    NxtSensorMode sensorMode
)
Visual Basic
Public Sub New ( _
    sensorType As NxtSensorType, _
    sensorMode As NxtSensorMode _
)
Visual C++
public:
NxtActiveSensor(
    NxtSensorType sensorType,
    NxtSensorMode sensorMode
)

Parameters

sensorType
Type: NKH.MindSqualls..::..NxtSensorType
Sensor type
sensorMode
Type: NKH.MindSqualls..::..NxtSensorMode
Sensor mode

See Also

NxtActiveSensor Class


NxtActiveSensor Fields

[image] [image]

MindSqualls v2.0 documentation
NxtActiveSensor Fields
NxtActiveSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtActiveSensor type exposes the following members.

Fields

 | Name | Description
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

See Also

NxtActiveSensor Class


NxtActiveSensor Methods

[image] [image]

MindSqualls v2.0 documentation
NxtActiveSensor Methods
NxtActiveSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtActiveSensor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Poll the sensor (Inherited from NxtSensor.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NxtActiveSensor Class


NxtActiveSensor Properties

[image] [image]

MindSqualls v2.0 documentation
NxtActiveSensor Properties
NxtActiveSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtActiveSensor type exposes the following members.

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

See Also

NxtActiveSensor Class


NxtActiveSensor Events

[image] [image]

MindSqualls v2.0 documentation
NxtActiveSensor Events
NxtActiveSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtActiveSensor type exposes the following members.

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtActiveSensor Class


NxtBluetoothConnection Class

[image]

MindSqualls v2.0 documentation
NxtBluetoothConnection Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Class representation communication over a Bluetooth connection.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class NxtBluetoothConnection : NxtCommunicationProtocol
Visual Basic
Public Class NxtBluetoothConnection _
    Inherits NxtCommunicationProtocol
Visual C++
public ref class NxtBluetoothConnection : public NxtCommunicationProtocol

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtCommunicationProtocol
NKH.MindSqualls..::..NxtBluetoothConnection

See Also

NxtBluetoothConnection Members
NKH.MindSqualls Namespace
NKH.MindSqualls..::..NxtUsbConnection


NxtBluetoothConnection Members

[image] [image]

MindSqualls v2.0 documentation
NxtBluetoothConnection Members
NxtBluetoothConnection Class Constructors Methods Fields Properties See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtBluetoothConnection type exposes the following members.

Constructors

 | Name | Description
Public method | NxtBluetoothConnection(Byte) | Constructor.
Public method | NxtBluetoothConnection(String) | Constructor.

Methods

 | Name | Description
Public method | BluetoothFactoryReset | BLUETOOTH FACTORY RESET COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | Boot | BOOT COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | Close | CLOSE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | CloseModuleHandle | CLOSE MODULE HANDLE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | Connect | Connect to the NXT brick via bluetooth. (Overrides NxtCommunicationProtocol..::..Connect()()()().)
Public method | Delete | DELETE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | DeleteUserFlash | DELETE USER FLASH (Inherited from NxtCommunicationProtocol.)
Public method | Disconnect | Disconnect from the brick. (Overrides NxtCommunicationProtocol..::..Disconnect()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFirst | FIND FIRST (Inherited from NxtCommunicationProtocol.)
Public method | FindNext | FIND NEXT (Inherited from NxtCommunicationProtocol.)
Public method | GetBatteryLevel | GETBATTERYLEVEL (Inherited from NxtCommunicationProtocol.)
Public method | GetCurrentProgramName | GETCURRENTPROGRAMNAME (Inherited from NxtCommunicationProtocol.)
Public method | GetDeviceInfo | GET DEVICE INFO (Inherited from NxtCommunicationProtocol.)
Public method | GetFirmwareVersion | GET FIRMWARE VERSION (Inherited from NxtCommunicationProtocol.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInputValues | GETINPUTVALUES (Inherited from NxtCommunicationProtocol.)
Public method | GetOutputState | GETOUTPUTSTATE (Inherited from NxtCommunicationProtocol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KeepAlive | KEEPALIVE (Inherited from NxtCommunicationProtocol.)
Public method | LsGetStatus | LSGETSTATUS (Inherited from NxtCommunicationProtocol.)
Public method | LsRead | LSREAD (Inherited from NxtCommunicationProtocol.)
Public method | LsWrite | LSWRITE (Inherited from NxtCommunicationProtocol.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MessageRead | MESSAGEREAD (Inherited from NxtCommunicationProtocol.)
Public method | MessageWrite | MESSAGEWRITE (Inherited from NxtCommunicationProtocol.)
Public method | OpenAppendData | OPEN APPEND DATA COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenRead | OPEN READ COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenReadLinear | OPEN READ LINEAR COMMAND (INTERNAL COMMAND) (Inherited from NxtCommunicationProtocol.)
Public method | OpenWrite | OPEN WRITE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenWriteData | OPEN WRITE DATA COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenWriteLinear | OPEN WRITE LINEAR COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | PlaySoundfile | PLAYSOUNDFILE (Inherited from NxtCommunicationProtocol.)
Public method | PlayTone | PLAYTONE (Inherited from NxtCommunicationProtocol.)
Public method | PollCommand | POLL COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | PollCommandLength | POLL COMMAND LENGTH (Inherited from NxtCommunicationProtocol.)
Public method | Read | READ COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | ReadIoMap | READ IO MAP COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | RequestFirstModule | REQUEST FIRST MODULE (Inherited from NxtCommunicationProtocol.)
Public method | RequestNextModule | REQUEST NEXT MODULE (Inherited from NxtCommunicationProtocol.)
Public method | ResetInputScaledValue | RESETINPUTSCALEDVALUE (Inherited from NxtCommunicationProtocol.)
Public method | ResetMotorPosition | RESETMOTORPOSITION (Inherited from NxtCommunicationProtocol.)
Protected method | Send | Sends a request for the NXT brick, and if applicable, receive the reply. (Overrides NxtCommunicationProtocol..::..Send(array<Byte>[]()[][]).)
Public method | SetBrickName | SET BRICK NAME COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | SetInputMode | SETINPUTMODE (Inherited from NxtCommunicationProtocol.)
Public method | SetOutputState | SETOUTPUTSTATE (Inherited from NxtCommunicationProtocol.)
Public method | StartProgram | STARTPROGRAM (Inherited from NxtCommunicationProtocol.)
Public method | StopProgram | STOPPROGRAM (Inherited from NxtCommunicationProtocol.)
Public method | StopSoundPlayback | STOPSOUNDPLAYBACK (Inherited from NxtCommunicationProtocol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | WRITE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | WriteIoMap | WRITE IO MAP COMMAND (Inherited from NxtCommunicationProtocol.)

Fields

 | Name | Description
Public field | ReplyRequired | Flag indicating if a reply should always be recieved. (Inherited from NxtCommunicationProtocol.)

Properties

 | Name | Description
Public property | IsConnected | Indicates if connected to the NXT brick. (Overrides NxtCommunicationProtocol..::..IsConnected.)

See Also

NxtBluetoothConnection Class


NxtBluetoothConnection Constructor

[image] [image]

MindSqualls v2.0 documentation
NxtBluetoothConnection Constructor
NxtBluetoothConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Overload List

 | Name | Description
Public method | NxtBluetoothConnection(Byte) | Constructor.
Public method | NxtBluetoothConnection(String) | Constructor.

See Also

NxtBluetoothConnection Class
NxtBluetoothConnection Members


NxtBluetoothConnection Constructor (Byte)

[image]

MindSqualls v2.0 documentation
NxtBluetoothConnection Constructor (Byte)
NxtBluetoothConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtBluetoothConnection(
    byte serialPortNo
)
Visual Basic
Public Sub New ( _
    serialPortNo As Byte _
)
Visual C++
public:
NxtBluetoothConnection(
    unsigned char serialPortNo
)

Parameters

serialPortNo
Type: System..::..Byte
The COM port used by the Bluetooth link

See Also

NxtBluetoothConnection Class
NxtBluetoothConnection Overload


NxtBluetoothConnection Constructor (String)

[image]

MindSqualls v2.0 documentation
NxtBluetoothConnection Constructor (String)
NxtBluetoothConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtBluetoothConnection(
    string serialPortName
)
Visual Basic
Public Sub New ( _
    serialPortName As String _
)
Visual C++
public:
NxtBluetoothConnection(
    String^ serialPortName
)

Parameters

serialPortName
Type: System..::..String
The COM port used by the Bluetooth link

See Also

NxtBluetoothConnection Class
NxtBluetoothConnection Overload


NxtBluetoothConnection Fields

[image] [image]

MindSqualls v2.0 documentation
NxtBluetoothConnection Fields
NxtBluetoothConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtBluetoothConnection type exposes the following members.

Fields

 | Name | Description
Public field | ReplyRequired | Flag indicating if a reply should always be recieved. (Inherited from NxtCommunicationProtocol.)

See Also

NxtBluetoothConnection Class


NxtBluetoothConnection Methods

[image] [image]

MindSqualls v2.0 documentation
NxtBluetoothConnection Methods
NxtBluetoothConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtBluetoothConnection type exposes the following members.

Methods

 | Name | Description
Public method | BluetoothFactoryReset | BLUETOOTH FACTORY RESET COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | Boot | BOOT COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | Close | CLOSE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | CloseModuleHandle | CLOSE MODULE HANDLE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | Connect | Connect to the NXT brick via bluetooth. (Overrides NxtCommunicationProtocol..::..Connect()()()().)
Public method | Delete | DELETE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | DeleteUserFlash | DELETE USER FLASH (Inherited from NxtCommunicationProtocol.)
Public method | Disconnect | Disconnect from the brick. (Overrides NxtCommunicationProtocol..::..Disconnect()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFirst | FIND FIRST (Inherited from NxtCommunicationProtocol.)
Public method | FindNext | FIND NEXT (Inherited from NxtCommunicationProtocol.)
Public method | GetBatteryLevel | GETBATTERYLEVEL (Inherited from NxtCommunicationProtocol.)
Public method | GetCurrentProgramName | GETCURRENTPROGRAMNAME (Inherited from NxtCommunicationProtocol.)
Public method | GetDeviceInfo | GET DEVICE INFO (Inherited from NxtCommunicationProtocol.)
Public method | GetFirmwareVersion | GET FIRMWARE VERSION (Inherited from NxtCommunicationProtocol.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInputValues | GETINPUTVALUES (Inherited from NxtCommunicationProtocol.)
Public method | GetOutputState | GETOUTPUTSTATE (Inherited from NxtCommunicationProtocol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KeepAlive | KEEPALIVE (Inherited from NxtCommunicationProtocol.)
Public method | LsGetStatus | LSGETSTATUS (Inherited from NxtCommunicationProtocol.)
Public method | LsRead | LSREAD (Inherited from NxtCommunicationProtocol.)
Public method | LsWrite | LSWRITE (Inherited from NxtCommunicationProtocol.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MessageRead | MESSAGEREAD (Inherited from NxtCommunicationProtocol.)
Public method | MessageWrite | MESSAGEWRITE (Inherited from NxtCommunicationProtocol.)
Public method | OpenAppendData | OPEN APPEND DATA COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenRead | OPEN READ COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenReadLinear | OPEN READ LINEAR COMMAND (INTERNAL COMMAND) (Inherited from NxtCommunicationProtocol.)
Public method | OpenWrite | OPEN WRITE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenWriteData | OPEN WRITE DATA COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenWriteLinear | OPEN WRITE LINEAR COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | PlaySoundfile | PLAYSOUNDFILE (Inherited from NxtCommunicationProtocol.)
Public method | PlayTone | PLAYTONE (Inherited from NxtCommunicationProtocol.)
Public method | PollCommand | POLL COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | PollCommandLength | POLL COMMAND LENGTH (Inherited from NxtCommunicationProtocol.)
Public method | Read | READ COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | ReadIoMap | READ IO MAP COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | RequestFirstModule | REQUEST FIRST MODULE (Inherited from NxtCommunicationProtocol.)
Public method | RequestNextModule | REQUEST NEXT MODULE (Inherited from NxtCommunicationProtocol.)
Public method | ResetInputScaledValue | RESETINPUTSCALEDVALUE (Inherited from NxtCommunicationProtocol.)
Public method | ResetMotorPosition | RESETMOTORPOSITION (Inherited from NxtCommunicationProtocol.)
Protected method | Send | Sends a request for the NXT brick, and if applicable, receive the reply. (Overrides NxtCommunicationProtocol..::..Send(array<Byte>[]()[][]).)
Public method | SetBrickName | SET BRICK NAME COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | SetInputMode | SETINPUTMODE (Inherited from NxtCommunicationProtocol.)
Public method | SetOutputState | SETOUTPUTSTATE (Inherited from NxtCommunicationProtocol.)
Public method | StartProgram | STARTPROGRAM (Inherited from NxtCommunicationProtocol.)
Public method | StopProgram | STOPPROGRAM (Inherited from NxtCommunicationProtocol.)
Public method | StopSoundPlayback | STOPSOUNDPLAYBACK (Inherited from NxtCommunicationProtocol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | WRITE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | WriteIoMap | WRITE IO MAP COMMAND (Inherited from NxtCommunicationProtocol.)

See Also

NxtBluetoothConnection Class


Connect Method

[image]

MindSqualls v2.0 documentation
NxtBluetoothConnection..::..Connect Method
NxtBluetoothConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Connect to the NXT brick via bluetooth.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Connect()
Visual Basic
Public Overrides Sub Connect
Visual C++
public:
virtual void Connect() override

See Also

NxtBluetoothConnection Class


Disconnect Method

[image]

MindSqualls v2.0 documentation
NxtBluetoothConnection..::..Disconnect Method
NxtBluetoothConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Disconnect from the brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Disconnect()
Visual Basic
Public Overrides Sub Disconnect
Visual C++
public:
virtual void Disconnect() override

See Also

NxtBluetoothConnection Class


Send Method

[image]

MindSqualls v2.0 documentation
NxtBluetoothConnection..::..Send Method
NxtBluetoothConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Sends a request for the NXT brick, and if applicable, receive the reply.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override byte[] Send(
    byte[] request
)
Visual Basic
Protected Overrides Function Send ( _
    request As Byte() _
) As Byte()
Visual C++
protected:
virtual array<unsigned char>^ Send(
    array<unsigned char>^ request
) override

Parameters

request
Type: array< System..::..Byte >[]()[][]
The request

Return Value

The reply as a byte-array, or null

See Also

NxtBluetoothConnection Class


NxtBluetoothConnection Properties

[image] [image]

MindSqualls v2.0 documentation
NxtBluetoothConnection Properties
NxtBluetoothConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtBluetoothConnection type exposes the following members.

Properties

 | Name | Description
Public property | IsConnected | Indicates if connected to the NXT brick. (Overrides NxtCommunicationProtocol..::..IsConnected.)

See Also

NxtBluetoothConnection Class


IsConnected Property

[image]

MindSqualls v2.0 documentation
NxtBluetoothConnection..::..IsConnected Property
NxtBluetoothConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Indicates if connected to the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool IsConnected { get; }
Visual Basic
Public Overrides ReadOnly Property IsConnected As Boolean
    Get
Visual C++
public:
virtual property bool IsConnected {
    bool get () override;
}

See Also

NxtBluetoothConnection Class


NxtBrick Class

[image]

MindSqualls v2.0 documentation
NxtBrick Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Class representing the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class NxtBrick
Visual Basic
Public Class NxtBrick
Visual C++
public ref class NxtBrick

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtBrick

See Also

NxtBrick Members


NxtBrick Members

[image] [image]

MindSqualls v2.0 documentation
NxtBrick Members
NxtBrick Class Constructors Methods Properties See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtBrick type exposes the following members.

Constructors

 | Name | Description
Public method | NxtBrick(Byte) | Obsolete. Constructor.
Public method | NxtBrick(String) | Obsolete. Constructor.
Public method | NxtBrick(NxtCommLinkType, Byte) | Constructor.

Methods

 | Name | Description
Public method | Connect | Connect to the NXT brick.
Public method | Disconnect | Disconnect from the NXT brick.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PlaySoundfile | Plays a sound file stored in the NXT brick.
Public method | PlayTone | Plays a tone.
Public method | StopSound | Stops all playing sound; sound files and tones.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BatteryLevel | The battery level of the NXT brick in millivolts.
Public property | CommLink | The communication link to the NXT brick.
Public property | IsConnected | Indicates if the NXT brick is connected.
Public property | MotorA | The motor attached to port A.
Public property | MotorB | The motor attached to port B.
Public property | MotorC | The motor attached to port C.
Public property | Name | The name of the NXT brick.
Public property | Program | This property returns the name of the currently running program, or null if no program is running. Set the property to a program name to run the program, or to null to stop any running program.
Public property | Programs | The programs currently stored in the NXT brick.
Public property | Sensor1 | The sensor attached to port 1.
Public property | Sensor2 | The sensor attached to port 2.
Public property | Sensor3 | The sensor attached to port 3.
Public property | Sensor4 | The sensor attached to port 4.
Public property | Sounds | The sounds currently stored in the NXT brick.

See Also

NxtBrick Class


NxtBrick Constructor

[image] [image]

MindSqualls v2.0 documentation
NxtBrick Constructor
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Overload List

 | Name | Description
Public method | NxtBrick(Byte) | Obsolete. Constructor.
Public method | NxtBrick(String) | Obsolete. Constructor.
Public method | NxtBrick(NxtCommLinkType, Byte) | Constructor.

See Also

NxtBrick Class
NxtBrick Members


NxtBrick Constructor (Byte)

[image]

MindSqualls v2.0 documentation
NxtBrick Constructor (Byte)
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[ObsoleteAttribute("Use NxtBrick(NxtCommLinkType, byte) instead.")]
public NxtBrick(
    byte serialPortNo
)
Visual Basic
<ObsoleteAttribute("Use NxtBrick(NxtCommLinkType, byte) instead.")> _
Public Sub New ( _
    serialPortNo As Byte _
)
Visual C++
[ObsoleteAttribute(L"Use NxtBrick(NxtCommLinkType, byte) instead.")]
public:
NxtBrick(
    unsigned char serialPortNo
)

Parameters

serialPortNo
Type: System..::..Byte
The COM port used by the Bluetooth link

See Also

NxtBrick Class
NxtBrick Overload


NxtBrick Constructor (String)

[image]

MindSqualls v2.0 documentation
NxtBrick Constructor (String)
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[ObsoleteAttribute("Use NxtBrick(NxtCommLinkType, byte) instead.")]
public NxtBrick(
    string serialPortName
)
Visual Basic
<ObsoleteAttribute("Use NxtBrick(NxtCommLinkType, byte) instead.")> _
Public Sub New ( _
    serialPortName As String _
)
Visual C++
[ObsoleteAttribute(L"Use NxtBrick(NxtCommLinkType, byte) instead.")]
public:
NxtBrick(
    String^ serialPortName
)

Parameters

serialPortName
Type: System..::..String
The COM port used by the Bluetooth link

See Also

NxtBrick Class
NxtBrick Overload


NxtBrick Constructor (NxtCommLinkType, Byte)

[image]

MindSqualls v2.0 documentation
NxtBrick Constructor (NxtCommLinkType, Byte)
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtBrick(
    NxtCommLinkType commLinkType,
    byte serialPortNo
)
Visual Basic
Public Sub New ( _
    commLinkType As NxtCommLinkType, _
    serialPortNo As Byte _
)
Visual C++
public:
NxtBrick(
    NxtCommLinkType commLinkType,
    unsigned char serialPortNo
)

Parameters

commLinkType
Type: NKH.MindSqualls..::..NxtCommLinkType
Indicates whether Bluetooth or USB should be used for the communication with the NXT brick.
serialPortNo
Type: System..::..Byte
The COM port used. Only relevant for Bluetooth links.

Remarks

Introduced with v2.0 of the framework.

See Also

NxtBrick Class
NxtBrick Overload


NxtBrick Methods

[image] [image]

MindSqualls v2.0 documentation
NxtBrick Methods
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtBrick type exposes the following members.

Methods

 | Name | Description
Public method | Connect | Connect to the NXT brick.
Public method | Disconnect | Disconnect from the NXT brick.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PlaySoundfile | Plays a sound file stored in the NXT brick.
Public method | PlayTone | Plays a tone.
Public method | StopSound | Stops all playing sound; sound files and tones.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NxtBrick Class


Connect Method

[image]

MindSqualls v2.0 documentation
NxtBrick..::..Connect Method
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Connect to the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Connect()
Visual Basic
Public Sub Connect
Visual C++
public:
void Connect()

See Also

NxtBrick Class
NKH.MindSqualls Namespace
NxtBrick..::..CommLink
NxtBrick..::..Disconnect()()()()
NxtBrick..::..IsConnected


Disconnect Method

[image]

MindSqualls v2.0 documentation
NxtBrick..::..Disconnect Method
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Disconnect from the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Disconnect()
Visual Basic
Public Sub Disconnect
Visual C++
public:
void Disconnect()

See Also

NxtBrick Class
NKH.MindSqualls Namespace
NxtBrick..::..CommLink
NxtBrick..::..Connect()()()()
NxtBrick..::..IsConnected


PlaySoundfile Method

[image]

MindSqualls v2.0 documentation
NxtBrick..::..PlaySoundfile Method
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Plays a sound file stored in the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void PlaySoundfile(
    string soundFile
)
Visual Basic
Public Sub PlaySoundfile ( _
    soundFile As String _
)
Visual C++
public:
void PlaySoundfile(
    String^ soundFile
)

Parameters

soundFile
Type: System..::..String
The sound file

See Also

NxtBrick Class


PlayTone Method

[image]

MindSqualls v2.0 documentation
NxtBrick..::..PlayTone Method
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Plays a tone.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void PlayTone(
    ushort frequency,
    ushort duration
)
Visual Basic
Public Sub PlayTone ( _
    frequency As UShort, _
    duration As UShort _
)
Visual C++
public:
void PlayTone(
    unsigned short frequency,
    unsigned short duration
)

Parameters

frequency
Type: System..::..UInt16
Frequency for the tone, Hz
duration
Type: System..::..UInt16
Duration of the tone, ms

See Also

NxtBrick Class


StopSound Method

[image]

MindSqualls v2.0 documentation
NxtBrick..::..StopSound Method
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Stops all playing sound; sound files and tones.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void StopSound()
Visual Basic
Public Sub StopSound
Visual C++
public:
void StopSound()

See Also

NxtBrick Class


NxtBrick Properties

[image] [image]

MindSqualls v2.0 documentation
NxtBrick Properties
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtBrick type exposes the following members.

Properties

 | Name | Description
Public property | BatteryLevel | The battery level of the NXT brick in millivolts.
Public property | CommLink | The communication link to the NXT brick.
Public property | IsConnected | Indicates if the NXT brick is connected.
Public property | MotorA | The motor attached to port A.
Public property | MotorB | The motor attached to port B.
Public property | MotorC | The motor attached to port C.
Public property | Name | The name of the NXT brick.
Public property | Program | This property returns the name of the currently running program, or null if no program is running. Set the property to a program name to run the program, or to null to stop any running program.
Public property | Programs | The programs currently stored in the NXT brick.
Public property | Sensor1 | The sensor attached to port 1.
Public property | Sensor2 | The sensor attached to port 2.
Public property | Sensor3 | The sensor attached to port 3.
Public property | Sensor4 | The sensor attached to port 4.
Public property | Sounds | The sounds currently stored in the NXT brick.

See Also

NxtBrick Class


BatteryLevel Property

[image]

MindSqualls v2.0 documentation
NxtBrick..::..BatteryLevel Property
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The battery level of the NXT brick in millivolts.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ushort BatteryLevel { get; }
Visual Basic
Public ReadOnly Property BatteryLevel As UShort
    Get
Visual C++
public:
property unsigned short BatteryLevel {
    unsigned short get ();
}

See Also

NxtBrick Class


CommLink Property

[image]

MindSqualls v2.0 documentation
NxtBrick..::..CommLink Property
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The communication link to the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtCommunicationProtocol CommLink { get; private set; }
Visual Basic
Public Property CommLink As NxtCommunicationProtocol
    Get
    Private Set
Visual C++
public:
property NxtCommunicationProtocol^ CommLink {
    NxtCommunicationProtocol^ get ();
    private: void set (NxtCommunicationProtocol^ value);
}

Remarks

The current version of the API only supports bluetooth links. Possibly a future version will support USB as well.

Exceptions

Exception | Condition
NKH.MindSqualls..::..NxtConnectionException | Throws a NxtConnectionException if not connected.

See Also

NxtBrick Class
NKH.MindSqualls Namespace
NxtBrick..::..Connect()()()()
NxtBrick..::..Disconnect()()()()
NxtBrick..::..IsConnected


IsConnected Property

[image]

MindSqualls v2.0 documentation
NxtBrick..::..IsConnected Property
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Indicates if the NXT brick is connected.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsConnected { get; }
Visual Basic
Public ReadOnly Property IsConnected As Boolean
    Get
Visual C++
public:
property bool IsConnected {
    bool get ();
}

See Also

NxtBrick Class
NKH.MindSqualls Namespace
NxtBrick..::..CommLink
NxtBrick..::..Connect()()()()
NxtBrick..::..Disconnect()()()()


MotorA Property

[image]

MindSqualls v2.0 documentation
NxtBrick..::..MotorA Property
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The motor attached to port A.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtMotor MotorA { get; set; }
Visual Basic
Public Property MotorA As NxtMotor
    Get
    Set
Visual C++
public:
property NxtMotor^ MotorA {
    NxtMotor^ get ();
    void set (NxtMotor^ value);
}

See Also

NxtBrick Class


MotorB Property

[image]

MindSqualls v2.0 documentation
NxtBrick..::..MotorB Property
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The motor attached to port B.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtMotor MotorB { get; set; }
Visual Basic
Public Property MotorB As NxtMotor
    Get
    Set
Visual C++
public:
property NxtMotor^ MotorB {
    NxtMotor^ get ();
    void set (NxtMotor^ value);
}

See Also

NxtBrick Class


MotorC Property

[image]

MindSqualls v2.0 documentation
NxtBrick..::..MotorC Property
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The motor attached to port C.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtMotor MotorC { get; set; }
Visual Basic
Public Property MotorC As NxtMotor
    Get
    Set
Visual C++
public:
property NxtMotor^ MotorC {
    NxtMotor^ get ();
    void set (NxtMotor^ value);
}

See Also

NxtBrick Class


Name Property

[image]

MindSqualls v2.0 documentation
NxtBrick..::..Name Property
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The name of the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

For some reason only the first 8 characters is remembered when the NXT is turned off. This is with version 1.4 of the firmware, and it may be fixed with newer versions.

See Also

NxtBrick Class


Program Property

[image]

MindSqualls v2.0 documentation
NxtBrick..::..Program Property
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This property returns the name of the currently running program, or null if no program is running.

Set the property to a program name to run the program, or to null to stop any running program.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string Program { get; set; }
Visual Basic
Public Property Program As String
    Get
    Set
Visual C++
public:
property String^ Program {
    String^ get ();
    void set (String^ value);
}

See Also

NxtBrick Class


Programs Property

[image]

MindSqualls v2.0 documentation
NxtBrick..::..Programs Property
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The programs currently stored in the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string[] Programs { get; }
Visual Basic
Public ReadOnly Property Programs As String()
    Get
Visual C++
public:
property array<String^>^ Programs {
    array<String^>^ get ();
}

See Also

NxtBrick Class


Sensor1 Property

[image]

MindSqualls v2.0 documentation
NxtBrick..::..Sensor1 Property
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The sensor attached to port 1.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtSensor Sensor1 { get; set; }
Visual Basic
Public Property Sensor1 As NxtSensor
    Get
    Set
Visual C++
public:
property NxtSensor^ Sensor1 {
    NxtSensor^ get ();
    void set (NxtSensor^ value);
}

See Also

NxtBrick Class


Sensor2 Property

[image]

MindSqualls v2.0 documentation
NxtBrick..::..Sensor2 Property
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The sensor attached to port 2.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtSensor Sensor2 { get; set; }
Visual Basic
Public Property Sensor2 As NxtSensor
    Get
    Set
Visual C++
public:
property NxtSensor^ Sensor2 {
    NxtSensor^ get ();
    void set (NxtSensor^ value);
}

See Also

NxtBrick Class


Sensor3 Property

[image]

MindSqualls v2.0 documentation
NxtBrick..::..Sensor3 Property
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The sensor attached to port 3.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtSensor Sensor3 { get; set; }
Visual Basic
Public Property Sensor3 As NxtSensor
    Get
    Set
Visual C++
public:
property NxtSensor^ Sensor3 {
    NxtSensor^ get ();
    void set (NxtSensor^ value);
}

See Also

NxtBrick Class


Sensor4 Property

[image]

MindSqualls v2.0 documentation
NxtBrick..::..Sensor4 Property
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The sensor attached to port 4.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtSensor Sensor4 { get; set; }
Visual Basic
Public Property Sensor4 As NxtSensor
    Get
    Set
Visual C++
public:
property NxtSensor^ Sensor4 {
    NxtSensor^ get ();
    void set (NxtSensor^ value);
}

See Also

NxtBrick Class


Sounds Property

[image]

MindSqualls v2.0 documentation
NxtBrick..::..Sounds Property
NxtBrick Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The sounds currently stored in the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string[] Sounds { get; }
Visual Basic
Public ReadOnly Property Sounds As String()
    Get
Visual C++
public:
property array<String^>^ Sounds {
    array<String^>^ get ();
}

See Also

NxtBrick Class


NxtCommand Enumeration

[image]

MindSqualls v2.0 documentation
NxtCommand Enumeration
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Commands to the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum NxtCommand
Visual Basic
Public Enumeration NxtCommand
Visual C++
public enum class NxtCommand

Members

Member name | Value | Description
StartProgram | 0 | BDK, Appendix 2, p. 5.
StopProgram | 1 | BDK, Appendix 2, p. 5.
PlaySoundfile | 2 | BDK, Appendix 2, p. 5.
PlayTone | 3 | BDK, Appendix 2, p. 6.
SetOutputState | 4 | BDK, Appendix 2, p. 6.
SetInputMode | 5 | BDK, Appendix 2, p. 7.
GetOutputState | 6 | BDK, Appendix 2, p. 8.
GetInputValues | 7 | BDK, Appendix 2, p. 8.
ResetInputScaledValue | 8 | BDK, Appendix 2, p. 8.
MessageWrite | 9 | BDK, Appendix 2, p. 9.
ResetMotorPosition | 10 | BDK, Appendix 2, p. 9.
GetBatteryLevel | 11 | BDK, Appendix 2, p. 9.
StopSoundPlayback | 12 | BDK, Appendix 2, p. 9.
KeepAlive | 13 | BDK, Appendix 2, p. 10.
LsGetStatus | 14 | BDK, Appendix 2, p. 10.
LsWrite | 15 | BDK, Appendix 2, p. 10.
LsRead | 16 | BDK, Appendix 2, p. 10.
GetCurrentProgramName | 17 | BDK, Appendix 2, p. 11.
MessageRead | 19 | BDK, Appendix 2, p. 11.
OpenRead | 128 | BDK, Appendix 1, p. 7.
OpenWrite | 129 | BDK, Appendix 1, p. 7.
Read | 130 | BDK, Appendix 1, p. 8.
Write | 131 | BDK, Appendix 1, p. 8.
Close | 132 | BDK, Appendix 1, p. 8.
Delete | 133 | BDK, Appendix 1, p. 9.
FindFirst | 134 | BDK, Appendix 1, p. 9.
FindNext | 135 | BDK, Appendix 1, p. 10.
GetFirmwareVersion | 136 | BDK, Appendix 1, p. 11.
OpenWriteLinear | 137 | BDK, Appendix 1, p. 11.
OpenReadLinear | 138 | BDK, Appendix 1, p. 12.
OpenWriteData | 139 | BDK, Appendix 1, p. 12.
OpenAppendData | 140 | BDK, Appendix 1, p. 13.
RequestFirstModule | 144 | BDK, Appendix 1, p. 19.
RequestNextModule | 145 | BDK, Appendix 1, p. 19.
CloseModuleHandle | 146 | BDK, Appendix 1, p. 20.
ReadIoMap | 148 | BDK, Appendix 1, p. 20.
WriteIoMap | 149 | BDK, Appendix 1, p. 21.
Boot | 151 | BDK, Appendix 1, p. 13.
SetBrickName | 152 | BDK, Appendix 1, p. 13.
GetDeviceInfo | 155 | BDK, Appendix 1, p. 14.
DeleteUserFlash | 160 | BDK, Appendix 1, p. 14.
PollCommandLength | 161 | BDK, Appendix 1, p. 15.
PollCommand | 162 | BDK, Appendix 1, p. 15.
BluetoothFactoryReset | 164 | BDK, Appendix 1, p. 15.

Remarks

Reference: BDK, Appendix 1 & 2.

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


NxtCommLinkType Enumeration

[image]

MindSqualls v2.0 documentation
NxtCommLinkType Enumeration
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Types of communication links usable for the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum NxtCommLinkType
Visual Basic
Public Enumeration NxtCommLinkType
Visual C++
public enum class NxtCommLinkType

Members

Member name | Value | Description
Bluetooth | 0 | Use Bluetooth for the communications link.
USB | 1 | Use USB for the communications link.

Remarks

Introduced with v2.0 of the framework.

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


NxtCommunicationProtocol Class

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Abstract class representing the NXT communication protocol.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class NxtCommunicationProtocol
Visual Basic
Public MustInherit Class NxtCommunicationProtocol
Visual C++
public ref class NxtCommunicationProtocol abstract

Remarks

The communication protocol for the NXT brick is specified in the documents:

Lego Mindstorms NXT,
Bluetooth Developer Kit,
Appendix 1: LEGO MINDSTORMS NXT Communication protocol
- and:
Appendix 2: LEGO MINDSTORMS NXT Direct commands

- which can be downloaded at:
http://mindstorms.lego.com/overview/NXTreme.aspx

For NXT 2.0 specific informaton:
http://www.ni.com/pdf/manuals/372574c.pdf

A special thanks goes to Bram Fokke for his NXT# project:
http://nxtsharp.fokke.net/

Without his work, I doubt very much if my own work would have gotten off the ground. I have even st... ehem... borrowed a bit of his code here and there. However the major part of the code is my own.

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtCommunicationProtocol
NKH.MindSqualls..::..NxtBluetoothConnection
NKH.MindSqualls..::..NxtUsbConnection

See Also

NxtCommunicationProtocol Members


NxtCommunicationProtocol Members

[image] [image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol Members
NxtCommunicationProtocol Class Constructors Methods Fields Properties See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtCommunicationProtocol type exposes the following members.

Constructors

 | Name | Description
Public method | NxtCommunicationProtocol | Constructor.

Methods

 | Name | Description
Public method | BluetoothFactoryReset | BLUETOOTH FACTORY RESET COMMAND
Public method | Boot | BOOT COMMAND
Public method | Close | CLOSE COMMAND
Public method | CloseModuleHandle | CLOSE MODULE HANDLE COMMAND
Public method | Connect | Connect to the NXT brick.
Public method | Delete | DELETE COMMAND
Public method | DeleteUserFlash | DELETE USER FLASH
Public method | Disconnect | Disconnect from the NXT brick.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFirst | FIND FIRST
Public method | FindNext | FIND NEXT
Public method | GetBatteryLevel | GETBATTERYLEVEL
Public method | GetCurrentProgramName | GETCURRENTPROGRAMNAME
Public method | GetDeviceInfo | GET DEVICE INFO
Public method | GetFirmwareVersion | GET FIRMWARE VERSION
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInputValues | GETINPUTVALUES
Public method | GetOutputState | GETOUTPUTSTATE
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KeepAlive | KEEPALIVE
Public method | LsGetStatus | LSGETSTATUS
Public method | LsRead | LSREAD
Public method | LsWrite | LSWRITE
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MessageRead | MESSAGEREAD
Public method | MessageWrite | MESSAGEWRITE
Public method | OpenAppendData | OPEN APPEND DATA COMMAND
Public method | OpenRead | OPEN READ COMMAND
Public method | OpenReadLinear | OPEN READ LINEAR COMMAND (INTERNAL COMMAND)
Public method | OpenWrite | OPEN WRITE COMMAND
Public method | OpenWriteData | OPEN WRITE DATA COMMAND
Public method | OpenWriteLinear | OPEN WRITE LINEAR COMMAND
Public method | PlaySoundfile | PLAYSOUNDFILE
Public method | PlayTone | PLAYTONE
Public method | PollCommand | POLL COMMAND
Public method | PollCommandLength | POLL COMMAND LENGTH
Public method | Read | READ COMMAND
Public method | ReadIoMap | READ IO MAP COMMAND
Public method | RequestFirstModule | REQUEST FIRST MODULE
Public method | RequestNextModule | REQUEST NEXT MODULE
Public method | ResetInputScaledValue | RESETINPUTSCALEDVALUE
Public method | ResetMotorPosition | RESETMOTORPOSITION
Protected method | Send | Send a request to the NXT brick, and return a reply.
Public method | SetBrickName | SET BRICK NAME COMMAND
Public method | SetInputMode | SETINPUTMODE
Public method | SetOutputState | SETOUTPUTSTATE
Public method | StartProgram | STARTPROGRAM
Public method | StopProgram | STOPPROGRAM
Public method | StopSoundPlayback | STOPSOUNDPLAYBACK
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | WRITE COMMAND
Public method | WriteIoMap | WRITE IO MAP COMMAND

Fields

 | Name | Description
Public field | ReplyRequired | Flag indicating if a reply should always be recieved.

Properties

 | Name | Description
Public property | IsConnected | Returns a boolean indicating if the NXT brick is connected.

See Also

NxtCommunicationProtocol Class


NxtCommunicationProtocol Constructor

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol Constructor
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtCommunicationProtocol()
Visual Basic
Public Sub New
Visual C++
public:
NxtCommunicationProtocol()

See Also

NxtCommunicationProtocol Class


NxtCommunicationProtocol Fields

[image] [image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol Fields
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtCommunicationProtocol type exposes the following members.

Fields

 | Name | Description
Public field | ReplyRequired | Flag indicating if a reply should always be recieved.

See Also

NxtCommunicationProtocol Class


ReplyRequired Field

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..ReplyRequired Field
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Flag indicating if a reply should always be recieved.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ReplyRequired
Visual Basic
Public ReplyRequired As Boolean
Visual C++
public:
bool ReplyRequired

See Also

NxtCommunicationProtocol Class


NxtCommunicationProtocol Methods

[image] [image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol Methods
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtCommunicationProtocol type exposes the following members.

Methods

 | Name | Description
Public method | BluetoothFactoryReset | BLUETOOTH FACTORY RESET COMMAND
Public method | Boot | BOOT COMMAND
Public method | Close | CLOSE COMMAND
Public method | CloseModuleHandle | CLOSE MODULE HANDLE COMMAND
Public method | Connect | Connect to the NXT brick.
Public method | Delete | DELETE COMMAND
Public method | DeleteUserFlash | DELETE USER FLASH
Public method | Disconnect | Disconnect from the NXT brick.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFirst | FIND FIRST
Public method | FindNext | FIND NEXT
Public method | GetBatteryLevel | GETBATTERYLEVEL
Public method | GetCurrentProgramName | GETCURRENTPROGRAMNAME
Public method | GetDeviceInfo | GET DEVICE INFO
Public method | GetFirmwareVersion | GET FIRMWARE VERSION
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInputValues | GETINPUTVALUES
Public method | GetOutputState | GETOUTPUTSTATE
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KeepAlive | KEEPALIVE
Public method | LsGetStatus | LSGETSTATUS
Public method | LsRead | LSREAD
Public method | LsWrite | LSWRITE
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MessageRead | MESSAGEREAD
Public method | MessageWrite | MESSAGEWRITE
Public method | OpenAppendData | OPEN APPEND DATA COMMAND
Public method | OpenRead | OPEN READ COMMAND
Public method | OpenReadLinear | OPEN READ LINEAR COMMAND (INTERNAL COMMAND)
Public method | OpenWrite | OPEN WRITE COMMAND
Public method | OpenWriteData | OPEN WRITE DATA COMMAND
Public method | OpenWriteLinear | OPEN WRITE LINEAR COMMAND
Public method | PlaySoundfile | PLAYSOUNDFILE
Public method | PlayTone | PLAYTONE
Public method | PollCommand | POLL COMMAND
Public method | PollCommandLength | POLL COMMAND LENGTH
Public method | Read | READ COMMAND
Public method | ReadIoMap | READ IO MAP COMMAND
Public method | RequestFirstModule | REQUEST FIRST MODULE
Public method | RequestNextModule | REQUEST NEXT MODULE
Public method | ResetInputScaledValue | RESETINPUTSCALEDVALUE
Public method | ResetMotorPosition | RESETMOTORPOSITION
Protected method | Send | Send a request to the NXT brick, and return a reply.
Public method | SetBrickName | SET BRICK NAME COMMAND
Public method | SetInputMode | SETINPUTMODE
Public method | SetOutputState | SETOUTPUTSTATE
Public method | StartProgram | STARTPROGRAM
Public method | StopProgram | STOPPROGRAM
Public method | StopSoundPlayback | STOPSOUNDPLAYBACK
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | WRITE COMMAND
Public method | WriteIoMap | WRITE IO MAP COMMAND

See Also

NxtCommunicationProtocol Class


BluetoothFactoryReset Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..BluetoothFactoryReset Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

BLUETOOTH FACTORY RESET COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void BluetoothFactoryReset()
Visual Basic
Public Sub BluetoothFactoryReset
Visual C++
public:
void BluetoothFactoryReset()

Remarks

Reference: BDK, Appendix 1, p. 15.

This command cannot be transmitted via Bluetooth because all Bluetooth functionality is reset by this command!

See Also

NxtCommunicationProtocol Class


Boot Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..Boot Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

BOOT COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Boot()
Visual Basic
Public Sub Boot
Visual C++
public:
void Boot()

Remarks

Reference: BDK, Appendix 1, p. 13.

This command can only be accepted by USB.

See Also

NxtCommunicationProtocol Class


Close Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..Close Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

CLOSE COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Close(
    byte handle
)
Visual Basic
Public Sub Close ( _
    handle As Byte _
)
Visual C++
public:
void Close(
    unsigned char handle
)

Parameters

handle
Type: System..::..Byte
File handle to close

Remarks

Reference: BDK, Appendix 1, p. 8.

See Also

NxtCommunicationProtocol Class


CloseModuleHandle Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..CloseModuleHandle Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

CLOSE MODULE HANDLE COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void CloseModuleHandle(
    byte handle
)
Visual Basic
Public Sub CloseModuleHandle ( _
    handle As Byte _
)
Visual C++
public:
void CloseModuleHandle(
    unsigned char handle
)

Parameters

handle
Type: System..::..Byte
Handle number

Remarks

Reference: BDK, Appendix 1, p. 20.

See Also

NxtCommunicationProtocol Class
NKH.MindSqualls Namespace
NxtCommunicationProtocol..::..RequestFirstModule(String)
NxtCommunicationProtocol..::..RequestNextModule(Byte)


Connect Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..Connect Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Connect to the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract void Connect()
Visual Basic
Public MustOverride Sub Connect
Visual C++
public:
virtual void Connect() abstract

See Also

NxtCommunicationProtocol Class


Delete Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..Delete Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

DELETE COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Delete(
    string fileName
)
Visual Basic
Public Sub Delete ( _
    fileName As String _
)
Visual C++
public:
void Delete(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The file name

Remarks

Reference: BDK, Appendix 1, p. 9.

See Also

NxtCommunicationProtocol Class


DeleteUserFlash Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..DeleteUserFlash Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

DELETE USER FLASH

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void DeleteUserFlash()
Visual Basic
Public Sub DeleteUserFlash
Visual C++
public:
void DeleteUserFlash()

Remarks

Reference: BDK, Appendix 1, p. 14.

See Also

NxtCommunicationProtocol Class


Disconnect Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..Disconnect Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Disconnect from the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract void Disconnect()
Visual Basic
Public MustOverride Sub Disconnect
Visual C++
public:
virtual void Disconnect() abstract

See Also

NxtCommunicationProtocol Class


FindFirst Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..FindFirst Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

FIND FIRST

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<NxtFindFileReply> FindFirst(
    string fileName
)
Visual Basic
Public Function FindFirst ( _
    fileName As String _
) As Nullable(Of NxtFindFileReply)
Visual C++
public:
Nullable<NxtFindFileReply> FindFirst(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
Filename or -mask to search

Return Value

A NxtFindFileReply containing the result for the search

Remarks

Reference: BDK, Appendix 1, p. 9.

Close the handle after use. The handle is automatically closed if an error occurs.

See Also

NxtCommunicationProtocol Class
NKH.MindSqualls Namespace
NxtCommunicationProtocol..::..FindNext(Byte)


FindNext Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..FindNext Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

FIND NEXT

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<NxtFindFileReply> FindNext(
    byte handle
)
Visual Basic
Public Function FindNext ( _
    handle As Byte _
) As Nullable(Of NxtFindFileReply)
Visual C++
public:
Nullable<NxtFindFileReply> FindNext(
    unsigned char handle
)

Parameters

handle
Type: System..::..Byte
Handle from the previous found file or from the FindFirst command

Return Value

A NxtFindFileReply containing the result for the search

Remarks

Reference: BDK, Appendix 1, p. 10.

Close the handle after use. The handle is automatically closed if an error occurs.

See Also

NxtCommunicationProtocol Class
NKH.MindSqualls Namespace
NxtCommunicationProtocol..::..FindFirst(String)


GetBatteryLevel Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..GetBatteryLevel Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

GETBATTERYLEVEL

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<ushort> GetBatteryLevel()
Visual Basic
Public Function GetBatteryLevel As Nullable(Of UShort)
Visual C++
public:
Nullable<unsigned short> GetBatteryLevel()

Return Value

Voltage in millivolts

Remarks

Reference: BDK, Appendix 2, p. 9.

See Also

NxtCommunicationProtocol Class


GetCurrentProgramName Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..GetCurrentProgramName Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

GETCURRENTPROGRAMNAME

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string GetCurrentProgramName()
Visual Basic
Public Function GetCurrentProgramName As String
Visual C++
public:
String^ GetCurrentProgramName()

Return Value

File name of the running program

Remarks

Reference: BDK, Appendix 2, p. 11.

See Also

NxtCommunicationProtocol Class


GetDeviceInfo Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..GetDeviceInfo Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

GET DEVICE INFO

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<NxtGetDeviceInfoReply> GetDeviceInfo()
Visual Basic
Public Function GetDeviceInfo As Nullable(Of NxtGetDeviceInfoReply)
Visual C++
public:
Nullable<NxtGetDeviceInfoReply> GetDeviceInfo()

Return Value

A NxtGetDeviceInfoReply containing the parsed result

Remarks

Reference: BDK, Appendix 1, p. 14.

For some reason only the first 8 characters of the BXT name is remembered when the NXT is turned off. This is with version 1.4 of the firmware, and it may be fixed with newer versions.

See Also

NxtCommunicationProtocol Class


GetFirmwareVersion Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..GetFirmwareVersion Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

GET FIRMWARE VERSION

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<NxtGetFirmwareVersionReply> GetFirmwareVersion()
Visual Basic
Public Function GetFirmwareVersion As Nullable(Of NxtGetFirmwareVersionReply)
Visual C++
public:
Nullable<NxtGetFirmwareVersionReply> GetFirmwareVersion()

Return Value

A NxtGetFirmwareVersionReply with the protocol-, and the firmware versions.

Remarks

Reference: BDK, Appendix 1, p. 11.

See Also

NxtCommunicationProtocol Class


GetInputValues Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..GetInputValues Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

GETINPUTVALUES

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<NxtGetInputValuesReply> GetInputValues(
    NxtSensorPort sensorPort
)
Visual Basic
Public Function GetInputValues ( _
    sensorPort As NxtSensorPort _
) As Nullable(Of NxtGetInputValuesReply)
Visual C++
public:
Nullable<NxtGetInputValuesReply> GetInputValues(
    NxtSensorPort sensorPort
)

Parameters

sensorPort
Type: NKH.MindSqualls..::..NxtSensorPort
Input Port

Return Value

Returns a NxtGetInputValues with the parsed reply

Remarks

Reference: BDK, Appendix 2, p. 8.

Used with passive sensors like the Touch, Light and Sound sensors.

See Also

NxtCommunicationProtocol Class


GetOutputState Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..GetOutputState Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

GETOUTPUTSTATE

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<NxtGetOutputStateReply> GetOutputState(
    NxtMotorPort motorPort
)
Visual Basic
Public Function GetOutputState ( _
    motorPort As NxtMotorPort _
) As Nullable(Of NxtGetOutputStateReply)
Visual C++
public:
Nullable<NxtGetOutputStateReply> GetOutputState(
    NxtMotorPort motorPort
)

Parameters

motorPort
Type: NKH.MindSqualls..::..NxtMotorPort
Ourput Port

Return Value

Returns a parsed NxtGetOutputStateReply with the reply

Remarks

Reference: BDK, Appendix 2, p. 8.

See Also

NxtCommunicationProtocol Class


KeepAlive Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..KeepAlive Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

KEEPALIVE

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<uint> KeepAlive()
Visual Basic
Public Function KeepAlive As Nullable(Of UInteger)
Visual C++
public:
Nullable<unsigned int> KeepAlive()

Return Value

Current sleep time limit, ms

Remarks

Reference: BDK, Appendix 2, p. 10.

See Also

NxtCommunicationProtocol Class


LsGetStatus Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..LsGetStatus Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

LSGETSTATUS

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> LsGetStatus(
    NxtSensorPort sensorPort
)
Visual Basic
Public Function LsGetStatus ( _
    sensorPort As NxtSensorPort _
) As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> LsGetStatus(
    NxtSensorPort sensorPort
)

Parameters

sensorPort
Type: NKH.MindSqualls..::..NxtSensorPort
Sensor port

Return Value

Bytes Ready (count of available bytes to read)

Remarks

Reference: BDK, Appendix 2, p. 10.

Returns the number of bytes ready in the LowSpeed port. Used with digital sensors like the Ultrasonic sensor.

See Also

NxtCommunicationProtocol Class
NKH.MindSqualls Namespace
NxtCommunicationProtocol..::..LsRead(NxtSensorPort)
NxtCommunicationProtocol..::..LsWrite(NxtSensorPort, Byte, array<Byte>[]()[][])


LsRead Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..LsRead Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

LSREAD

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte[] LsRead(
    NxtSensorPort sensorPort
)
Visual Basic
Public Function LsRead ( _
    sensorPort As NxtSensorPort _
) As Byte()
Visual C++
public:
array<unsigned char>^ LsRead(
    NxtSensorPort sensorPort
)

Parameters

sensorPort
Type: NKH.MindSqualls..::..NxtSensorPort
The sensor port

Return Value

The data read from the port

Remarks

Reference: BDK, Appendix 2, p. 10.

Reads data from the LowSpeed port. Used with digital sensors like the Ultrasonic sensor.

See Also

NxtCommunicationProtocol Class
NKH.MindSqualls Namespace
NxtCommunicationProtocol..::..LsGetStatus(NxtSensorPort)
NxtCommunicationProtocol..::..LsWrite(NxtSensorPort, Byte, array<Byte>[]()[][])


LsWrite Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..LsWrite Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

LSWRITE

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void LsWrite(
    NxtSensorPort sensorPort,
    byte rxDataLength,
    byte[] txData
)
Visual Basic
Public Sub LsWrite ( _
    sensorPort As NxtSensorPort, _
    rxDataLength As Byte, _
    txData As Byte() _
)
Visual C++
public:
void LsWrite(
    NxtSensorPort sensorPort,
    unsigned char rxDataLength,
    array<unsigned char>^ txData
)

Parameters

sensorPort
Type: NKH.MindSqualls..::..NxtSensorPort
Sensor port
rxDataLength
Type: System..::..Byte
Rx Data Length
txData
Type: array< System..::..Byte >[]()[][]
Tx Data

Remarks

Reference: BDK, Appendix 2, p. 10.

Writes data to the LowSpeed port. Used with digital sensors like the Ultrasonic sensor.

See Also

NxtCommunicationProtocol Class
NKH.MindSqualls Namespace
NxtCommunicationProtocol..::..LsRead(NxtSensorPort)
NxtCommunicationProtocol..::..LsGetStatus(NxtSensorPort)


MessageRead Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..MessageRead Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

MESSAGEREAD

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string MessageRead(
    NxtMailbox2 remoteInboxNo,
    NxtMailbox localInboxNo,
    bool remove
)
Visual Basic
Public Function MessageRead ( _
    remoteInboxNo As NxtMailbox2, _
    localInboxNo As NxtMailbox, _
    remove As Boolean _
) As String
Visual C++
public:
String^ MessageRead(
    NxtMailbox2 remoteInboxNo,
    NxtMailbox localInboxNo,
    bool remove
)

Parameters

remoteInboxNo
Type: NKH.MindSqualls..::..NxtMailbox2
Remote Inbox number
localInboxNo
Type: NKH.MindSqualls..::..NxtMailbox
Local Inbox number
remove
Type: System..::..Boolean
Remove? True: clears message from Remote Inbox

Return Value

Message data

Remarks

Reference: BDK, Appendix 2, p. 11.

See Also

NxtCommunicationProtocol Class


MessageWrite Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..MessageWrite Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

MESSAGEWRITE

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void MessageWrite(
    NxtMailbox inBox,
    string messageData
)
Visual Basic
Public Sub MessageWrite ( _
    inBox As NxtMailbox, _
    messageData As String _
)
Visual C++
public:
void MessageWrite(
    NxtMailbox inBox,
    String^ messageData
)

Parameters

inBox
Type: NKH.MindSqualls..::..NxtMailbox
Inbox number
messageData
Type: System..::..String
Message data

Remarks

Reference: BDK, Appendix 2, p. 9.

See Also

NxtCommunicationProtocol Class


OpenAppendData Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..OpenAppendData Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

OPEN APPEND DATA COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<NxtOpenAppendDataReply> OpenAppendData(
    string fileName
)
Visual Basic
Public Function OpenAppendData ( _
    fileName As String _
) As Nullable(Of NxtOpenAppendDataReply)
Visual C++
public:
Nullable<NxtOpenAppendDataReply> OpenAppendData(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The file name

Return Value

A NxtOpenAppendDataReply withe the parsed reply

Remarks

Reference: BDK, Appendix 1, p. 13.

See Also

NxtCommunicationProtocol Class


OpenRead Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..OpenRead Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

OPEN READ COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<NxtOpenReadReply> OpenRead(
    string fileName
)
Visual Basic
Public Function OpenRead ( _
    fileName As String _
) As Nullable(Of NxtOpenReadReply)
Visual C++
public:
Nullable<NxtOpenReadReply> OpenRead(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The name of the file

Return Value

A NxtOpenReadReply with the result of the request

Remarks

Reference: BDK, Appendix 1, p. 7.

Close the handle after use. The handle is automatically closed if an error occurs.

See Also

NxtCommunicationProtocol Class


OpenReadLinear Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..OpenReadLinear Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

OPEN READ LINEAR COMMAND (INTERNAL COMMAND)

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<uint> OpenReadLinear(
    string fileName
)
Visual Basic
Public Function OpenReadLinear ( _
    fileName As String _
) As Nullable(Of UInteger)
Visual C++
public:
Nullable<unsigned int> OpenReadLinear(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The file name

Return Value

Pointer to linear memory segment

Remarks

Reference: BDK, Appendix 1, p. 12.

See Also

NxtCommunicationProtocol Class


OpenWrite Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..OpenWrite Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

OPEN WRITE COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> OpenWrite(
    string fileName,
    uint fileSize
)
Visual Basic
Public Function OpenWrite ( _
    fileName As String, _
    fileSize As UInteger _
) As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> OpenWrite(
    String^ fileName,
    unsigned int fileSize
)

Parameters

fileName
Type: System..::..String
The file name
fileSize
Type: System..::..UInt32
The file size

Return Value

A handle to the file

Remarks

Reference: BDK, Appendix 1, p. 7.

Close the handle after use. The handle is automatically closed if an error occurs.

See Also

NxtCommunicationProtocol Class


OpenWriteData Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..OpenWriteData Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

OPEN WRITE DATA COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> OpenWriteData(
    string fileName,
    uint fileSize
)
Visual Basic
Public Function OpenWriteData ( _
    fileName As String, _
    fileSize As UInteger _
) As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> OpenWriteData(
    String^ fileName,
    unsigned int fileSize
)

Parameters

fileName
Type: System..::..String
The file name
fileSize
Type: System..::..UInt32
The file size

Return Value

A handle to the file

Remarks

Reference: BDK, Appendix 1, p. 12.

See Also

NxtCommunicationProtocol Class


OpenWriteLinear Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..OpenWriteLinear Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

OPEN WRITE LINEAR COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> OpenWriteLinear(
    string fileName,
    uint fileSize
)
Visual Basic
Public Function OpenWriteLinear ( _
    fileName As String, _
    fileSize As UInteger _
) As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> OpenWriteLinear(
    String^ fileName,
    unsigned int fileSize
)

Parameters

fileName
Type: System..::..String
The file name
fileSize
Type: System..::..UInt32
The file size

Return Value

A handle to the file

Remarks

Reference: BDK, Appendix 1, p. 11.

See Also

NxtCommunicationProtocol Class


PlaySoundfile Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..PlaySoundfile Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

PLAYSOUNDFILE

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void PlaySoundfile(
    bool loop,
    string fileName
)
Visual Basic
Public Sub PlaySoundfile ( _
    loop As Boolean, _
    fileName As String _
)
Visual C++
public:
void PlaySoundfile(
    bool loop,
    String^ fileName
)

Parameters

loop
Type: System..::..Boolean
Loop sound file indefinately?
fileName
Type: System..::..String
File name

Remarks

Reference: BDK, Appendix 2, p. 5.

See Also

NxtCommunicationProtocol Class


PlayTone Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..PlayTone Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

PLAYTONE

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void PlayTone(
    ushort frequency,
    ushort duration
)
Visual Basic
Public Sub PlayTone ( _
    frequency As UShort, _
    duration As UShort _
)
Visual C++
public:
void PlayTone(
    unsigned short frequency,
    unsigned short duration
)

Parameters

frequency
Type: System..::..UInt16
Frequency for the tone, Hz
duration
Type: System..::..UInt16
Duration of the tone, ms

Remarks

Reference: BDK, Appendix 2, p. 6.

See Also

NxtCommunicationProtocol Class


PollCommand Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..PollCommand Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

POLL COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void PollCommand(
    byte bufferNo,
    byte commandLength
)
Visual Basic
Public Sub PollCommand ( _
    bufferNo As Byte, _
    commandLength As Byte _
)
Visual C++
public:
void PollCommand(
    unsigned char bufferNo,
    unsigned char commandLength
)

Parameters

bufferNo
Type: System..::..Byte
Buffer Number: 0x00 = Poll Buffer, 0x01 = High Speed buffer
commandLength
Type: System..::..Byte
Command length

Remarks

Reference: BDK, Appendix 1, p. 15.

See Also

NxtCommunicationProtocol Class


PollCommandLength Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..PollCommandLength Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

POLL COMMAND LENGTH

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> PollCommandLength(
    byte bufferNo
)
Visual Basic
Public Function PollCommandLength ( _
    bufferNo As Byte _
) As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> PollCommandLength(
    unsigned char bufferNo
)

Parameters

bufferNo
Type: System..::..Byte
Buffer Number: 0x00 = Poll Buffer, 0x01 = High Speed buffer

Return Value

Number of bytes for the command ready in the buffer

Remarks

Reference: BDK, Appendix 1, p. 15.

See Also

NxtCommunicationProtocol Class


Read Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..Read Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

READ COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte[] Read(
    byte handle,
    ushort bytesToRead
)
Visual Basic
Public Function Read ( _
    handle As Byte, _
    bytesToRead As UShort _
) As Byte()
Visual C++
public:
array<unsigned char>^ Read(
    unsigned char handle,
    unsigned short bytesToRead
)

Parameters

handle
Type: System..::..Byte
A handle to the file
bytesToRead
Type: System..::..UInt16
Number of data bytes to be read

Return Value

A byte array with the read data

Remarks

Reference: BDK, Appendix 1, p. 8.

See Also

NxtCommunicationProtocol Class


ReadIoMap Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..ReadIoMap Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

READ IO MAP COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte[] ReadIoMap(
    uint moduleId,
    ushort offset,
    ushort bytesToRead
)
Visual Basic
Public Function ReadIoMap ( _
    moduleId As UInteger, _
    offset As UShort, _
    bytesToRead As UShort _
) As Byte()
Visual C++
public:
array<unsigned char>^ ReadIoMap(
    unsigned int moduleId,
    unsigned short offset,
    unsigned short bytesToRead
)

Parameters

moduleId
Type: System..::..UInt32
The module ID
offset
Type: System..::..UInt16
The offset to read from
bytesToRead
Type: System..::..UInt16
Number of bytes to be read

Return Value

IO-map content

Remarks

Reference: BDK, Appendix 1, p. 20.

See Also

NxtCommunicationProtocol Class


RequestFirstModule Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..RequestFirstModule Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

REQUEST FIRST MODULE

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<NxtRequestModuleReply> RequestFirstModule(
    string resourceName
)
Visual Basic
Public Function RequestFirstModule ( _
    resourceName As String _
) As Nullable(Of NxtRequestModuleReply)
Visual C++
public:
Nullable<NxtRequestModuleReply> RequestFirstModule(
    String^ resourceName
)

Parameters

resourceName
Type: System..::..String
Modulename or -mask to search

Return Value

A NxtRequestModuleReply containing the result for the search

Remarks

Reference: BDK, Appendix 1, p. 19.

See Also

NxtCommunicationProtocol Class
NKH.MindSqualls Namespace
NxtCommunicationProtocol..::..RequestNextModule(Byte)
NxtCommunicationProtocol..::..CloseModuleHandle(Byte)


RequestNextModule Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..RequestNextModule Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

REQUEST NEXT MODULE

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<NxtRequestModuleReply> RequestNextModule(
    byte handle
)
Visual Basic
Public Function RequestNextModule ( _
    handle As Byte _
) As Nullable(Of NxtRequestModuleReply)
Visual C++
public:
Nullable<NxtRequestModuleReply> RequestNextModule(
    unsigned char handle
)

Parameters

handle
Type: System..::..Byte
Handle number from the previous Request Next Module command or from the very first Request First Module command

Return Value

A NxtRequestModuleReply containing the result for the search

Remarks

Reference: BDK, Appendix 1, p. 19.

See Also

NxtCommunicationProtocol Class
NKH.MindSqualls Namespace
NxtCommunicationProtocol..::..RequestFirstModule(String)
NxtCommunicationProtocol..::..CloseModuleHandle(Byte)


ResetInputScaledValue Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..ResetInputScaledValue Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

RESETINPUTSCALEDVALUE

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void ResetInputScaledValue(
    NxtSensorPort sensorPort
)
Visual Basic
Public Sub ResetInputScaledValue ( _
    sensorPort As NxtSensorPort _
)
Visual C++
public:
void ResetInputScaledValue(
    NxtSensorPort sensorPort
)

Parameters

sensorPort
Type: NKH.MindSqualls..::..NxtSensorPort
Input Port

Remarks

Reference: BDK, Appendix 2, p. 8.

See Also

NxtCommunicationProtocol Class


ResetMotorPosition Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..ResetMotorPosition Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

RESETMOTORPOSITION

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void ResetMotorPosition(
    NxtMotorPort motorPort,
    bool relative
)
Visual Basic
Public Sub ResetMotorPosition ( _
    motorPort As NxtMotorPort, _
    relative As Boolean _
)
Visual C++
public:
void ResetMotorPosition(
    NxtMotorPort motorPort,
    bool relative
)

Parameters

motorPort
Type: NKH.MindSqualls..::..NxtMotorPort
Output port
relative
Type: System..::..Boolean
Relative? True: position relative to last movement, False: absolute position

Remarks

Reference: BDK, Appendix 2, p. 9.

See Also

NxtCommunicationProtocol Class


Send Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..Send Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Send a request to the NXT brick, and return a reply.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected abstract byte[] Send(
    byte[] request
)
Visual Basic
Protected MustOverride Function Send ( _
    request As Byte() _
) As Byte()
Visual C++
protected:
virtual array<unsigned char>^ Send(
    array<unsigned char>^ request
) abstract

Parameters

request
Type: array< System..::..Byte >[]()[][]
The request to the NXT brick

Return Value

The reply from the NXT brick, or null

See Also

NxtCommunicationProtocol Class


SetBrickName Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..SetBrickName Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

SET BRICK NAME COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetBrickName(
    string brickName
)
Visual Basic
Public Sub SetBrickName ( _
    brickName As String _
)
Visual C++
public:
void SetBrickName(
    String^ brickName
)

Parameters

brickName
Type: System..::..String
The new name of the NXT brick

Remarks

Reference: BDK, Appendix 1, p. 13.

For some reason only the first 8 characters is remembered when the NXT is turned off. This is with version 1.4 of the firmware, and it may be fixed with newer versions.

See Also

NxtCommunicationProtocol Class


SetInputMode Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..SetInputMode Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

SETINPUTMODE

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetInputMode(
    NxtSensorPort sensorPort,
    NxtSensorType sensorType,
    NxtSensorMode sensorMode
)
Visual Basic
Public Sub SetInputMode ( _
    sensorPort As NxtSensorPort, _
    sensorType As NxtSensorType, _
    sensorMode As NxtSensorMode _
)
Visual C++
public:
void SetInputMode(
    NxtSensorPort sensorPort,
    NxtSensorType sensorType,
    NxtSensorMode sensorMode
)

Parameters

sensorPort
Type: NKH.MindSqualls..::..NxtSensorPort
Input Port
sensorType
Type: NKH.MindSqualls..::..NxtSensorType
Sensor Type
sensorMode
Type: NKH.MindSqualls..::..NxtSensorMode
Sensor Mode

Remarks

Reference: BDK, Appendix 2, p. 7.

See Also

NxtCommunicationProtocol Class


SetOutputState Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..SetOutputState Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

SETOUTPUTSTATE

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetOutputState(
    NxtMotorPort motorPort,
    sbyte power,
    NxtMotorMode mode,
    NxtMotorRegulationMode regulationMode,
    sbyte turnRatio,
    NxtMotorRunState runState,
    uint tachoLimit
)
Visual Basic
Public Sub SetOutputState ( _
    motorPort As NxtMotorPort, _
    power As SByte, _
    mode As NxtMotorMode, _
    regulationMode As NxtMotorRegulationMode, _
    turnRatio As SByte, _
    runState As NxtMotorRunState, _
    tachoLimit As UInteger _
)
Visual C++
public:
void SetOutputState(
    NxtMotorPort motorPort,
    signed char power,
    NxtMotorMode mode,
    NxtMotorRegulationMode regulationMode,
    signed char turnRatio,
    NxtMotorRunState runState,
    unsigned int tachoLimit
)

Parameters

motorPort
Type: NKH.MindSqualls..::..NxtMotorPort
Motor port
power
Type: System..::..SByte
Power set point
mode
Type: NKH.MindSqualls..::..NxtMotorMode
Mode
regulationMode
Type: NKH.MindSqualls..::..NxtMotorRegulationMode
Regulation mode
turnRatio
Type: System..::..SByte
Turn ratio
runState
Type: NKH.MindSqualls..::..NxtMotorRunState
Run state
tachoLimit
Type: System..::..UInt32
Tacho limit, 0: run forever

Remarks

Reference: BDK, Appendix 2, p. 6.

See Also

NxtCommunicationProtocol Class


StartProgram Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..StartProgram Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

STARTPROGRAM

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void StartProgram(
    string fileName
)
Visual Basic
Public Sub StartProgram ( _
    fileName As String _
)
Visual C++
public:
void StartProgram(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
File name

Remarks

Reference: BDK, Appendix 2, p. 5.

See Also

NxtCommunicationProtocol Class


StopProgram Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..StopProgram Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

STOPPROGRAM

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void StopProgram()
Visual Basic
Public Sub StopProgram
Visual C++
public:
void StopProgram()

Remarks

Reference: BDK, Appendix 2, p. 5.

See Also

NxtCommunicationProtocol Class


StopSoundPlayback Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..StopSoundPlayback Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

STOPSOUNDPLAYBACK

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void StopSoundPlayback()
Visual Basic
Public Sub StopSoundPlayback
Visual C++
public:
void StopSoundPlayback()

Remarks

Reference: BDK, Appendix 2, p. 9.

See Also

NxtCommunicationProtocol Class


Write Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..Write Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

WRITE COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<ushort> Write(
    byte handle,
    byte[] data
)
Visual Basic
Public Function Write ( _
    handle As Byte, _
    data As Byte() _
) As Nullable(Of UShort)
Visual C++
public:
Nullable<unsigned short> Write(
    unsigned char handle,
    array<unsigned char>^ data
)

Parameters

handle
Type: System..::..Byte
File handle to write to
data
Type: array< System..::..Byte >[]()[][]
Data to write

Return Value

Number of bytes written

Remarks

Reference: BDK, Appendix 1, p. 8.

See Also

NxtCommunicationProtocol Class


WriteIoMap Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..WriteIoMap Method
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

WRITE IO MAP COMMAND

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<ushort> WriteIoMap(
    uint moduleId,
    ushort offset,
    byte[] ioMapContent
)
Visual Basic
Public Function WriteIoMap ( _
    moduleId As UInteger, _
    offset As UShort, _
    ioMapContent As Byte() _
) As Nullable(Of UShort)
Visual C++
public:
Nullable<unsigned short> WriteIoMap(
    unsigned int moduleId,
    unsigned short offset,
    array<unsigned char>^ ioMapContent
)

Parameters

moduleId
Type: System..::..UInt32
The module ID
offset
Type: System..::..UInt16
The offset to write to
ioMapContent
Type: array< System..::..Byte >[]()[][]
IO-map content to be stored in IO-map[index]...IO-map[index+N]

Return Value

The number of data that have been written

Remarks

Reference: BDK, Appendix 1, p. 21.

See Also

NxtCommunicationProtocol Class


NxtCommunicationProtocol Properties

[image] [image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol Properties
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtCommunicationProtocol type exposes the following members.

Properties

 | Name | Description
Public property | IsConnected | Returns a boolean indicating if the NXT brick is connected.

See Also

NxtCommunicationProtocol Class


IsConnected Property

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocol..::..IsConnected Property
NxtCommunicationProtocol Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns a boolean indicating if the NXT brick is connected.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract bool IsConnected { get; }
Visual Basic
Public MustOverride ReadOnly Property IsConnected As Boolean
    Get
Visual C++
public:
virtual property bool IsConnected {
    bool get () abstract;
}

See Also

NxtCommunicationProtocol Class


NxtCommunicationProtocolException Class

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocolException Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Exception thrown when there is an error in the communication to the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class NxtCommunicationProtocolException : NxtException
Visual Basic
Public Class NxtCommunicationProtocolException _
    Inherits NxtException
Visual C++
public ref class NxtCommunicationProtocolException : public NxtException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
NKH.MindSqualls..::..NxtException
NKH.MindSqualls..::..NxtCommunicationProtocolException

See Also

NxtCommunicationProtocolException Members


NxtCommunicationProtocolException Members

[image] [image]

MindSqualls v2.0 documentation
NxtCommunicationProtocolException Members
NxtCommunicationProtocolException Class Constructors Methods Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtCommunicationProtocolException type exposes the following members.

Constructors

 | Name | Description
Public method | NxtCommunicationProtocolException | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString() override. (Overrides Exception..::..ToString()()()().)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

NxtCommunicationProtocolException Class


NxtCommunicationProtocolException Constructor

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocolException Constructor
NxtCommunicationProtocolException Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtCommunicationProtocolException(
    NxtCommand command,
    NxtErrorMessage errorMessage,
    string Message
)
Visual Basic
Public Sub New ( _
    command As NxtCommand, _
    errorMessage As NxtErrorMessage, _
    Message As String _
)
Visual C++
public:
NxtCommunicationProtocolException(
    NxtCommand command,
    NxtErrorMessage errorMessage,
    String^ Message
)

Parameters

command
Type: NKH.MindSqualls..::..NxtCommand
The command
errorMessage
Type: NKH.MindSqualls..::..NxtErrorMessage
The error code
Message
Type: System..::..String
The exception message

See Also

NxtCommunicationProtocolException Class


NxtCommunicationProtocolException Methods

[image] [image]

MindSqualls v2.0 documentation
NxtCommunicationProtocolException Methods
NxtCommunicationProtocolException Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtCommunicationProtocolException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString() override. (Overrides Exception..::..ToString()()()().)

See Also

NxtCommunicationProtocolException Class


ToString Method

[image]

MindSqualls v2.0 documentation
NxtCommunicationProtocolException..::..ToString Method
NxtCommunicationProtocolException Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

ToString() override.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

... TBD ...

Implements

_Exception..::..ToString()()()()

See Also

NxtCommunicationProtocolException Class


NxtCommunicationProtocolException Properties

[image] [image]

MindSqualls v2.0 documentation
NxtCommunicationProtocolException Properties
NxtCommunicationProtocolException Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtCommunicationProtocolException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NxtCommunicationProtocolException Class


NxtCommunicationProtocolException Events

[image] [image]

MindSqualls v2.0 documentation
NxtCommunicationProtocolException Events
NxtCommunicationProtocolException Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtCommunicationProtocolException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

NxtCommunicationProtocolException Class


NxtConnectionException Class

[image]

MindSqualls v2.0 documentation
NxtConnectionException Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This exception is thrown when there is no connection to the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class NxtConnectionException : NxtException
Visual Basic
Public Class NxtConnectionException _
    Inherits NxtException
Visual C++
public ref class NxtConnectionException : public NxtException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
NKH.MindSqualls..::..NxtException
NKH.MindSqualls..::..NxtConnectionException

See Also

NxtConnectionException Members


NxtConnectionException Members

[image] [image]

MindSqualls v2.0 documentation
NxtConnectionException Members
NxtConnectionException Class Constructors Methods Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtConnectionException type exposes the following members.

Constructors

 | Name | Description
Public method | NxtConnectionException | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

NxtConnectionException Class


NxtConnectionException Constructor

[image]

MindSqualls v2.0 documentation
NxtConnectionException Constructor
NxtConnectionException Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtConnectionException(
    string Message
)
Visual Basic
Public Sub New ( _
    Message As String _
)
Visual C++
public:
NxtConnectionException(
    String^ Message
)

Parameters

Message
Type: System..::..String

[Missing <param name="Message"/> documentation for "M:NKH.MindSqualls.NxtConnectionException.#ctor(System.String)"]

See Also

NxtConnectionException Class


NxtConnectionException Methods

[image] [image]

MindSqualls v2.0 documentation
NxtConnectionException Methods
NxtConnectionException Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtConnectionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

NxtConnectionException Class


NxtConnectionException Properties

[image] [image]

MindSqualls v2.0 documentation
NxtConnectionException Properties
NxtConnectionException Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtConnectionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NxtConnectionException Class


NxtConnectionException Events

[image] [image]

MindSqualls v2.0 documentation
NxtConnectionException Events
NxtConnectionException Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtConnectionException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

NxtConnectionException Class


NxtDigitalSensor Class

[image]

MindSqualls v2.0 documentation
NxtDigitalSensor Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Abstract class representing a Digital sensor, i.e. a sensor using the I2C protocol.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class NxtDigitalSensor : NxtSensor
Visual Basic
Public MustInherit Class NxtDigitalSensor _
    Inherits NxtSensor
Visual C++
public ref class NxtDigitalSensor abstract : public NxtSensor

Remarks

The "Device Memory Arrangement" for a Digital sensor is specified at p. 10 of the document:

LEGO MINDSTORMS NXT,
Hardware Developer Kit

which can be downloaded at:
http://mindstorms.lego.com/overview/NXTreme.aspx

The Ultrasonic sensor protocol is specifed in appendix 7 of the HDK.

"Digital I/O Communication Methods" is also explained in the Executable File Specification document, p. 70-72.

.oOo.

According to the LEGO MINDSTORMS NXT Hardware Developer Kit p. 7, sensors is divided into three types: active sensors (e.g. Robotics Invention Systems sensors), passive sensors (e.g. the NXT touch, light, and sound sensors), and digital sensors (e.g. the NXT ultrasonic sensor and the HiTechnic compass sensor). The three abstract classes NxtActiveSensor, NxtPassiveSensor, and NxtDigitalSensor reflect this.

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtPollable
NKH.MindSqualls..::..NxtSensor
NKH.MindSqualls..::..NxtDigitalSensor
NKH.MindSqualls..::..HiTechnicAccelerationSensor
NKH.MindSqualls..::..HiTechnicColorSensor
NKH.MindSqualls..::..HiTechnicCompassSensor
NKH.MindSqualls..::..NxtUltrasonicSensor

See Also

NxtDigitalSensor Members
NKH.MindSqualls Namespace
NKH.MindSqualls..::..NxtActiveSensor
NKH.MindSqualls..::..NxtPassiveSensor


NxtDigitalSensor Members

[image] [image]

MindSqualls v2.0 documentation
NxtDigitalSensor Members
NxtDigitalSensor Class Constructors Methods Fields Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtDigitalSensor type exposes the following members.

Constructors

 | Name | Description
Public method | NxtDigitalSensor | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Poll the sensor (Inherited from NxtSensor.)
Public method | ReadProductId | Returns the name of the manufacturer, e.g. "LEGO".
Public method | ReadSensorType | Returns the sensor type, e.g. "Sonar".
Public method | ReadVersion | Returns the version of the sensor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtDigitalSensor Class


NxtDigitalSensor Constructor

[image]

MindSqualls v2.0 documentation
NxtDigitalSensor Constructor
NxtDigitalSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtDigitalSensor()
Visual Basic
Public Sub New
Visual C++
public:
NxtDigitalSensor()

See Also

NxtDigitalSensor Class


NxtDigitalSensor Fields

[image] [image]

MindSqualls v2.0 documentation
NxtDigitalSensor Fields
NxtDigitalSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtDigitalSensor type exposes the following members.

Fields

 | Name | Description
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

See Also

NxtDigitalSensor Class


NxtDigitalSensor Methods

[image] [image]

MindSqualls v2.0 documentation
NxtDigitalSensor Methods
NxtDigitalSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtDigitalSensor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Poll the sensor (Inherited from NxtSensor.)
Public method | ReadProductId | Returns the name of the manufacturer, e.g. "LEGO".
Public method | ReadSensorType | Returns the sensor type, e.g. "Sonar".
Public method | ReadVersion | Returns the version of the sensor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NxtDigitalSensor Class


ReadProductId Method

[image]

MindSqualls v2.0 documentation
NxtDigitalSensor..::..ReadProductId Method
NxtDigitalSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the name of the manufacturer, e.g. "LEGO".

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ReadProductId()
Visual Basic
Public Function ReadProductId As String
Visual C++
public:
String^ ReadProductId()

Return Value

... TBD ...

See Also

NxtDigitalSensor Class


ReadSensorType Method

[image]

MindSqualls v2.0 documentation
NxtDigitalSensor..::..ReadSensorType Method
NxtDigitalSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the sensor type, e.g. "Sonar".

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ReadSensorType()
Visual Basic
Public Function ReadSensorType As String
Visual C++
public:
String^ ReadSensorType()

Return Value

... TBD ...

See Also

NxtDigitalSensor Class


ReadVersion Method

[image]

MindSqualls v2.0 documentation
NxtDigitalSensor..::..ReadVersion Method
NxtDigitalSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the version of the sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ReadVersion()
Visual Basic
Public Function ReadVersion As String
Visual C++
public:
String^ ReadVersion()

Return Value

... TBD ...

See Also

NxtDigitalSensor Class


NxtDigitalSensor Properties

[image] [image]

MindSqualls v2.0 documentation
NxtDigitalSensor Properties
NxtDigitalSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtDigitalSensor type exposes the following members.

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

See Also

NxtDigitalSensor Class


NxtDigitalSensor Events

[image] [image]

MindSqualls v2.0 documentation
NxtDigitalSensor Events
NxtDigitalSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtDigitalSensor type exposes the following members.

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtDigitalSensor Class


NxtErrorMessage Enumeration

[image]

MindSqualls v2.0 documentation
NxtErrorMessage Enumeration
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

ERROR MESSAGE BACK TO THE HOST

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum NxtErrorMessage
Visual Basic
Public Enumeration NxtErrorMessage
Visual C++
public enum class NxtErrorMessage

Members

Member name | Value | Description
Succes | 0 | BDK, Appendix 2, p. 12.
PendingCommunicationTransactionInProgress | 32 | BDK, Appendix 2, p. 12.
SpecifiedMailboxQueueIsEmpty | 64 | BDK, Appendix 2, p. 12.
NoMoreHandles | 129 | BDK, Appendix 1, p. 16.
NoSpace | 130 | BDK, Appendix 1, p. 16.
NoMoreFiles | 131 | BDK, Appendix 1, p. 16.
EndOfFileExpected | 132 | BDK, Appendix 1, p. 16.
EndOfFile | 133 | BDK, Appendix 1, p. 16.
NotALinearFile | 134 | BDK, Appendix 1, p. 16.
FileNotFound | 135 | BDK, Appendix 1, p. 16.
HandleAllReadyClosed | 136 | BDK, Appendix 1, p. 16.
NoLinearSpace | 137 | BDK, Appendix 1, p. 16.
UndefinedError | 138 | BDK, Appendix 1, p. 16.
FileIsBusy | 139 | BDK, Appendix 1, p. 16.
NoWriteBuffers | 140 | BDK, Appendix 1, p. 16.
AppendNotPossible | 141 | BDK, Appendix 1, p. 16.
FileIsFull | 142 | BDK, Appendix 1, p. 16.
FileExists | 143 | BDK, Appendix 1, p. 16.
ModuleNotFound | 144 | BDK, Appendix 1, p. 16.
OutIfBoundary | 145 | BDK, Appendix 1, p. 16.
IllegalFileName | 146 | BDK, Appendix 1, p. 16.
IllegalHandle | 147 | BDK, Appendix 1, p. 16.
RequestFailed | 189 | BDK, Appendix 2, p. 12.
UnknownCommandOpcode | 190 | BDK, Appendix 2, p. 12.
InsanePacket | 191 | BDK, Appendix 2, p. 12.
DataContainsOutOfRangeValues | 192 | BDK, Appendix 2, p. 12.
CommunicationBusError | 221 | BDK, Appendix 2, p. 12.
NoFreeMemoryInCommunicationBuffer | 222 | BDK, Appendix 2, p. 12.
SpecifiedChannelOrConnectionIsNotValid | 223 | BDK, Appendix 2, p. 12.
SpecifiedChannelOrConnectionNotConfiguredOrBusy | 224 | BDK, Appendix 2, p. 12.
NoActiveProgram | 236 | BDK, Appendix 2, p. 12.
IllegalSizeSpecified | 237 | BDK, Appendix 2, p. 12.
IllegalMailboxQueueIdSpecified | 238 | BDK, Appendix 2, p. 12.
AttemptedToAccessInvalidFieldOfAStructure | 239 | BDK, Appendix 2, p. 12.
BadInputOrOutputSpecified | 240 | BDK, Appendix 2, p. 12.
InsufficientMemoryAvailable | 251 | BDK, Appendix 2, p. 12.
BadArguments | 255 | BDK, Appendix 2, p. 12.

Remarks

Reference: BDK, Appendix 1, p. 16.
Reference: BDK, Appendix 2, p. 12.

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


NxtException Class

[image]

MindSqualls v2.0 documentation
NxtException Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Generic NXT exception.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class NxtException : ApplicationException
Visual Basic
Public Class NxtException _
    Inherits ApplicationException
Visual C++
public ref class NxtException : public ApplicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
NKH.MindSqualls..::..NxtException
NKH.MindSqualls..::..NxtCommunicationProtocolException
NKH.MindSqualls..::..NxtConnectionException

See Also

NxtException Members


NxtException Members

[image] [image]

MindSqualls v2.0 documentation
NxtException Members
NxtException Class Constructors Methods Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtException type exposes the following members.

Constructors

 | Name | Description
Public method | NxtException | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

NxtException Class


NxtException Constructor

[image]

MindSqualls v2.0 documentation
NxtException Constructor
NxtException Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtException(
    string Message
)
Visual Basic
Public Sub New ( _
    Message As String _
)
Visual C++
public:
NxtException(
    String^ Message
)

Parameters

Message
Type: System..::..String
The exception message.

See Also

NxtException Class


NxtException Methods

[image] [image]

MindSqualls v2.0 documentation
NxtException Methods
NxtException Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

NxtException Class


NxtException Properties

[image] [image]

MindSqualls v2.0 documentation
NxtException Properties
NxtException Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NxtException Class


NxtException Events

[image] [image]

MindSqualls v2.0 documentation
NxtException Events
NxtException Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

NxtException Class


NxtFindFileReply Structure

[image]

MindSqualls v2.0 documentation
NxtFindFileReply Structure
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reply type for the FindFirst() and FindNext() functions.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public struct NxtFindFileReply
Visual Basic
Public Structure NxtFindFileReply
Visual C++
public value class NxtFindFileReply

See Also

NxtFindFileReply Members
NKH.MindSqualls Namespace
NxtCommunicationProtocolFindFirst()()()()
NxtCommunicationProtocolFindNext()()()()


NxtFindFileReply Members

[image] [image]

MindSqualls v2.0 documentation
NxtFindFileReply Members
NxtFindFileReply Structure Methods Fields See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtFindFileReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | fileFound | Boolean indicating if a file was found or not.
Public field | fileName | The file name.
Public field | fileSize | The filesize.
Public field | handle | The file handle.

See Also

NxtFindFileReply Structure


NxtFindFileReply Fields

[image] [image]

MindSqualls v2.0 documentation
NxtFindFileReply Fields
NxtFindFileReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtFindFileReply type exposes the following members.

Fields

 | Name | Description
Public field | fileFound | Boolean indicating if a file was found or not.
Public field | fileName | The file name.
Public field | fileSize | The filesize.
Public field | handle | The file handle.

See Also

NxtFindFileReply Structure


fileFound Field

[image]

MindSqualls v2.0 documentation
NxtFindFileReply..::..fileFound Field
NxtFindFileReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Boolean indicating if a file was found or not.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool fileFound
Visual Basic
Public fileFound As Boolean
Visual C++
public:
bool fileFound

See Also

NxtFindFileReply Structure


fileName Field

[image]

MindSqualls v2.0 documentation
NxtFindFileReply..::..fileName Field
NxtFindFileReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The file name.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string fileName
Visual Basic
Public fileName As String
Visual C++
public:
String^ fileName

See Also

NxtFindFileReply Structure


fileSize Field

[image]

MindSqualls v2.0 documentation
NxtFindFileReply..::..fileSize Field
NxtFindFileReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The filesize.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public uint fileSize
Visual Basic
Public fileSize As UInteger
Visual C++
public:
unsigned int fileSize

See Also

NxtFindFileReply Structure


handle Field

[image]

MindSqualls v2.0 documentation
NxtFindFileReply..::..handle Field
NxtFindFileReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The file handle.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte handle
Visual Basic
Public handle As Byte
Visual C++
public:
unsigned char handle

See Also

NxtFindFileReply Structure


NxtFindFileReply Methods

[image] [image]

MindSqualls v2.0 documentation
NxtFindFileReply Methods
NxtFindFileReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtFindFileReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

NxtFindFileReply Structure


NxtGetDeviceInfoReply Structure

[image]

MindSqualls v2.0 documentation
NxtGetDeviceInfoReply Structure
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reply type for the GetDeviceInfo() function.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public struct NxtGetDeviceInfoReply
Visual Basic
Public Structure NxtGetDeviceInfoReply
Visual C++
public value class NxtGetDeviceInfoReply

See Also

NxtGetDeviceInfoReply Members
NKH.MindSqualls Namespace
NxtCommunicationProtocol..::..GetDeviceInfo()()()()


NxtGetDeviceInfoReply Members

[image] [image]

MindSqualls v2.0 documentation
NxtGetDeviceInfoReply Members
NxtGetDeviceInfoReply Structure Methods Fields See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtGetDeviceInfoReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | bluetoothSignalStrength | The bluetooth signal strength.
Public field | btAdress | The bluetooth address.
Public field | freeUserFlash | The size of the free user flash.
Public field | nxtName | The name of the NXT brick.

See Also

NxtGetDeviceInfoReply Structure


NxtGetDeviceInfoReply Fields

[image] [image]

MindSqualls v2.0 documentation
NxtGetDeviceInfoReply Fields
NxtGetDeviceInfoReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtGetDeviceInfoReply type exposes the following members.

Fields

 | Name | Description
Public field | bluetoothSignalStrength | The bluetooth signal strength.
Public field | btAdress | The bluetooth address.
Public field | freeUserFlash | The size of the free user flash.
Public field | nxtName | The name of the NXT brick.

See Also

NxtGetDeviceInfoReply Structure


bluetoothSignalStrength Field

[image]

MindSqualls v2.0 documentation
NxtGetDeviceInfoReply..::..bluetoothSignalStrength Field
NxtGetDeviceInfoReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The bluetooth signal strength.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public uint bluetoothSignalStrength
Visual Basic
Public bluetoothSignalStrength As UInteger
Visual C++
public:
unsigned int bluetoothSignalStrength

See Also

NxtGetDeviceInfoReply Structure


btAdress Field

[image]

MindSqualls v2.0 documentation
NxtGetDeviceInfoReply..::..btAdress Field
NxtGetDeviceInfoReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The bluetooth address.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte[] btAdress
Visual Basic
Public btAdress As Byte()
Visual C++
public:
array<unsigned char>^ btAdress

See Also

NxtGetDeviceInfoReply Structure


freeUserFlash Field

[image]

MindSqualls v2.0 documentation
NxtGetDeviceInfoReply..::..freeUserFlash Field
NxtGetDeviceInfoReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The size of the free user flash.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public uint freeUserFlash
Visual Basic
Public freeUserFlash As UInteger
Visual C++
public:
unsigned int freeUserFlash

See Also

NxtGetDeviceInfoReply Structure


nxtName Field

[image]

MindSqualls v2.0 documentation
NxtGetDeviceInfoReply..::..nxtName Field
NxtGetDeviceInfoReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The name of the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string nxtName
Visual Basic
Public nxtName As String
Visual C++
public:
String^ nxtName

See Also

NxtGetDeviceInfoReply Structure


NxtGetDeviceInfoReply Methods

[image] [image]

MindSqualls v2.0 documentation
NxtGetDeviceInfoReply Methods
NxtGetDeviceInfoReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtGetDeviceInfoReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

NxtGetDeviceInfoReply Structure


NxtGetFirmwareVersionReply Structure

[image]

MindSqualls v2.0 documentation
NxtGetFirmwareVersionReply Structure
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reply type for the GetFirmwareVersion() function.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public struct NxtGetFirmwareVersionReply
Visual Basic
Public Structure NxtGetFirmwareVersionReply
Visual C++
public value class NxtGetFirmwareVersionReply

See Also

NxtGetFirmwareVersionReply Members
NKH.MindSqualls Namespace
NxtCommunicationProtocol..::..GetFirmwareVersion()()()()


NxtGetFirmwareVersionReply Members

[image] [image]

MindSqualls v2.0 documentation
NxtGetFirmwareVersionReply Members
NxtGetFirmwareVersionReply Structure Methods Fields See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtGetFirmwareVersionReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | firmwareVersion | The firmware version.
Public field | protocolVersion | The protocol version.

See Also

NxtGetFirmwareVersionReply Structure


NxtGetFirmwareVersionReply Fields

[image] [image]

MindSqualls v2.0 documentation
NxtGetFirmwareVersionReply Fields
NxtGetFirmwareVersionReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtGetFirmwareVersionReply type exposes the following members.

Fields

 | Name | Description
Public field | firmwareVersion | The firmware version.
Public field | protocolVersion | The protocol version.

See Also

NxtGetFirmwareVersionReply Structure


firmwareVersion Field

[image]

MindSqualls v2.0 documentation
NxtGetFirmwareVersionReply..::..firmwareVersion Field
NxtGetFirmwareVersionReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The firmware version.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Version firmwareVersion
Visual Basic
Public firmwareVersion As Version
Visual C++
public:
Version^ firmwareVersion

See Also

NxtGetFirmwareVersionReply Structure


protocolVersion Field

[image]

MindSqualls v2.0 documentation
NxtGetFirmwareVersionReply..::..protocolVersion Field
NxtGetFirmwareVersionReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The protocol version.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Version protocolVersion
Visual Basic
Public protocolVersion As Version
Visual C++
public:
Version^ protocolVersion

See Also

NxtGetFirmwareVersionReply Structure


NxtGetFirmwareVersionReply Methods

[image] [image]

MindSqualls v2.0 documentation
NxtGetFirmwareVersionReply Methods
NxtGetFirmwareVersionReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtGetFirmwareVersionReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

NxtGetFirmwareVersionReply Structure


NxtGetInputValuesReply Structure

[image]

MindSqualls v2.0 documentation
NxtGetInputValuesReply Structure
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reply type for the GetInputValues() function.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public struct NxtGetInputValuesReply
Visual Basic
Public Structure NxtGetInputValuesReply
Visual C++
public value class NxtGetInputValuesReply

See Also

NxtGetInputValuesReply Members
NKH.MindSqualls Namespace
NxtCommunicationProtocolGetInputValues()()()()


NxtGetInputValuesReply Members

[image] [image]

MindSqualls v2.0 documentation
NxtGetInputValuesReply Members
NxtGetInputValuesReply Structure Methods Fields See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtGetInputValuesReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | calibrated | A boolean indicating if the returned result is calibrated or not.
Public field | calibratedValue | The calibrated value.
Public field | normalizedAdValue | The normalized A/D value.
Public field | rawAdValue | The raw A/D value.
Public field | scaledValue | The scaled value.
Public field | sensorMode | The sensor mode.
Public field | sensorType | The sensor type.
Public field | valid | A boolean indicating if the returned result is valid or not.

See Also

NxtGetInputValuesReply Structure


NxtGetInputValuesReply Fields

[image] [image]

MindSqualls v2.0 documentation
NxtGetInputValuesReply Fields
NxtGetInputValuesReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtGetInputValuesReply type exposes the following members.

Fields

 | Name | Description
Public field | calibrated | A boolean indicating if the returned result is calibrated or not.
Public field | calibratedValue | The calibrated value.
Public field | normalizedAdValue | The normalized A/D value.
Public field | rawAdValue | The raw A/D value.
Public field | scaledValue | The scaled value.
Public field | sensorMode | The sensor mode.
Public field | sensorType | The sensor type.
Public field | valid | A boolean indicating if the returned result is valid or not.

See Also

NxtGetInputValuesReply Structure


calibrated Field

[image]

MindSqualls v2.0 documentation
NxtGetInputValuesReply..::..calibrated Field
NxtGetInputValuesReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

A boolean indicating if the returned result is calibrated or not.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool calibrated
Visual Basic
Public calibrated As Boolean
Visual C++
public:
bool calibrated

See Also

NxtGetInputValuesReply Structure


calibratedValue Field

[image]

MindSqualls v2.0 documentation
NxtGetInputValuesReply..::..calibratedValue Field
NxtGetInputValuesReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The calibrated value.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public short calibratedValue
Visual Basic
Public calibratedValue As Short
Visual C++
public:
short calibratedValue

See Also

NxtGetInputValuesReply Structure


normalizedAdValue Field

[image]

MindSqualls v2.0 documentation
NxtGetInputValuesReply..::..normalizedAdValue Field
NxtGetInputValuesReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The normalized A/D value.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ushort normalizedAdValue
Visual Basic
Public normalizedAdValue As UShort
Visual C++
public:
unsigned short normalizedAdValue

See Also

NxtGetInputValuesReply Structure


rawAdValue Field

[image]

MindSqualls v2.0 documentation
NxtGetInputValuesReply..::..rawAdValue Field
NxtGetInputValuesReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The raw A/D value.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ushort rawAdValue
Visual Basic
Public rawAdValue As UShort
Visual C++
public:
unsigned short rawAdValue

See Also

NxtGetInputValuesReply Structure


scaledValue Field

[image]

MindSqualls v2.0 documentation
NxtGetInputValuesReply..::..scaledValue Field
NxtGetInputValuesReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The scaled value.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public short scaledValue
Visual Basic
Public scaledValue As Short
Visual C++
public:
short scaledValue

See Also

NxtGetInputValuesReply Structure


sensorMode Field

[image]

MindSqualls v2.0 documentation
NxtGetInputValuesReply..::..sensorMode Field
NxtGetInputValuesReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The sensor mode.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtSensorMode sensorMode
Visual Basic
Public sensorMode As NxtSensorMode
Visual C++
public:
NxtSensorMode sensorMode

See Also

NxtGetInputValuesReply Structure


sensorType Field

[image]

MindSqualls v2.0 documentation
NxtGetInputValuesReply..::..sensorType Field
NxtGetInputValuesReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The sensor type.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtSensorType sensorType
Visual Basic
Public sensorType As NxtSensorType
Visual C++
public:
NxtSensorType sensorType

See Also

NxtGetInputValuesReply Structure


valid Field

[image]

MindSqualls v2.0 documentation
NxtGetInputValuesReply..::..valid Field
NxtGetInputValuesReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

A boolean indicating if the returned result is valid or not.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool valid
Visual Basic
Public valid As Boolean
Visual C++
public:
bool valid

See Also

NxtGetInputValuesReply Structure


NxtGetInputValuesReply Methods

[image] [image]

MindSqualls v2.0 documentation
NxtGetInputValuesReply Methods
NxtGetInputValuesReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtGetInputValuesReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

NxtGetInputValuesReply Structure


NxtGetOutputStateReply Structure

[image]

MindSqualls v2.0 documentation
NxtGetOutputStateReply Structure
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reply type for the GetOutputState() function.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public struct NxtGetOutputStateReply
Visual Basic
Public Structure NxtGetOutputStateReply
Visual C++
public value class NxtGetOutputStateReply

See Also

NxtGetOutputStateReply Members
NKH.MindSqualls Namespace
NxtCommunicationProtocolGetOutputState()()()()


NxtGetOutputStateReply Members

[image] [image]

MindSqualls v2.0 documentation
NxtGetOutputStateReply Members
NxtGetOutputStateReply Structure Methods Fields See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtGetOutputStateReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString()-override. (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | blockTachoCount | The block tacho count.
Public field | mode | The motor mode.
Public field | power | The motor power.
Public field | regulationMode | The regulation mode.
Public field | rotationCount | The rotation count.
Public field | runState | The run state.
Public field | tachoCount | The tacho count.
Public field | tachoLimit | The tacho limit in degrees, 0 means unlimited.
Public field | turnRatio | The turn ratio.

See Also

NxtGetOutputStateReply Structure


NxtGetOutputStateReply Fields

[image] [image]

MindSqualls v2.0 documentation
NxtGetOutputStateReply Fields
NxtGetOutputStateReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtGetOutputStateReply type exposes the following members.

Fields

 | Name | Description
Public field | blockTachoCount | The block tacho count.
Public field | mode | The motor mode.
Public field | power | The motor power.
Public field | regulationMode | The regulation mode.
Public field | rotationCount | The rotation count.
Public field | runState | The run state.
Public field | tachoCount | The tacho count.
Public field | tachoLimit | The tacho limit in degrees, 0 means unlimited.
Public field | turnRatio | The turn ratio.

See Also

NxtGetOutputStateReply Structure


blockTachoCount Field

[image]

MindSqualls v2.0 documentation
NxtGetOutputStateReply..::..blockTachoCount Field
NxtGetOutputStateReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The block tacho count.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int blockTachoCount
Visual Basic
Public blockTachoCount As Integer
Visual C++
public:
int blockTachoCount

See Also

NxtGetOutputStateReply Structure


mode Field

[image]

MindSqualls v2.0 documentation
NxtGetOutputStateReply..::..mode Field
NxtGetOutputStateReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The motor mode.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtMotorMode mode
Visual Basic
Public mode As NxtMotorMode
Visual C++
public:
NxtMotorMode mode

See Also

NxtGetOutputStateReply Structure


power Field

[image]

MindSqualls v2.0 documentation
NxtGetOutputStateReply..::..power Field
NxtGetOutputStateReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The motor power.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public sbyte power
Visual Basic
Public power As SByte
Visual C++
public:
signed char power

See Also

NxtGetOutputStateReply Structure


regulationMode Field

[image]

MindSqualls v2.0 documentation
NxtGetOutputStateReply..::..regulationMode Field
NxtGetOutputStateReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The regulation mode.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtMotorRegulationMode regulationMode
Visual Basic
Public regulationMode As NxtMotorRegulationMode
Visual C++
public:
NxtMotorRegulationMode regulationMode

See Also

NxtGetOutputStateReply Structure


rotationCount Field

[image]

MindSqualls v2.0 documentation
NxtGetOutputStateReply..::..rotationCount Field
NxtGetOutputStateReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The rotation count.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int rotationCount
Visual Basic
Public rotationCount As Integer
Visual C++
public:
int rotationCount

See Also

NxtGetOutputStateReply Structure


runState Field

[image]

MindSqualls v2.0 documentation
NxtGetOutputStateReply..::..runState Field
NxtGetOutputStateReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The run state.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtMotorRunState runState
Visual Basic
Public runState As NxtMotorRunState
Visual C++
public:
NxtMotorRunState runState

See Also

NxtGetOutputStateReply Structure


tachoCount Field

[image]

MindSqualls v2.0 documentation
NxtGetOutputStateReply..::..tachoCount Field
NxtGetOutputStateReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The tacho count.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int tachoCount
Visual Basic
Public tachoCount As Integer
Visual C++
public:
int tachoCount

See Also

NxtGetOutputStateReply Structure


tachoLimit Field

[image]

MindSqualls v2.0 documentation
NxtGetOutputStateReply..::..tachoLimit Field
NxtGetOutputStateReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The tacho limit in degrees, 0 means unlimited.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public uint tachoLimit
Visual Basic
Public tachoLimit As UInteger
Visual C++
public:
unsigned int tachoLimit

See Also

NxtGetOutputStateReply Structure


turnRatio Field

[image]

MindSqualls v2.0 documentation
NxtGetOutputStateReply..::..turnRatio Field
NxtGetOutputStateReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The turn ratio.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public sbyte turnRatio
Visual Basic
Public turnRatio As SByte
Visual C++
public:
signed char turnRatio

See Also

NxtGetOutputStateReply Structure


NxtGetOutputStateReply Methods

[image] [image]

MindSqualls v2.0 documentation
NxtGetOutputStateReply Methods
NxtGetOutputStateReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtGetOutputStateReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString()-override. (Overrides ValueType..::..ToString()()()().)

See Also

NxtGetOutputStateReply Structure


ToString Method

[image]

MindSqualls v2.0 documentation
NxtGetOutputStateReply..::..ToString Method
NxtGetOutputStateReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

ToString()-override.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

... TBD ...

See Also

NxtGetOutputStateReply Structure


NxtLightSensor Class

[image]

MindSqualls v2.0 documentation
NxtLightSensor Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Class representing the Light sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class NxtLightSensor : NxtPassiveSensor
Visual Basic
Public Class NxtLightSensor _
    Inherits NxtPassiveSensor
Visual C++
public ref class NxtLightSensor : public NxtPassiveSensor

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtPollable
NKH.MindSqualls..::..NxtSensor
NKH.MindSqualls..::..NxtPassiveSensor
NKH.MindSqualls..::..NxtLightSensor

See Also

NxtLightSensor Members


NxtLightSensor Members

[image] [image]

MindSqualls v2.0 documentation
NxtLightSensor Members
NxtLightSensor Class Constructors Methods Fields Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtLightSensor type exposes the following members.

Constructors

 | Name | Description
Public method | NxtLightSensor | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Polls the sensor, and fires the NXT-G like events if appropriate. (Overrides NxtPassiveSensor..::..Poll()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | pollData | The data from the last poll of the sensor. (Inherited from NxtPassiveSensor.)
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

Properties

 | Name | Description
Public property | GenerateLight | Indicates if the sensor should supply its own light.
Public property | Intensity | The intensity of the measured light.
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)
Public property | ThresholdIntensity | Threshold intensity.

Events

 | Name | Description
Public event | OnAboveThresholdIntensity | This event is fired whenever the measured light intensity passes above the threshold-intensity.
Public event | OnBelowThresholdIntensity | This event is fired whenever the measured light intensity passes below the threshold-intensity.
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtLightSensor Class


NxtLightSensor Constructor

[image]

MindSqualls v2.0 documentation
NxtLightSensor Constructor
NxtLightSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtLightSensor()
Visual Basic
Public Sub New
Visual C++
public:
NxtLightSensor()

See Also

NxtLightSensor Class


NxtLightSensor Fields

[image] [image]

MindSqualls v2.0 documentation
NxtLightSensor Fields
NxtLightSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtLightSensor type exposes the following members.

Fields

 | Name | Description
Protected field | pollData | The data from the last poll of the sensor. (Inherited from NxtPassiveSensor.)
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

See Also

NxtLightSensor Class


NxtLightSensor Methods

[image] [image]

MindSqualls v2.0 documentation
NxtLightSensor Methods
NxtLightSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtLightSensor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Polls the sensor, and fires the NXT-G like events if appropriate. (Overrides NxtPassiveSensor..::..Poll()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NxtLightSensor Class


Poll Method

[image]

MindSqualls v2.0 documentation
NxtLightSensor..::..Poll Method
NxtLightSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Polls the sensor, and fires the NXT-G like events if appropriate.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Poll()
Visual Basic
Public Overrides Sub Poll
Visual C++
public:
virtual void Poll() override

See Also

NxtLightSensor Class
NKH.MindSqualls Namespace
NxtLightSensor..::..ThresholdIntensity
NxtLightSensor..::..OnAboveThresholdIntensity
NxtLightSensor..::..OnBelowThresholdIntensity


NxtLightSensor Properties

[image] [image]

MindSqualls v2.0 documentation
NxtLightSensor Properties
NxtLightSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtLightSensor type exposes the following members.

Properties

 | Name | Description
Public property | GenerateLight | Indicates if the sensor should supply its own light.
Public property | Intensity | The intensity of the measured light.
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)
Public property | ThresholdIntensity | Threshold intensity.

See Also

NxtLightSensor Class


GenerateLight Property

[image]

MindSqualls v2.0 documentation
NxtLightSensor..::..GenerateLight Property
NxtLightSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Indicates if the sensor should supply its own light.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool GenerateLight { get; set; }
Visual Basic
Public Property GenerateLight As Boolean
    Get
    Set
Visual C++
public:
property bool GenerateLight {
    bool get ();
    void set (bool value);
}

See Also

NxtLightSensor Class


Intensity Property

[image]

MindSqualls v2.0 documentation
NxtLightSensor..::..Intensity Property
NxtLightSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The intensity of the measured light.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> Intensity { get; }
Visual Basic
Public ReadOnly Property Intensity As Nullable(Of Byte)
    Get
Visual C++
public:
property Nullable<unsigned char> Intensity {
    Nullable<unsigned char> get ();
}

See Also

NxtLightSensor Class


ThresholdIntensity Property

[image]

MindSqualls v2.0 documentation
NxtLightSensor..::..ThresholdIntensity Property
NxtLightSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Threshold intensity.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte ThresholdIntensity { get; set; }
Visual Basic
Public Property ThresholdIntensity As Byte
    Get
    Set
Visual C++
public:
property unsigned char ThresholdIntensity {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

NxtLightSensor Class
NKH.MindSqualls Namespace
NxtLightSensor..::..OnAboveThresholdIntensity
NxtLightSensor..::..OnBelowThresholdIntensity


NxtLightSensor Events

[image] [image]

MindSqualls v2.0 documentation
NxtLightSensor Events
NxtLightSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtLightSensor type exposes the following members.

Events

 | Name | Description
Public event | OnAboveThresholdIntensity | This event is fired whenever the measured light intensity passes above the threshold-intensity.
Public event | OnBelowThresholdIntensity | This event is fired whenever the measured light intensity passes below the threshold-intensity.
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtLightSensor Class


OnAboveThresholdIntensity Event

[image]

MindSqualls v2.0 documentation
NxtLightSensor..::..OnAboveThresholdIntensity Event
NxtLightSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired whenever the measured light intensity passes above the threshold-intensity.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event NxtSensorEvent OnAboveThresholdIntensity
Visual Basic
Public Event OnAboveThresholdIntensity As NxtSensorEvent
Visual C++
public:
 event NxtSensorEvent^ OnAboveThresholdIntensity {
    void add (NxtSensorEvent^ value);
    void remove (NxtSensorEvent^ value);
}

See Also

NxtLightSensor Class
NKH.MindSqualls Namespace
NxtLightSensor..::..ThresholdIntensity
NxtLightSensor..::..OnBelowThresholdIntensity


OnBelowThresholdIntensity Event

[image]

MindSqualls v2.0 documentation
NxtLightSensor..::..OnBelowThresholdIntensity Event
NxtLightSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired whenever the measured light intensity passes below the threshold-intensity.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event NxtSensorEvent OnBelowThresholdIntensity
Visual Basic
Public Event OnBelowThresholdIntensity As NxtSensorEvent
Visual C++
public:
 event NxtSensorEvent^ OnBelowThresholdIntensity {
    void add (NxtSensorEvent^ value);
    void remove (NxtSensorEvent^ value);
}

See Also

NxtLightSensor Class
NKH.MindSqualls Namespace
NxtLightSensor..::..ThresholdIntensity
NxtLightSensor..::..OnAboveThresholdIntensity


NxtMailbox Enumeration

[image]

MindSqualls v2.0 documentation
NxtMailbox Enumeration
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: BDK, Appendix 2, p. 9.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum NxtMailbox
Visual Basic
Public Enumeration NxtMailbox
Visual C++
public enum class NxtMailbox

Members

Member name | Value | Description
Box0 | 0 | ... TBD ...
Box1 | 1 | ... TBD ...
Box2 | 2 | ... TBD ...
Box3 | 3 | ... TBD ...
Box4 | 4 | ... TBD ...
Box5 | 5 | ... TBD ...
Box6 | 6 | ... TBD ...
Box7 | 7 | ... TBD ...
Box8 | 8 | ... TBD ...
Box9 | 9 | ... TBD ...

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


NxtMailbox2 Enumeration

[image]

MindSqualls v2.0 documentation
NxtMailbox2 Enumeration
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: BDK, Appendix 2, p. 9.
Reference: BDK, Appendix 2, p. 11. (see MessageRead() function).

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum NxtMailbox2
Visual Basic
Public Enumeration NxtMailbox2
Visual C++
public enum class NxtMailbox2

Members

Member name | Value | Description
Box0 | 0 | ... TBD ...
Box1 | 1 | ... TBD ...
Box2 | 2 | ... TBD ...
Box3 | 3 | ... TBD ...
Box4 | 4 | ... TBD ...
Box5 | 5 | ... TBD ...
Box6 | 6 | ... TBD ...
Box7 | 7 | ... TBD ...
Box8 | 8 | ... TBD ...
Box9 | 9 | ... TBD ...
Box10 | 10 | ... TBD ...
Box11 | 11 | ... TBD ...
Box12 | 12 | ... TBD ...
Box13 | 13 | ... TBD ...
Box14 | 14 | ... TBD ...
Box15 | 15 | ... TBD ...
Box16 | 16 | ... TBD ...
Box17 | 17 | ... TBD ...
Box18 | 18 | ... TBD ...
Box19 | 19 | ... TBD ...

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


NxtMotor Class

[image]

MindSqualls v2.0 documentation
NxtMotor Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Class representing a motor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class NxtMotor : NxtPollable
Visual Basic
Public Class NxtMotor _
    Inherits NxtPollable
Visual C++
public ref class NxtMotor : public NxtPollable

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtPollable
NKH.MindSqualls..::..NxtMotor

See Also

NxtMotor Members
NKH.MindSqualls Namespace
NKH.MindSqualls..::..NxtMotorSync


NxtMotor Members

[image] [image]

MindSqualls v2.0 documentation
NxtMotor Members
NxtMotor Class Constructors Methods Fields Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtMotor type exposes the following members.

Constructors

 | Name | Description
Public method | NxtMotor()()()() | Constructor.
Public method | NxtMotor(Boolean) | Constructor.

Methods

 | Name | Description
Public method | Brake | Brake the motor.
Public method | Coast | Coast the motor.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Idle | Sets the motor into the idle state.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Poll the motor. (Overrides NxtPollable..::..Poll()()()().)
Public method | ResetMotorPosition | Resets the motors tachometer.
Public method | Run | Run the motor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | pollData | The data from the previous poll of the motor.

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)
Public property | TachoCount | Returns the current tacho count of the motor (in degrees).
Public property | TriggerTachoCount | Trigger value for the tachocount.

Events

 | Name | Description
Public event | OnAboveTachoCount | This event is fired when the tachocount of the motor goes above the trigger-value.
Public event | OnBelowTachoCount | This event is fired when the tachocount of the motor goes below the trigger-value.
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtMotor Class


NxtMotor Constructor

[image] [image]

MindSqualls v2.0 documentation
NxtMotor Constructor
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Overload List

 | Name | Description
Public method | NxtMotor()()()() | Constructor.
Public method | NxtMotor(Boolean) | Constructor.

See Also

NxtMotor Class
NxtMotor Members


NxtMotor Constructor

[image]

MindSqualls v2.0 documentation
NxtMotor Constructor
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtMotor()
Visual Basic
Public Sub New
Visual C++
public:
NxtMotor()

See Also

NxtMotor Class
NxtMotor Overload


NxtMotor Constructor (Boolean)

[image]

MindSqualls v2.0 documentation
NxtMotor Constructor (Boolean)
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtMotor(
    bool reverse
)
Visual Basic
Public Sub New ( _
    reverse As Boolean _
)
Visual C++
public:
NxtMotor(
    bool reverse
)

Parameters

reverse
Type: System..::..Boolean
Indicates if the motor-direction should be reversed.

See Also

NxtMotor Class
NxtMotor Overload


NxtMotor Fields

[image] [image]

MindSqualls v2.0 documentation
NxtMotor Fields
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtMotor type exposes the following members.

Fields

 | Name | Description
Protected field | pollData | The data from the previous poll of the motor.

See Also

NxtMotor Class


pollData Field

[image]

MindSqualls v2.0 documentation
NxtMotor..::..pollData Field
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The data from the previous poll of the motor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected Nullable<NxtGetOutputStateReply> pollData
Visual Basic
Protected pollData As Nullable(Of NxtGetOutputStateReply)
Visual C++
protected:
Nullable<NxtGetOutputStateReply> pollData

See Also

NxtMotor Class


NxtMotor Methods

[image] [image]

MindSqualls v2.0 documentation
NxtMotor Methods
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtMotor type exposes the following members.

Methods

 | Name | Description
Public method | Brake | Brake the motor.
Public method | Coast | Coast the motor.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Idle | Sets the motor into the idle state.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Poll the motor. (Overrides NxtPollable..::..Poll()()()().)
Public method | ResetMotorPosition | Resets the motors tachometer.
Public method | Run | Run the motor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NxtMotor Class


Brake Method

[image]

MindSqualls v2.0 documentation
NxtMotor..::..Brake Method
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Brake the motor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Brake()
Visual Basic
Public Sub Brake
Visual C++
public:
void Brake()

See Also

NxtMotor Class


Coast Method

[image]

MindSqualls v2.0 documentation
NxtMotor..::..Coast Method
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Coast the motor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Coast()
Visual Basic
Public Sub Coast
Visual C++
public:
void Coast()

See Also

NxtMotor Class


Idle Method

[image]

MindSqualls v2.0 documentation
NxtMotor..::..Idle Method
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Sets the motor into the idle state.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Idle()
Visual Basic
Public Sub Idle
Visual C++
public:
void Idle()

See Also

NxtMotor Class


Poll Method

[image]

MindSqualls v2.0 documentation
NxtMotor..::..Poll Method
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Poll the motor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Poll()
Visual Basic
Public Overrides Sub Poll
Visual C++
public:
virtual void Poll() override

See Also

NxtMotor Class


ResetMotorPosition Method

[image]

MindSqualls v2.0 documentation
NxtMotor..::..ResetMotorPosition Method
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Resets the motors tachometer.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void ResetMotorPosition(
    bool relative
)
Visual Basic
Public Sub ResetMotorPosition ( _
    relative As Boolean _
)
Visual C++
public:
void ResetMotorPosition(
    bool relative
)

Parameters

relative
Type: System..::..Boolean
True if the reset is relative to the last movement, false if the absolute position

See Also

NxtMotor Class
NKH.MindSqualls Namespace
NxtCommunicationProtocolResetMotorPosition()()()()


Run Method

[image]

MindSqualls v2.0 documentation
NxtMotor..::..Run Method
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Run the motor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Run(
    sbyte power,
    uint tachoLimit
)
Visual Basic
Public Sub Run ( _
    power As SByte, _
    tachoLimit As UInteger _
)
Visual C++
public:
void Run(
    signed char power,
    unsigned int tachoLimit
)

Parameters

power
Type: System..::..SByte
The power for the motor
tachoLimit
Type: System..::..UInt32
The duration in degrees, 0 = unlimited

See Also

NxtMotor Class


NxtMotor Properties

[image] [image]

MindSqualls v2.0 documentation
NxtMotor Properties
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtMotor type exposes the following members.

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)
Public property | TachoCount | Returns the current tacho count of the motor (in degrees).
Public property | TriggerTachoCount | Trigger value for the tachocount.

See Also

NxtMotor Class


TachoCount Property

[image]

MindSqualls v2.0 documentation
NxtMotor..::..TachoCount Property
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the current tacho count of the motor (in degrees).

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<int> TachoCount { get; }
Visual Basic
Public ReadOnly Property TachoCount As Nullable(Of Integer)
    Get
Visual C++
public:
property Nullable<int> TachoCount {
    Nullable<int> get ();
}

See Also

NxtMotor Class


TriggerTachoCount Property

[image]

MindSqualls v2.0 documentation
NxtMotor..::..TriggerTachoCount Property
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Trigger value for the tachocount.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte TriggerTachoCount { get; set; }
Visual Basic
Public Property TriggerTachoCount As Byte
    Get
    Set
Visual C++
public:
property unsigned char TriggerTachoCount {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

NxtMotor Class
NKH.MindSqualls Namespace
NxtMotor..::..OnBelowTachoCount
NxtMotor..::..OnAboveTachoCount


NxtMotor Events

[image] [image]

MindSqualls v2.0 documentation
NxtMotor Events
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtMotor type exposes the following members.

Events

 | Name | Description
Public event | OnAboveTachoCount | This event is fired when the tachocount of the motor goes above the trigger-value.
Public event | OnBelowTachoCount | This event is fired when the tachocount of the motor goes below the trigger-value.
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtMotor Class


OnAboveTachoCount Event

[image]

MindSqualls v2.0 documentation
NxtMotor..::..OnAboveTachoCount Event
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired when the tachocount of the motor goes above the trigger-value.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event NxtMotorEvent OnAboveTachoCount
Visual Basic
Public Event OnAboveTachoCount As NxtMotorEvent
Visual C++
public:
 event NxtMotorEvent^ OnAboveTachoCount {
    void add (NxtMotorEvent^ value);
    void remove (NxtMotorEvent^ value);
}

See Also

NxtMotor Class
NKH.MindSqualls Namespace
NxtMotor..::..TriggerTachoCount
NxtMotor..::..OnBelowTachoCount
NxtMotor..::..Poll()()()()


OnBelowTachoCount Event

[image]

MindSqualls v2.0 documentation
NxtMotor..::..OnBelowTachoCount Event
NxtMotor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired when the tachocount of the motor goes below the trigger-value.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event NxtMotorEvent OnBelowTachoCount
Visual Basic
Public Event OnBelowTachoCount As NxtMotorEvent
Visual C++
public:
 event NxtMotorEvent^ OnBelowTachoCount {
    void add (NxtMotorEvent^ value);
    void remove (NxtMotorEvent^ value);
}

See Also

NxtMotor Class
NKH.MindSqualls Namespace
NxtMotor..::..TriggerTachoCount
NxtMotor..::..OnAboveTachoCount
NxtMotor..::..Poll()()()()


NxtMotorEvent Delegate

[image]

MindSqualls v2.0 documentation
NxtMotorEvent Delegate
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Delegate used for the NXT-G like events implemented in the motor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public delegate void NxtMotorEvent(
    NxtMotor motor
)
Visual Basic
Public Delegate Sub NxtMotorEvent ( _
    motor As NxtMotor _
)
Visual C++
public delegate void NxtMotorEvent(
    NxtMotor^ motor
)

Parameters

motor
Type: NKH.MindSqualls..::..NxtMotor
The motor

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


NxtMotorMode Enumeration

[image]

MindSqualls v2.0 documentation
NxtMotorMode Enumeration
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: BDK, Appendix 2, p. 6.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[FlagsAttribute]
public enum NxtMotorMode
Visual Basic
<FlagsAttribute> _
Public Enumeration NxtMotorMode
Visual C++
[FlagsAttribute]
public enum class NxtMotorMode

Members

Member name | Value | Description
MOTORON | 1 | Turn on the specified motor.
BRAKE | 2 | Use run/break instead of run/float in PWM.
REGULATED | 4 | Turns on the regulation.

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


NxtMotorPort Enumeration

[image]

MindSqualls v2.0 documentation
NxtMotorPort Enumeration
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: BDK, Appendix 2, p. 6.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum NxtMotorPort
Visual Basic
Public Enumeration NxtMotorPort
Visual C++
public enum class NxtMotorPort

Members

Member name | Value | Description
PortA | 0 | Motor port A.
PortB | 1 | Motor port B.
PortC | 2 | Motor port C.
All | 255 | All motor ports.

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


NxtMotorRegulationMode Enumeration

[image]

MindSqualls v2.0 documentation
NxtMotorRegulationMode Enumeration
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: BDK, Appendix 2, p. 6.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum NxtMotorRegulationMode
Visual Basic
Public Enumeration NxtMotorRegulationMode
Visual C++
public enum class NxtMotorRegulationMode

Members

Member name | Value | Description
REGULATION_MODE_IDLE | 0 | No regulation will be enabled.
REGULATION_MODE_MOTOR_SPEED | 1 | Power control will be enabled on specified output.
REGULATION_MODE_MOTOR_SYNC | 2 | Syncronization will be enabled (Needs enabled on two output).

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


NxtMotorRunState Enumeration

[image]

MindSqualls v2.0 documentation
NxtMotorRunState Enumeration
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: BDK, Appendix 2, p. 6.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[FlagsAttribute]
public enum NxtMotorRunState
Visual Basic
<FlagsAttribute> _
Public Enumeration NxtMotorRunState
Visual C++
[FlagsAttribute]
public enum class NxtMotorRunState

Members

Member name | Value | Description
MOTOR_RUN_STATE_IDLE | 0 | Output will be idle.
MOTOR_RUN_STATE_RAMPUP | 16 | Output will ramp-up.
MOTOR_RUN_STATE_RUNNING | 32 | Output will be running.
MOTOR_RUN_STATE_RAMPDOWN | 64 | Output will ramp-down.

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


NxtMotorSync Class

[image]

MindSqualls v2.0 documentation
NxtMotorSync Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Class representing a synchronized pair of motors.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class NxtMotorSync
Visual Basic
Public Class NxtMotorSync
Visual C++
public ref class NxtMotorSync

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtMotorSync

See Also

NxtMotorSync Members
NKH.MindSqualls Namespace
NKH.MindSqualls..::..NxtMotor


NxtMotorSync Members

[image] [image]

MindSqualls v2.0 documentation
NxtMotorSync Members
NxtMotorSync Class Constructors Methods See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtMotorSync type exposes the following members.

Constructors

 | Name | Description
Public method | NxtMotorSync | Constructor.

Methods

 | Name | Description
Public method | Brake | Brakes the motors.
Public method | Coast | Coasts the motors.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Idle | Puts the motors into the idle state.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetMotorPosition | Calls ResetMotorPosition() on both motors.
Public method | Run | Run the motors (in sync).
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NxtMotorSync Class


NxtMotorSync Constructor

[image]

MindSqualls v2.0 documentation
NxtMotorSync Constructor
NxtMotorSync Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtMotorSync(
    NxtMotor motorX,
    NxtMotor motorY
)
Visual Basic
Public Sub New ( _
    motorX As NxtMotor, _
    motorY As NxtMotor _
)
Visual C++
public:
NxtMotorSync(
    NxtMotor^ motorX,
    NxtMotor^ motorY
)

Parameters

motorX
Type: NKH.MindSqualls..::..NxtMotor
The 1. motor of the synchronized pair
motorY
Type: NKH.MindSqualls..::..NxtMotor
The 2. motor of the synchronized pair

See Also

NxtMotorSync Class


NxtMotorSync Methods

[image] [image]

MindSqualls v2.0 documentation
NxtMotorSync Methods
NxtMotorSync Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtMotorSync type exposes the following members.

Methods

 | Name | Description
Public method | Brake | Brakes the motors.
Public method | Coast | Coasts the motors.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Idle | Puts the motors into the idle state.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetMotorPosition | Calls ResetMotorPosition() on both motors.
Public method | Run | Run the motors (in sync).
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NxtMotorSync Class


Brake Method

[image]

MindSqualls v2.0 documentation
NxtMotorSync..::..Brake Method
NxtMotorSync Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Brakes the motors.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Brake()
Visual Basic
Public Sub Brake
Visual C++
public:
void Brake()

See Also

NxtMotorSync Class


Coast Method

[image]

MindSqualls v2.0 documentation
NxtMotorSync..::..Coast Method
NxtMotorSync Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Coasts the motors.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Coast()
Visual Basic
Public Sub Coast
Visual C++
public:
void Coast()

See Also

NxtMotorSync Class


Idle Method

[image]

MindSqualls v2.0 documentation
NxtMotorSync..::..Idle Method
NxtMotorSync Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Puts the motors into the idle state.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Idle()
Visual Basic
Public Sub Idle
Visual C++
public:
void Idle()

See Also

NxtMotorSync Class


ResetMotorPosition Method

[image]

MindSqualls v2.0 documentation
NxtMotorSync..::..ResetMotorPosition Method
NxtMotorSync Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Calls ResetMotorPosition() on both motors.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void ResetMotorPosition(
    bool relative
)
Visual Basic
Public Sub ResetMotorPosition ( _
    relative As Boolean _
)
Visual C++
public:
void ResetMotorPosition(
    bool relative
)

Parameters

relative
Type: System..::..Boolean
True if the reset is relative to the last movement, false if the absolute position

See Also

NxtMotorSync Class
NKH.MindSqualls Namespace
NxtMotorResetMotorPosition()()()()


Run Method

[image]

MindSqualls v2.0 documentation
NxtMotorSync..::..Run Method
NxtMotorSync Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Run the motors (in sync).

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Run(
    sbyte power,
    ushort tachoLimit,
    sbyte turnRatio
)
Visual Basic
Public Sub Run ( _
    power As SByte, _
    tachoLimit As UShort, _
    turnRatio As SByte _
)
Visual C++
public:
void Run(
    signed char power,
    unsigned short tachoLimit,
    signed char turnRatio
)

Parameters

power
Type: System..::..SByte
The poser
tachoLimit
Type: System..::..UInt16
The tacho limit in degrees, 0 means unlimited
turnRatio
Type: System..::..SByte
The turn ratio

See Also

NxtMotorSync Class


NxtNoSensor Class

[image]

MindSqualls v2.0 documentation
NxtNoSensor Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Class representing a port with no sensor attached.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class NxtNoSensor : NxtSensor
Visual Basic
Public Class NxtNoSensor _
    Inherits NxtSensor
Visual C++
public ref class NxtNoSensor : public NxtSensor

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtPollable
NKH.MindSqualls..::..NxtSensor
NKH.MindSqualls..::..NxtNoSensor

See Also

NxtNoSensor Members


NxtNoSensor Members

[image] [image]

MindSqualls v2.0 documentation
NxtNoSensor Members
NxtNoSensor Class Constructors Methods Fields Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtNoSensor type exposes the following members.

Constructors

 | Name | Description
Public method | NxtNoSensor | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | This empty Pool-method effectively cancels polling on this port. (Overrides NxtSensor..::..Poll()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtNoSensor Class


NxtNoSensor Constructor

[image]

MindSqualls v2.0 documentation
NxtNoSensor Constructor
NxtNoSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtNoSensor()
Visual Basic
Public Sub New
Visual C++
public:
NxtNoSensor()

See Also

NxtNoSensor Class


NxtNoSensor Fields

[image] [image]

MindSqualls v2.0 documentation
NxtNoSensor Fields
NxtNoSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtNoSensor type exposes the following members.

Fields

 | Name | Description
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

See Also

NxtNoSensor Class


NxtNoSensor Methods

[image] [image]

MindSqualls v2.0 documentation
NxtNoSensor Methods
NxtNoSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtNoSensor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | This empty Pool-method effectively cancels polling on this port. (Overrides NxtSensor..::..Poll()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NxtNoSensor Class


Poll Method

[image]

MindSqualls v2.0 documentation
NxtNoSensor..::..Poll Method
NxtNoSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This empty Pool-method effectively cancels polling on this port.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Poll()
Visual Basic
Public Overrides Sub Poll
Visual C++
public:
virtual void Poll() override

See Also

NxtNoSensor Class


NxtNoSensor Properties

[image] [image]

MindSqualls v2.0 documentation
NxtNoSensor Properties
NxtNoSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtNoSensor type exposes the following members.

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

See Also

NxtNoSensor Class


NxtNoSensor Events

[image] [image]

MindSqualls v2.0 documentation
NxtNoSensor Events
NxtNoSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtNoSensor type exposes the following members.

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtNoSensor Class


NxtOpenAppendDataReply Structure

[image]

MindSqualls v2.0 documentation
NxtOpenAppendDataReply Structure
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reply type for the OpenAppendData() function.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public struct NxtOpenAppendDataReply
Visual Basic
Public Structure NxtOpenAppendDataReply
Visual C++
public value class NxtOpenAppendDataReply

See Also

NxtOpenAppendDataReply Members
NKH.MindSqualls Namespace
NxtCommunicationProtocolOpenAppendData()()()()


NxtOpenAppendDataReply Members

[image] [image]

MindSqualls v2.0 documentation
NxtOpenAppendDataReply Members
NxtOpenAppendDataReply Structure Methods Fields See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtOpenAppendDataReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | availableFilesize | Available file size.
Public field | handle | File handle.

See Also

NxtOpenAppendDataReply Structure


NxtOpenAppendDataReply Fields

[image] [image]

MindSqualls v2.0 documentation
NxtOpenAppendDataReply Fields
NxtOpenAppendDataReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtOpenAppendDataReply type exposes the following members.

Fields

 | Name | Description
Public field | availableFilesize | Available file size.
Public field | handle | File handle.

See Also

NxtOpenAppendDataReply Structure


availableFilesize Field

[image]

MindSqualls v2.0 documentation
NxtOpenAppendDataReply..::..availableFilesize Field
NxtOpenAppendDataReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Available file size.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public uint availableFilesize
Visual Basic
Public availableFilesize As UInteger
Visual C++
public:
unsigned int availableFilesize

See Also

NxtOpenAppendDataReply Structure


handle Field

[image]

MindSqualls v2.0 documentation
NxtOpenAppendDataReply..::..handle Field
NxtOpenAppendDataReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

File handle.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte handle
Visual Basic
Public handle As Byte
Visual C++
public:
unsigned char handle

See Also

NxtOpenAppendDataReply Structure


NxtOpenAppendDataReply Methods

[image] [image]

MindSqualls v2.0 documentation
NxtOpenAppendDataReply Methods
NxtOpenAppendDataReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtOpenAppendDataReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

NxtOpenAppendDataReply Structure


NxtOpenReadReply Structure

[image]

MindSqualls v2.0 documentation
NxtOpenReadReply Structure
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reply type for the OpenRead() function.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public struct NxtOpenReadReply
Visual Basic
Public Structure NxtOpenReadReply
Visual C++
public value class NxtOpenReadReply

See Also

NxtOpenReadReply Members
NKH.MindSqualls Namespace
NxtCommunicationProtocolOpenRead()()()()


NxtOpenReadReply Members

[image] [image]

MindSqualls v2.0 documentation
NxtOpenReadReply Members
NxtOpenReadReply Structure Methods Fields See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtOpenReadReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | fileSize | File size.
Public field | handle | File handle.

See Also

NxtOpenReadReply Structure


NxtOpenReadReply Fields

[image] [image]

MindSqualls v2.0 documentation
NxtOpenReadReply Fields
NxtOpenReadReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtOpenReadReply type exposes the following members.

Fields

 | Name | Description
Public field | fileSize | File size.
Public field | handle | File handle.

See Also

NxtOpenReadReply Structure


fileSize Field

[image]

MindSqualls v2.0 documentation
NxtOpenReadReply..::..fileSize Field
NxtOpenReadReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

File size.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public uint fileSize
Visual Basic
Public fileSize As UInteger
Visual C++
public:
unsigned int fileSize

See Also

NxtOpenReadReply Structure


handle Field

[image]

MindSqualls v2.0 documentation
NxtOpenReadReply..::..handle Field
NxtOpenReadReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

File handle.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte handle
Visual Basic
Public handle As Byte
Visual C++
public:
unsigned char handle

See Also

NxtOpenReadReply Structure


NxtOpenReadReply Methods

[image] [image]

MindSqualls v2.0 documentation
NxtOpenReadReply Methods
NxtOpenReadReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtOpenReadReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

NxtOpenReadReply Structure


NxtPassiveSensor Class

[image]

MindSqualls v2.0 documentation
NxtPassiveSensor Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Abstract class representing a Passive Sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class NxtPassiveSensor : NxtSensor
Visual Basic
Public MustInherit Class NxtPassiveSensor _
    Inherits NxtSensor
Visual C++
public ref class NxtPassiveSensor abstract : public NxtSensor

Remarks

According to the LEGO MINDSTORMS NXT Hardware Developer Kit p. 7, sensors is divided into three types: active sensors (e.g. Robotics Invention Systems sensors), passive sensors (e.g. the NXT touch, light, and sound sensors), and digital sensors (e.g. the NXT ultrasonic sensor and the HiTechnic compass sensor). The three abstract classes NxtActiveSensor, NxtPassiveSensor, and NxtDigitalSensor reflect this.

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtPollable
NKH.MindSqualls..::..NxtSensor
NKH.MindSqualls..::..NxtPassiveSensor
NKH.MindSqualls..::..Nxt2ColorSensor
NKH.MindSqualls..::..NxtLightSensor
NKH.MindSqualls..::..NxtSoundSensor
NKH.MindSqualls..::..NxtTouchSensor

See Also

NxtPassiveSensor Members
NKH.MindSqualls Namespace
NKH.MindSqualls..::..NxtActiveSensor
NKH.MindSqualls..::..NxtDigitalSensor


NxtPassiveSensor Members

[image] [image]

MindSqualls v2.0 documentation
NxtPassiveSensor Members
NxtPassiveSensor Class Constructors Methods Fields Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtPassiveSensor type exposes the following members.

Constructors

 | Name | Description
Public method | NxtPassiveSensor | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Poll the sensor. (Overrides NxtSensor..::..Poll()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | pollData | The data from the last poll of the sensor.
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtPassiveSensor Class


NxtPassiveSensor Constructor

[image]

MindSqualls v2.0 documentation
NxtPassiveSensor Constructor
NxtPassiveSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtPassiveSensor(
    NxtSensorType sensorType,
    NxtSensorMode sensorMode
)
Visual Basic
Public Sub New ( _
    sensorType As NxtSensorType, _
    sensorMode As NxtSensorMode _
)
Visual C++
public:
NxtPassiveSensor(
    NxtSensorType sensorType,
    NxtSensorMode sensorMode
)

Parameters

sensorType
Type: NKH.MindSqualls..::..NxtSensorType
Sensor type
sensorMode
Type: NKH.MindSqualls..::..NxtSensorMode
Sensor mode

See Also

NxtPassiveSensor Class


NxtPassiveSensor Fields

[image] [image]

MindSqualls v2.0 documentation
NxtPassiveSensor Fields
NxtPassiveSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtPassiveSensor type exposes the following members.

Fields

 | Name | Description
Protected field | pollData | The data from the last poll of the sensor.
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

See Also

NxtPassiveSensor Class


pollData Field

[image]

MindSqualls v2.0 documentation
NxtPassiveSensor..::..pollData Field
NxtPassiveSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The data from the last poll of the sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected Nullable<NxtGetInputValuesReply> pollData
Visual Basic
Protected pollData As Nullable(Of NxtGetInputValuesReply)
Visual C++
protected:
Nullable<NxtGetInputValuesReply> pollData

See Also

NxtPassiveSensor Class


NxtPassiveSensor Methods

[image] [image]

MindSqualls v2.0 documentation
NxtPassiveSensor Methods
NxtPassiveSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtPassiveSensor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Poll the sensor. (Overrides NxtSensor..::..Poll()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NxtPassiveSensor Class


Poll Method

[image]

MindSqualls v2.0 documentation
NxtPassiveSensor..::..Poll Method
NxtPassiveSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Poll the sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Poll()
Visual Basic
Public Overrides Sub Poll
Visual C++
public:
virtual void Poll() override

See Also

NxtPassiveSensor Class


NxtPassiveSensor Properties

[image] [image]

MindSqualls v2.0 documentation
NxtPassiveSensor Properties
NxtPassiveSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtPassiveSensor type exposes the following members.

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

See Also

NxtPassiveSensor Class


NxtPassiveSensor Events

[image] [image]

MindSqualls v2.0 documentation
NxtPassiveSensor Events
NxtPassiveSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtPassiveSensor type exposes the following members.

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtPassiveSensor Class


NxtPollable Class

[image]

MindSqualls v2.0 documentation
NxtPollable Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Abstract class used as superclass for the NxtMotor and NxtSensor classes.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class NxtPollable
Visual Basic
Public MustInherit Class NxtPollable
Visual C++
public ref class NxtPollable abstract

Remarks

This class has been modified from using System.Timers.Timer (in versions 1.0 and 1.1) to using System.Threading.Timer in order to be able to function with the compact framework (i.e. to run on a PDA). A special thanks to Giorgio T. for his suggestion.

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtPollable
NKH.MindSqualls..::..NxtMotor
NKH.MindSqualls..::..NxtSensor

See Also

NxtPollable Members


NxtPollable Members

[image] [image]

MindSqualls v2.0 documentation
NxtPollable Members
NxtPollable Class Constructors Methods Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtPollable type exposes the following members.

Constructors

 | Name | Description
Public method | NxtPollable | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Poll the sensor/motor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not.

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled.

See Also

NxtPollable Class


NxtPollable Constructor

[image]

MindSqualls v2.0 documentation
NxtPollable Constructor
NxtPollable Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtPollable()
Visual Basic
Public Sub New
Visual C++
public:
NxtPollable()

See Also

NxtPollable Class


NxtPollable Methods

[image] [image]

MindSqualls v2.0 documentation
NxtPollable Methods
NxtPollable Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtPollable type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Poll the sensor/motor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NxtPollable Class


Poll Method

[image]

MindSqualls v2.0 documentation
NxtPollable..::..Poll Method
NxtPollable Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Poll the sensor/motor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual void Poll()
Visual Basic
Public Overridable Sub Poll
Visual C++
public:
virtual void Poll()

See Also

NxtPollable Class


NxtPollable Properties

[image] [image]

MindSqualls v2.0 documentation
NxtPollable Properties
NxtPollable Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtPollable type exposes the following members.

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not.

See Also

NxtPollable Class


PollInterval Property

[image]

MindSqualls v2.0 documentation
NxtPollable..::..PollInterval Property
NxtPollable Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Indicates if the sensor, or motor, is auto-polled or not.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int PollInterval { get; set; }
Visual Basic
Public Property PollInterval As Integer
    Get
    Set
Visual C++
public:
property int PollInterval {
    int get ();
    void set (int value);
}

Field Value

A positive value means that the sensor is auto-pooled, and with the indicated interval i milliseconds.

Zero, or a negative value, means that the sensor is not auto-polled.

See Also

NxtPollable Class


NxtPollable Events

[image] [image]

MindSqualls v2.0 documentation
NxtPollable Events
NxtPollable Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtPollable type exposes the following members.

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled.

See Also

NxtPollable Class


OnPolled Event

[image]

MindSqualls v2.0 documentation
NxtPollable..::..OnPolled Event
NxtPollable Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired when the sensor, or motor, is polled.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event Polled OnPolled
Visual Basic
Public Event OnPolled As Polled
Visual C++
public:
 event Polled^ OnPolled {
    void add (Polled^ value);
    void remove (Polled^ value);
}

See Also

NxtPollable Class


NxtRequestModuleReply Structure

[image]

MindSqualls v2.0 documentation
NxtRequestModuleReply Structure
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reply type for the RequestFirstModule() and RequestNextModule() functions.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public struct NxtRequestModuleReply
Visual Basic
Public Structure NxtRequestModuleReply
Visual C++
public value class NxtRequestModuleReply

See Also

NxtRequestModuleReply Members
NKH.MindSqualls Namespace
NxtCommunicationProtocolRequestFirstModule()()()()
NxtCommunicationProtocolRequestNextModule()()()()


NxtRequestModuleReply Members

[image] [image]

MindSqualls v2.0 documentation
NxtRequestModuleReply Members
NxtRequestModuleReply Structure Methods Fields See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtRequestModuleReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | handle | Module handle.
Public field | ModuleFound | Boolean indicating if a module was found, or not.
Public field | moduleId | Module ID.
Public field | moduleIdCC | Module ID, CC-value.
Public field | moduleIdFF | Module ID, FF-value.
Public field | moduleIdPP | Module ID, PP-value.
Public field | moduleIdTT | Module ID, TT-value.
Public field | moduleIoMapSize | Module IO-map size.
Public field | moduleName | Module name.
Public field | moduleSize | Module size.

See Also

NxtRequestModuleReply Structure


NxtRequestModuleReply Fields

[image] [image]

MindSqualls v2.0 documentation
NxtRequestModuleReply Fields
NxtRequestModuleReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtRequestModuleReply type exposes the following members.

Fields

 | Name | Description
Public field | handle | Module handle.
Public field | ModuleFound | Boolean indicating if a module was found, or not.
Public field | moduleId | Module ID.
Public field | moduleIdCC | Module ID, CC-value.
Public field | moduleIdFF | Module ID, FF-value.
Public field | moduleIdPP | Module ID, PP-value.
Public field | moduleIdTT | Module ID, TT-value.
Public field | moduleIoMapSize | Module IO-map size.
Public field | moduleName | Module name.
Public field | moduleSize | Module size.

See Also

NxtRequestModuleReply Structure


handle Field

[image]

MindSqualls v2.0 documentation
NxtRequestModuleReply..::..handle Field
NxtRequestModuleReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Module handle.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte handle
Visual Basic
Public handle As Byte
Visual C++
public:
unsigned char handle

See Also

NxtRequestModuleReply Structure


ModuleFound Field

[image]

MindSqualls v2.0 documentation
NxtRequestModuleReply..::..ModuleFound Field
NxtRequestModuleReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Boolean indicating if a module was found, or not.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ModuleFound
Visual Basic
Public ModuleFound As Boolean
Visual C++
public:
bool ModuleFound

See Also

NxtRequestModuleReply Structure


moduleId Field

[image]

MindSqualls v2.0 documentation
NxtRequestModuleReply..::..moduleId Field
NxtRequestModuleReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Module ID.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public uint moduleId
Visual Basic
Public moduleId As UInteger
Visual C++
public:
unsigned int moduleId

See Also

NxtRequestModuleReply Structure


moduleIdCC Field

[image]

MindSqualls v2.0 documentation
NxtRequestModuleReply..::..moduleIdCC Field
NxtRequestModuleReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Module ID, CC-value.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte moduleIdCC
Visual Basic
Public moduleIdCC As Byte
Visual C++
public:
unsigned char moduleIdCC

See Also

NxtRequestModuleReply Structure


moduleIdFF Field

[image]

MindSqualls v2.0 documentation
NxtRequestModuleReply..::..moduleIdFF Field
NxtRequestModuleReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Module ID, FF-value.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte moduleIdFF
Visual Basic
Public moduleIdFF As Byte
Visual C++
public:
unsigned char moduleIdFF

See Also

NxtRequestModuleReply Structure


moduleIdPP Field

[image]

MindSqualls v2.0 documentation
NxtRequestModuleReply..::..moduleIdPP Field
NxtRequestModuleReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Module ID, PP-value.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte moduleIdPP
Visual Basic
Public moduleIdPP As Byte
Visual C++
public:
unsigned char moduleIdPP

See Also

NxtRequestModuleReply Structure


moduleIdTT Field

[image]

MindSqualls v2.0 documentation
NxtRequestModuleReply..::..moduleIdTT Field
NxtRequestModuleReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Module ID, TT-value.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte moduleIdTT
Visual Basic
Public moduleIdTT As Byte
Visual C++
public:
unsigned char moduleIdTT

See Also

NxtRequestModuleReply Structure


moduleIoMapSize Field

[image]

MindSqualls v2.0 documentation
NxtRequestModuleReply..::..moduleIoMapSize Field
NxtRequestModuleReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Module IO-map size.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ushort moduleIoMapSize
Visual Basic
Public moduleIoMapSize As UShort
Visual C++
public:
unsigned short moduleIoMapSize

See Also

NxtRequestModuleReply Structure


moduleName Field

[image]

MindSqualls v2.0 documentation
NxtRequestModuleReply..::..moduleName Field
NxtRequestModuleReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Module name.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string moduleName
Visual Basic
Public moduleName As String
Visual C++
public:
String^ moduleName

See Also

NxtRequestModuleReply Structure


moduleSize Field

[image]

MindSqualls v2.0 documentation
NxtRequestModuleReply..::..moduleSize Field
NxtRequestModuleReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Module size.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public uint moduleSize
Visual Basic
Public moduleSize As UInteger
Visual C++
public:
unsigned int moduleSize

See Also

NxtRequestModuleReply Structure


NxtRequestModuleReply Methods

[image] [image]

MindSqualls v2.0 documentation
NxtRequestModuleReply Methods
NxtRequestModuleReply Structure See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtRequestModuleReply type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

NxtRequestModuleReply Structure


NxtSensor Class

[image]

MindSqualls v2.0 documentation
NxtSensor Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Superclass representing a generic sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class NxtSensor : NxtPollable
Visual Basic
Public MustInherit Class NxtSensor _
    Inherits NxtPollable
Visual C++
public ref class NxtSensor abstract : public NxtPollable

Remarks

Used as base class for the specific sensor classes.

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtPollable
NKH.MindSqualls..::..NxtSensor
NKH.MindSqualls..::..NxtActiveSensor
NKH.MindSqualls..::..NxtDigitalSensor
NKH.MindSqualls..::..NxtNoSensor
NKH.MindSqualls..::..NxtPassiveSensor

See Also

NxtSensor Members


NxtSensor Members

[image] [image]

MindSqualls v2.0 documentation
NxtSensor Members
NxtSensor Class Constructors Methods Fields Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtSensor type exposes the following members.

Constructors

 | Name | Description
Public method | NxtSensor | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Poll the sensor (Overrides NxtPollable..::..Poll()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | sensorPort | The port the sensor is attached to.
Protected field | sensorType | The type of the sensor.

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtSensor Class


NxtSensor Constructor

[image]

MindSqualls v2.0 documentation
NxtSensor Constructor
NxtSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtSensor(
    NxtSensorType sensorType,
    NxtSensorMode sensorMode
)
Visual Basic
Public Sub New ( _
    sensorType As NxtSensorType, _
    sensorMode As NxtSensorMode _
)
Visual C++
public:
NxtSensor(
    NxtSensorType sensorType,
    NxtSensorMode sensorMode
)

Parameters

sensorType
Type: NKH.MindSqualls..::..NxtSensorType
The type of the sensor
sensorMode
Type: NKH.MindSqualls..::..NxtSensorMode
The sensors mode

See Also

NxtSensor Class


NxtSensor Fields

[image] [image]

MindSqualls v2.0 documentation
NxtSensor Fields
NxtSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtSensor type exposes the following members.

Fields

 | Name | Description
Protected field | sensorPort | The port the sensor is attached to.
Protected field | sensorType | The type of the sensor.

See Also

NxtSensor Class


sensorPort Field

[image]

MindSqualls v2.0 documentation
NxtSensor..::..sensorPort Field
NxtSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The port the sensor is attached to.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected NxtSensorPort sensorPort
Visual Basic
Protected sensorPort As NxtSensorPort
Visual C++
protected:
NxtSensorPort sensorPort

See Also

NxtSensor Class


sensorType Field

[image]

MindSqualls v2.0 documentation
NxtSensor..::..sensorType Field
NxtSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The type of the sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected NxtSensorType sensorType
Visual Basic
Protected sensorType As NxtSensorType
Visual C++
protected:
NxtSensorType sensorType

See Also

NxtSensor Class


NxtSensor Methods

[image] [image]

MindSqualls v2.0 documentation
NxtSensor Methods
NxtSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtSensor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Poll the sensor (Overrides NxtPollable..::..Poll()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NxtSensor Class


Poll Method

[image]

MindSqualls v2.0 documentation
NxtSensor..::..Poll Method
NxtSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Poll the sensor

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Poll()
Visual Basic
Public Overrides Sub Poll
Visual C++
public:
virtual void Poll() override

See Also

NxtSensor Class


NxtSensor Properties

[image] [image]

MindSqualls v2.0 documentation
NxtSensor Properties
NxtSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtSensor type exposes the following members.

Properties

 | Name | Description
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

See Also

NxtSensor Class


NxtSensor Events

[image] [image]

MindSqualls v2.0 documentation
NxtSensor Events
NxtSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtSensor type exposes the following members.

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtSensor Class


NxtSensorEvent Delegate

[image]

MindSqualls v2.0 documentation
NxtSensorEvent Delegate
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Delegate used for the NXT-G like events implemented in the various sensors.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public delegate void NxtSensorEvent(
    NxtSensor sensor
)
Visual Basic
Public Delegate Sub NxtSensorEvent ( _
    sensor As NxtSensor _
)
Visual C++
public delegate void NxtSensorEvent(
    NxtSensor^ sensor
)

Parameters

sensor
Type: NKH.MindSqualls..::..NxtSensor
The sensor

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


NxtSensorMode Enumeration

[image]

MindSqualls v2.0 documentation
NxtSensorMode Enumeration
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: BDK, Appendix 2, p. 7.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum NxtSensorMode
Visual Basic
Public Enumeration NxtSensorMode
Visual C++
public enum class NxtSensorMode

Members

Member name | Value | Description
RAWMODE | 0 | ... TBD ...
BOOLEANMODE | 32 | ... TBD ...
TRANSITIONCNTMODE | 64 | ... TBD ...
PERIODCOUNTERMODE | 96 | ... TBD ...
PCTFULLSCALEMODE | 128 | ... TBD ...
CELSIUSMODE | 160 | ... TBD ...
FAHRENHEITMODE | 192 | ... TBD ...
ANGLESTEPMODE | 224 | ... TBD ...

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


NxtSensorPort Enumeration

[image]

MindSqualls v2.0 documentation
NxtSensorPort Enumeration
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: BDK, Appendix 2, p. 7.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum NxtSensorPort
Visual Basic
Public Enumeration NxtSensorPort
Visual C++
public enum class NxtSensorPort

Members

Member name | Value | Description
Port1 | 0 | Sensor port 1.
Port2 | 1 | Sensor port 2.
Port3 | 2 | Sensor port 3.
Port4 | 3 | Sensor port 4.

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


NxtSensorType Enumeration

[image]

MindSqualls v2.0 documentation
NxtSensorType Enumeration
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: BDK, Appendix 2, p. 7.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum NxtSensorType
Visual Basic
Public Enumeration NxtSensorType
Visual C++
public enum class NxtSensorType

Members

Member name | Value | Description
NO_SENSOR | 0 | No sensor configured.
SWITCH | 1 | NXT or RCX touch sensor.
TEMPERATURE | 2 | RCX temperature sensor.
REFLECTION | 3 | RCX light sensor.
ANGLE | 4 | RCX rotation sensor.
LIGHT_ACTIVE | 5 | NXT light sensor with floodlight enabled.
LIGHT_INACTIVE | 6 | NXT light sensor with floodlight disabled.
SOUND_DB | 7 | NXT sound sensor; dB scaling.
SOUND_DBA | 8 | NXT sound sensor; dBA scaling.
CUSTOM | 9 | Unused in NXT programs.
LOWSPEED | 10 | I2C digital sensor.
LOWSPEED_9V | 11 | I2C digital sensor; 9V power.
HIGHSPEED | 12 | Unused in NXT programs.
COLORFULL | 13 | NXT color sensor in color detector mode.
COLORRED | 14 | NXT color sensor in light sensor mode with red light.
COLORGREEN | 15 | NXT color sensor in light sensor mode with green light.
COLORBLUE | 16 | NXT color sensor in light sensor mode with blue light.
COLORNONE | 17 | NXT color sensor in light sensor mode with no light.

Remarks

Explantion of the values is found on p. 46 of the Executable File Specification document.

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff


NxtSoundSensor Class

[image]

MindSqualls v2.0 documentation
NxtSoundSensor Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Class representing the Sound sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class NxtSoundSensor : NxtPassiveSensor
Visual Basic
Public Class NxtSoundSensor _
    Inherits NxtPassiveSensor
Visual C++
public ref class NxtSoundSensor : public NxtPassiveSensor

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtPollable
NKH.MindSqualls..::..NxtSensor
NKH.MindSqualls..::..NxtPassiveSensor
NKH.MindSqualls..::..NxtSoundSensor

See Also

NxtSoundSensor Members


NxtSoundSensor Members

[image] [image]

MindSqualls v2.0 documentation
NxtSoundSensor Members
NxtSoundSensor Class Constructors Methods Fields Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtSoundSensor type exposes the following members.

Constructors

 | Name | Description
Public method | NxtSoundSensor | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Polls the sensor, and fires the NXT-G like events if appropriate. (Overrides NxtPassiveSensor..::..Poll()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | pollData | The data from the last poll of the sensor. (Inherited from NxtPassiveSensor.)
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

Properties

 | Name | Description
Public property | dBA | Indicating if the sensor should return results as dB or as dBA (adjusted for the human ear).
Public property | Intensity | The measured sound intensity.
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)
Public property | ThresholdIntensity | Threshold sound intensity.

Events

 | Name | Description
Public event | OnAboveThresholdIntensity | This event is fired whenever the measured sound intensity passes above the threshold-level.
Public event | OnBelowThresholdIntensity | This event is fired whenever the measured sound intensity passes below the threshold-level.
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtSoundSensor Class


NxtSoundSensor Constructor

[image]

MindSqualls v2.0 documentation
NxtSoundSensor Constructor
NxtSoundSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtSoundSensor()
Visual Basic
Public Sub New
Visual C++
public:
NxtSoundSensor()

See Also

NxtSoundSensor Class


NxtSoundSensor Fields

[image] [image]

MindSqualls v2.0 documentation
NxtSoundSensor Fields
NxtSoundSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtSoundSensor type exposes the following members.

Fields

 | Name | Description
Protected field | pollData | The data from the last poll of the sensor. (Inherited from NxtPassiveSensor.)
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

See Also

NxtSoundSensor Class


NxtSoundSensor Methods

[image] [image]

MindSqualls v2.0 documentation
NxtSoundSensor Methods
NxtSoundSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtSoundSensor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Polls the sensor, and fires the NXT-G like events if appropriate. (Overrides NxtPassiveSensor..::..Poll()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NxtSoundSensor Class


Poll Method

[image]

MindSqualls v2.0 documentation
NxtSoundSensor..::..Poll Method
NxtSoundSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Polls the sensor, and fires the NXT-G like events if appropriate.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Poll()
Visual Basic
Public Overrides Sub Poll
Visual C++
public:
virtual void Poll() override

See Also

NxtSoundSensor Class
NKH.MindSqualls Namespace
NxtSoundSensor..::..ThresholdIntensity
NxtSoundSensor..::..OnAboveThresholdIntensity
NxtSoundSensor..::..OnBelowThresholdIntensity


NxtSoundSensor Properties

[image] [image]

MindSqualls v2.0 documentation
NxtSoundSensor Properties
NxtSoundSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtSoundSensor type exposes the following members.

Properties

 | Name | Description
Public property | dBA | Indicating if the sensor should return results as dB or as dBA (adjusted for the human ear).
Public property | Intensity | The measured sound intensity.
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)
Public property | ThresholdIntensity | Threshold sound intensity.

See Also

NxtSoundSensor Class


dBA Property

[image]

MindSqualls v2.0 documentation
NxtSoundSensor..::..dBA Property
NxtSoundSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Indicating if the sensor should return results as dB or as dBA (adjusted for the human ear).

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool dBA { get; set; }
Visual Basic
Public Property dBA As Boolean
    Get
    Set
Visual C++
public:
property bool dBA {
    bool get ();
    void set (bool value);
}

See Also

NxtSoundSensor Class


Intensity Property

[image]

MindSqualls v2.0 documentation
NxtSoundSensor..::..Intensity Property
NxtSoundSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The measured sound intensity.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> Intensity { get; }
Visual Basic
Public ReadOnly Property Intensity As Nullable(Of Byte)
    Get
Visual C++
public:
property Nullable<unsigned char> Intensity {
    Nullable<unsigned char> get ();
}

See Also

NxtSoundSensor Class
NKH.MindSqualls Namespace
NxtSoundSensor..::..dBA


ThresholdIntensity Property

[image]

MindSqualls v2.0 documentation
NxtSoundSensor..::..ThresholdIntensity Property
NxtSoundSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Threshold sound intensity.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte ThresholdIntensity { get; set; }
Visual Basic
Public Property ThresholdIntensity As Byte
    Get
    Set
Visual C++
public:
property unsigned char ThresholdIntensity {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

NxtSoundSensor Class
NKH.MindSqualls Namespace
NxtSoundSensor..::..OnAboveThresholdIntensity
NxtSoundSensor..::..OnBelowThresholdIntensity


NxtSoundSensor Events

[image] [image]

MindSqualls v2.0 documentation
NxtSoundSensor Events
NxtSoundSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtSoundSensor type exposes the following members.

Events

 | Name | Description
Public event | OnAboveThresholdIntensity | This event is fired whenever the measured sound intensity passes above the threshold-level.
Public event | OnBelowThresholdIntensity | This event is fired whenever the measured sound intensity passes below the threshold-level.
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)

See Also

NxtSoundSensor Class


OnAboveThresholdIntensity Event

[image]

MindSqualls v2.0 documentation
NxtSoundSensor..::..OnAboveThresholdIntensity Event
NxtSoundSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired whenever the measured sound intensity passes above the threshold-level.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event NxtSensorEvent OnAboveThresholdIntensity
Visual Basic
Public Event OnAboveThresholdIntensity As NxtSensorEvent
Visual C++
public:
 event NxtSensorEvent^ OnAboveThresholdIntensity {
    void add (NxtSensorEvent^ value);
    void remove (NxtSensorEvent^ value);
}

See Also

NxtSoundSensor Class
NKH.MindSqualls Namespace
NxtSoundSensor..::..ThresholdIntensity
NxtSoundSensor..::..OnBelowThresholdIntensity
NxtSoundSensor..::..Poll()()()()


OnBelowThresholdIntensity Event

[image]

MindSqualls v2.0 documentation
NxtSoundSensor..::..OnBelowThresholdIntensity Event
NxtSoundSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired whenever the measured sound intensity passes below the threshold-level.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event NxtSensorEvent OnBelowThresholdIntensity
Visual Basic
Public Event OnBelowThresholdIntensity As NxtSensorEvent
Visual C++
public:
 event NxtSensorEvent^ OnBelowThresholdIntensity {
    void add (NxtSensorEvent^ value);
    void remove (NxtSensorEvent^ value);
}

See Also

NxtSoundSensor Class
NKH.MindSqualls Namespace
NxtSoundSensor..::..ThresholdIntensity
NxtSoundSensor..::..OnAboveThresholdIntensity
NxtSoundSensor..::..Poll()()()()


NxtTouchSensor Class

[image]

MindSqualls v2.0 documentation
NxtTouchSensor Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Class representing the Touch sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class NxtTouchSensor : NxtPassiveSensor
Visual Basic
Public Class NxtTouchSensor _
    Inherits NxtPassiveSensor
Visual C++
public ref class NxtTouchSensor : public NxtPassiveSensor

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtPollable
NKH.MindSqualls..::..NxtSensor
NKH.MindSqualls..::..NxtPassiveSensor
NKH.MindSqualls..::..NxtTouchSensor

See Also

NxtTouchSensor Members


NxtTouchSensor Members

[image] [image]

MindSqualls v2.0 documentation
NxtTouchSensor Members
NxtTouchSensor Class Constructors Methods Fields Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtTouchSensor type exposes the following members.

Constructors

 | Name | Description
Public method | NxtTouchSensor | Constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Polls the sensor, and fires the NXT-G like events if appropriate. (Overrides NxtPassiveSensor..::..Poll()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | pollData | The data from the last poll of the sensor. (Inherited from NxtPassiveSensor.)
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

Properties

 | Name | Description
Public property | IsPressed | Indicating if the sensor-button is pressed or not.
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)
Public event | OnPressed | This event is fired when the touch sensor is pressed.
Public event | OnReleased | This event is fired when the touch sensor is released.

See Also

NxtTouchSensor Class


NxtTouchSensor Constructor

[image]

MindSqualls v2.0 documentation
NxtTouchSensor Constructor
NxtTouchSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtTouchSensor()
Visual Basic
Public Sub New
Visual C++
public:
NxtTouchSensor()

See Also

NxtTouchSensor Class


NxtTouchSensor Fields

[image] [image]

MindSqualls v2.0 documentation
NxtTouchSensor Fields
NxtTouchSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtTouchSensor type exposes the following members.

Fields

 | Name | Description
Protected field | pollData | The data from the last poll of the sensor. (Inherited from NxtPassiveSensor.)
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

See Also

NxtTouchSensor Class


NxtTouchSensor Methods

[image] [image]

MindSqualls v2.0 documentation
NxtTouchSensor Methods
NxtTouchSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtTouchSensor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Poll | Polls the sensor, and fires the NXT-G like events if appropriate. (Overrides NxtPassiveSensor..::..Poll()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NxtTouchSensor Class


Poll Method

[image]

MindSqualls v2.0 documentation
NxtTouchSensor..::..Poll Method
NxtTouchSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Polls the sensor, and fires the NXT-G like events if appropriate.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Poll()
Visual Basic
Public Overrides Sub Poll
Visual C++
public:
virtual void Poll() override

See Also

NxtTouchSensor Class
NKH.MindSqualls Namespace
NxtTouchSensor..::..OnPressed
NxtTouchSensor..::..OnReleased


NxtTouchSensor Properties

[image] [image]

MindSqualls v2.0 documentation
NxtTouchSensor Properties
NxtTouchSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtTouchSensor type exposes the following members.

Properties

 | Name | Description
Public property | IsPressed | Indicating if the sensor-button is pressed or not.
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)

See Also

NxtTouchSensor Class


IsPressed Property

[image]

MindSqualls v2.0 documentation
NxtTouchSensor..::..IsPressed Property
NxtTouchSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Indicating if the sensor-button is pressed or not.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<bool> IsPressed { get; }
Visual Basic
Public ReadOnly Property IsPressed As Nullable(Of Boolean)
    Get
Visual C++
public:
property Nullable<bool> IsPressed {
    Nullable<bool> get ();
}

See Also

NxtTouchSensor Class


NxtTouchSensor Events

[image] [image]

MindSqualls v2.0 documentation
NxtTouchSensor Events
NxtTouchSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtTouchSensor type exposes the following members.

Events

 | Name | Description
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)
Public event | OnPressed | This event is fired when the touch sensor is pressed.
Public event | OnReleased | This event is fired when the touch sensor is released.

See Also

NxtTouchSensor Class


OnPressed Event

[image]

MindSqualls v2.0 documentation
NxtTouchSensor..::..OnPressed Event
NxtTouchSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired when the touch sensor is pressed.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event NxtSensorEvent OnPressed
Visual Basic
Public Event OnPressed As NxtSensorEvent
Visual C++
public:
 event NxtSensorEvent^ OnPressed {
    void add (NxtSensorEvent^ value);
    void remove (NxtSensorEvent^ value);
}

See Also

NxtTouchSensor Class
NKH.MindSqualls Namespace
NxtTouchSensor..::..OnReleased
NxtTouchSensor..::..Poll()()()()


OnReleased Event

[image]

MindSqualls v2.0 documentation
NxtTouchSensor..::..OnReleased Event
NxtTouchSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired when the touch sensor is released.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event NxtSensorEvent OnReleased
Visual Basic
Public Event OnReleased As NxtSensorEvent
Visual C++
public:
 event NxtSensorEvent^ OnReleased {
    void add (NxtSensorEvent^ value);
    void remove (NxtSensorEvent^ value);
}

See Also

NxtTouchSensor Class
NKH.MindSqualls Namespace
NxtTouchSensor..::..OnPressed
NxtTouchSensor..::..Poll()()()()


NxtUltrasonicSensor Class

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Class representing the Ultrasonic sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class NxtUltrasonicSensor : NxtDigitalSensor
Visual Basic
Public Class NxtUltrasonicSensor _
    Inherits NxtDigitalSensor
Visual C++
public ref class NxtUltrasonicSensor : public NxtDigitalSensor

Remarks

The I2C protocol for the Ultrasonic sensor is specified in the document:

Lego Mindstorms NXT,
Hardware Developer Kit,
Appendix 7: LEGO MINDSTORMS NXT Ultrasonic Sensor I2C communication protocol

which can be downloaded at:
http://mindstorms.lego.com/overview/NXTreme.aspx

A special thanks goes to Dick Swan and Templar for their invaluable explanations in:
http://forums.nxtasy.org/index.php?showtopic=141

The resulting code stated out being part of the NxtUltrasonicSensor class but has since been moved to the NxtDigitalSensor class.

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtPollable
NKH.MindSqualls..::..NxtSensor
NKH.MindSqualls..::..NxtDigitalSensor
NKH.MindSqualls..::..NxtUltrasonicSensor

See Also

NxtUltrasonicSensor Members


NxtUltrasonicSensor Members

[image] [image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor Members
NxtUltrasonicSensor Class Constructors Methods Fields Properties Events See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtUltrasonicSensor type exposes the following members.

Constructors

 | Name | Description
Public method | NxtUltrasonicSensor | Constructor.

Methods

 | Name | Description
Public method | ContinuousMeasurementCommand | Reference: HDK, Appendix 7, p. 3.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EventCaptureCommand | Reference: HDK, Appendix 7, p. 3.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OffCommand | Reference: HDK, Appendix 7, p. 3.
Public method | Poll | Polls the sensor, and fires the NXT-G like events if appropriate. (Overrides NxtSensor..::..Poll()()()().)
Public method | ReadActualScaleDivisor | Reference: HDK, Appendix 7, p. 3.
Public method | ReadActualScaleFactor | Reference: HDK, Appendix 7, p. 3.
Public method | ReadActualZero | Reference: HDK, Appendix 7, p. 2.
Public method | ReadCommandState | Reference: HDK, Appendix 7, p. 2.
Public method | ReadContinuousMeasurementsInterval | Reference: HDK, Appendix 7, p. 2.
Public method | ReadFactoryScaleDivisor | Returns the factory scale divisor of the sensor.
Public method | ReadFactoryScaleFactor | Returns the "factory scale factor" of the sensor.
Public method | ReadFactoryZero | Returns the "factory zero" of the sensor.
Public method | ReadMeasurementByteX | Reference: HDK, Appendix 7, p. 2.
Public method | ReadMeasurementUnits | Returns the measurement units if the sensor, e.g. "10E-2m".
Public method | ReadProductId | Returns the name of the manufacturer, e.g. "LEGO". (Inherited from NxtDigitalSensor.)
Public method | ReadSensorType | Returns the sensor type, e.g. "Sonar". (Inherited from NxtDigitalSensor.)
Public method | ReadVersion | Returns the version of the sensor. (Inherited from NxtDigitalSensor.)
Public method | RequestWarmReset | Reference: HDK, Appendix 7, p. 3.
Public method | SetActualScaleDivisor | Reference: HDK, Appendix 7, p. 3.
Public method | SetActualScaleFactor | Reference: HDK, Appendix 7, p. 3.
Public method | SetActualZero | Reference: HDK, Appendix 7, p. 3.
Public method | SetContinuousMeasurementInterval | Reference: HDK, Appendix 7, p. 3.
Public method | SingleShotCommand | Reference: HDK, Appendix 7, p. 3.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | pollData | The data from the previous poll of the sensor.
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

Properties

 | Name | Description
Public property | DistanceCm | Returns the measured distance in cm.
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)
Public property | ThresholdDistanceCm | Threshold distance.

Events

 | Name | Description
Public event | OnOutsideThresholdDistanceCm | This event is fired if the sensor does not detect an object within the threshold distance.
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)
Public event | OnWithinThresholdDistanceCm | This event is fired if the sensor detects an object within the threshold distance.

See Also

NxtUltrasonicSensor Class


NxtUltrasonicSensor Constructor

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor Constructor
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Constructor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtUltrasonicSensor()
Visual Basic
Public Sub New
Visual C++
public:
NxtUltrasonicSensor()

See Also

NxtUltrasonicSensor Class


NxtUltrasonicSensor Fields

[image] [image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor Fields
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtUltrasonicSensor type exposes the following members.

Fields

 | Name | Description
Protected field | pollData | The data from the previous poll of the sensor.
Protected field | sensorPort | The port the sensor is attached to. (Inherited from NxtSensor.)
Protected field | sensorType | The type of the sensor. (Inherited from NxtSensor.)

See Also

NxtUltrasonicSensor Class


pollData Field

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..pollData Field
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The data from the previous poll of the sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected Nullable<byte> pollData
Visual Basic
Protected pollData As Nullable(Of Byte)
Visual C++
protected:
Nullable<unsigned char> pollData

See Also

NxtUltrasonicSensor Class
NKH.MindSqualls Namespace
NxtUltrasonicSensor..::..Poll()()()()


NxtUltrasonicSensor Methods

[image] [image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor Methods
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtUltrasonicSensor type exposes the following members.

Methods

 | Name | Description
Public method | ContinuousMeasurementCommand | Reference: HDK, Appendix 7, p. 3.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EventCaptureCommand | Reference: HDK, Appendix 7, p. 3.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OffCommand | Reference: HDK, Appendix 7, p. 3.
Public method | Poll | Polls the sensor, and fires the NXT-G like events if appropriate. (Overrides NxtSensor..::..Poll()()()().)
Public method | ReadActualScaleDivisor | Reference: HDK, Appendix 7, p. 3.
Public method | ReadActualScaleFactor | Reference: HDK, Appendix 7, p. 3.
Public method | ReadActualZero | Reference: HDK, Appendix 7, p. 2.
Public method | ReadCommandState | Reference: HDK, Appendix 7, p. 2.
Public method | ReadContinuousMeasurementsInterval | Reference: HDK, Appendix 7, p. 2.
Public method | ReadFactoryScaleDivisor | Returns the factory scale divisor of the sensor.
Public method | ReadFactoryScaleFactor | Returns the "factory scale factor" of the sensor.
Public method | ReadFactoryZero | Returns the "factory zero" of the sensor.
Public method | ReadMeasurementByteX | Reference: HDK, Appendix 7, p. 2.
Public method | ReadMeasurementUnits | Returns the measurement units if the sensor, e.g. "10E-2m".
Public method | ReadProductId | Returns the name of the manufacturer, e.g. "LEGO". (Inherited from NxtDigitalSensor.)
Public method | ReadSensorType | Returns the sensor type, e.g. "Sonar". (Inherited from NxtDigitalSensor.)
Public method | ReadVersion | Returns the version of the sensor. (Inherited from NxtDigitalSensor.)
Public method | RequestWarmReset | Reference: HDK, Appendix 7, p. 3.
Public method | SetActualScaleDivisor | Reference: HDK, Appendix 7, p. 3.
Public method | SetActualScaleFactor | Reference: HDK, Appendix 7, p. 3.
Public method | SetActualZero | Reference: HDK, Appendix 7, p. 3.
Public method | SetContinuousMeasurementInterval | Reference: HDK, Appendix 7, p. 3.
Public method | SingleShotCommand | Reference: HDK, Appendix 7, p. 3.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NxtUltrasonicSensor Class


ContinuousMeasurementCommand Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..ContinuousMeasurementCommand Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: HDK, Appendix 7, p. 3.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void ContinuousMeasurementCommand()
Visual Basic
Public Sub ContinuousMeasurementCommand
Visual C++
public:
void ContinuousMeasurementCommand()

See Also

NxtUltrasonicSensor Class
NKH.MindSqualls Namespace
NxtUltrasonicSensor..::..ReadContinuousMeasurementsInterval()()()()
NxtUltrasonicSensor..::..SetContinuousMeasurementInterval(Byte)
NxtUltrasonicSensor..::..SingleShotCommand()()()()


EventCaptureCommand Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..EventCaptureCommand Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: HDK, Appendix 7, p. 3.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void EventCaptureCommand()
Visual Basic
Public Sub EventCaptureCommand
Visual C++
public:
void EventCaptureCommand()

See Also

NxtUltrasonicSensor Class


OffCommand Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..OffCommand Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: HDK, Appendix 7, p. 3.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void OffCommand()
Visual Basic
Public Sub OffCommand
Visual C++
public:
void OffCommand()

See Also

NxtUltrasonicSensor Class


Poll Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..Poll Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Polls the sensor, and fires the NXT-G like events if appropriate.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Poll()
Visual Basic
Public Overrides Sub Poll
Visual C++
public:
virtual void Poll() override

See Also

NxtUltrasonicSensor Class
NKH.MindSqualls Namespace
NxtUltrasonicSensor..::..ThresholdDistanceCm
NxtUltrasonicSensor..::..OnWithinThresholdDistanceCm
NxtUltrasonicSensor..::..OnOutsideThresholdDistanceCm


ReadActualScaleDivisor Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..ReadActualScaleDivisor Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: HDK, Appendix 7, p. 3.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> ReadActualScaleDivisor()
Visual Basic
Public Function ReadActualScaleDivisor As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> ReadActualScaleDivisor()

Return Value

... TBD ...

See Also

NxtUltrasonicSensor Class
NKH.MindSqualls Namespace
NxtUltrasonicSensor..::..SetActualScaleDivisor(Byte)


ReadActualScaleFactor Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..ReadActualScaleFactor Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: HDK, Appendix 7, p. 3.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> ReadActualScaleFactor()
Visual Basic
Public Function ReadActualScaleFactor As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> ReadActualScaleFactor()

Return Value

... TBD ...

See Also

NxtUltrasonicSensor Class
NKH.MindSqualls Namespace
NxtUltrasonicSensor..::..SetActualScaleFactor(Byte)


ReadActualZero Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..ReadActualZero Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: HDK, Appendix 7, p. 2.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> ReadActualZero()
Visual Basic
Public Function ReadActualZero As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> ReadActualZero()

Return Value

... TBD ...

See Also

NxtUltrasonicSensor Class
NKH.MindSqualls Namespace
NxtUltrasonicSensor..::..SetActualZero(Byte)


ReadCommandState Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..ReadCommandState Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: HDK, Appendix 7, p. 2.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> ReadCommandState()
Visual Basic
Public Function ReadCommandState As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> ReadCommandState()

Return Value

... TBD ...

See Also

NxtUltrasonicSensor Class


ReadContinuousMeasurementsInterval Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..ReadContinuousMeasurementsInterval Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: HDK, Appendix 7, p. 2.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> ReadContinuousMeasurementsInterval()
Visual Basic
Public Function ReadContinuousMeasurementsInterval As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> ReadContinuousMeasurementsInterval()

Return Value

... TBD ...

See Also

NxtUltrasonicSensor Class
NKH.MindSqualls Namespace
NxtUltrasonicSensor..::..ContinuousMeasurementCommand()()()()
NxtUltrasonicSensor..::..SetContinuousMeasurementInterval(Byte)


ReadFactoryScaleDivisor Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..ReadFactoryScaleDivisor Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the factory scale divisor of the sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte ReadFactoryScaleDivisor()
Visual Basic
Public Function ReadFactoryScaleDivisor As Byte
Visual C++
public:
unsigned char ReadFactoryScaleDivisor()

Return Value

... TBD ...

See Also

NxtUltrasonicSensor Class


ReadFactoryScaleFactor Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..ReadFactoryScaleFactor Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the "factory scale factor" of the sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte ReadFactoryScaleFactor()
Visual Basic
Public Function ReadFactoryScaleFactor As Byte
Visual C++
public:
unsigned char ReadFactoryScaleFactor()

Return Value

... TBD ...

See Also

NxtUltrasonicSensor Class


ReadFactoryZero Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..ReadFactoryZero Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the "factory zero" of the sensor.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte ReadFactoryZero()
Visual Basic
Public Function ReadFactoryZero As Byte
Visual C++
public:
unsigned char ReadFactoryZero()

Return Value

... TBD ...

See Also

NxtUltrasonicSensor Class


ReadMeasurementByteX Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..ReadMeasurementByteX Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: HDK, Appendix 7, p. 2.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> ReadMeasurementByteX(
    byte x
)
Visual Basic
Public Function ReadMeasurementByteX ( _
    x As Byte _
) As Nullable(Of Byte)
Visual C++
public:
Nullable<unsigned char> ReadMeasurementByteX(
    unsigned char x
)

Parameters

x
Type: System..::..Byte
The byte no.

Return Value

... TBD ...

See Also

NxtUltrasonicSensor Class


ReadMeasurementUnits Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..ReadMeasurementUnits Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the measurement units if the sensor, e.g. "10E-2m".

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ReadMeasurementUnits()
Visual Basic
Public Function ReadMeasurementUnits As String
Visual C++
public:
String^ ReadMeasurementUnits()

Return Value

... TBD ...

See Also

NxtUltrasonicSensor Class


RequestWarmReset Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..RequestWarmReset Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: HDK, Appendix 7, p. 3.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void RequestWarmReset()
Visual Basic
Public Sub RequestWarmReset
Visual C++
public:
void RequestWarmReset()

See Also

NxtUltrasonicSensor Class


SetActualScaleDivisor Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..SetActualScaleDivisor Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: HDK, Appendix 7, p. 3.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetActualScaleDivisor(
    byte value
)
Visual Basic
Public Sub SetActualScaleDivisor ( _
    value As Byte _
)
Visual C++
public:
void SetActualScaleDivisor(
    unsigned char value
)

Parameters

value
Type: System..::..Byte
The value

Remarks

See the remark for ReadActualScaleDivisor().

See Also

NxtUltrasonicSensor Class
NKH.MindSqualls Namespace
NxtUltrasonicSensor..::..ReadActualScaleDivisor()()()()


SetActualScaleFactor Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..SetActualScaleFactor Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: HDK, Appendix 7, p. 3.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetActualScaleFactor(
    byte value
)
Visual Basic
Public Sub SetActualScaleFactor ( _
    value As Byte _
)
Visual C++
public:
void SetActualScaleFactor(
    unsigned char value
)

Parameters

value
Type: System..::..Byte
The value

See Also

NxtUltrasonicSensor Class
NKH.MindSqualls Namespace
NxtUltrasonicSensor..::..ReadActualScaleFactor()()()()


SetActualZero Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..SetActualZero Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: HDK, Appendix 7, p. 3.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetActualZero(
    byte value
)
Visual Basic
Public Sub SetActualZero ( _
    value As Byte _
)
Visual C++
public:
void SetActualZero(
    unsigned char value
)

Parameters

value
Type: System..::..Byte
The value

See Also

NxtUltrasonicSensor Class
NKH.MindSqualls Namespace
NxtUltrasonicSensor..::..ReadActualZero()()()()


SetContinuousMeasurementInterval Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..SetContinuousMeasurementInterval Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: HDK, Appendix 7, p. 3.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetContinuousMeasurementInterval(
    byte interval
)
Visual Basic
Public Sub SetContinuousMeasurementInterval ( _
    interval As Byte _
)
Visual C++
public:
void SetContinuousMeasurementInterval(
    unsigned char interval
)

Parameters

interval
Type: System..::..Byte
The interval

See Also

NxtUltrasonicSensor Class
NKH.MindSqualls Namespace
NxtUltrasonicSensor..::..ContinuousMeasurementCommand()()()()
NxtUltrasonicSensor..::..ReadContinuousMeasurementsInterval()()()()


SingleShotCommand Method

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..SingleShotCommand Method
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Reference: HDK, Appendix 7, p. 3.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SingleShotCommand()
Visual Basic
Public Sub SingleShotCommand
Visual C++
public:
void SingleShotCommand()

See Also

NxtUltrasonicSensor Class
NKH.MindSqualls Namespace
NxtUltrasonicSensor..::..ContinuousMeasurementCommand()()()()


NxtUltrasonicSensor Properties

[image] [image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor Properties
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtUltrasonicSensor type exposes the following members.

Properties

 | Name | Description
Public property | DistanceCm | Returns the measured distance in cm.
Public property | PollInterval | Indicates if the sensor, or motor, is auto-polled or not. (Inherited from NxtPollable.)
Public property | ThresholdDistanceCm | Threshold distance.

See Also

NxtUltrasonicSensor Class


DistanceCm Property

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..DistanceCm Property
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Returns the measured distance in cm.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<byte> DistanceCm { get; }
Visual Basic
Public ReadOnly Property DistanceCm As Nullable(Of Byte)
    Get
Visual C++
public:
property Nullable<unsigned char> DistanceCm {
    Nullable<unsigned char> get ();
}

See Also

NxtUltrasonicSensor Class


ThresholdDistanceCm Property

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..ThresholdDistanceCm Property
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Threshold distance.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public byte ThresholdDistanceCm { get; set; }
Visual Basic
Public Property ThresholdDistanceCm As Byte
    Get
    Set
Visual C++
public:
property unsigned char ThresholdDistanceCm {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

NxtUltrasonicSensor Class
NKH.MindSqualls Namespace
NxtUltrasonicSensor..::..OnWithinThresholdDistanceCm
NxtUltrasonicSensor..::..OnOutsideThresholdDistanceCm


NxtUltrasonicSensor Events

[image] [image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor Events
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtUltrasonicSensor type exposes the following members.

Events

 | Name | Description
Public event | OnOutsideThresholdDistanceCm | This event is fired if the sensor does not detect an object within the threshold distance.
Public event | OnPolled | This event is fired when the sensor, or motor, is polled. (Inherited from NxtPollable.)
Public event | OnWithinThresholdDistanceCm | This event is fired if the sensor detects an object within the threshold distance.

See Also

NxtUltrasonicSensor Class


OnOutsideThresholdDistanceCm Event

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..OnOutsideThresholdDistanceCm Event
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired if the sensor does not detect an object within the threshold distance.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event NxtSensorEvent OnOutsideThresholdDistanceCm
Visual Basic
Public Event OnOutsideThresholdDistanceCm As NxtSensorEvent
Visual C++
public:
 event NxtSensorEvent^ OnOutsideThresholdDistanceCm {
    void add (NxtSensorEvent^ value);
    void remove (NxtSensorEvent^ value);
}

See Also

NxtUltrasonicSensor Class
NKH.MindSqualls Namespace
NxtUltrasonicSensor..::..ThresholdDistanceCm
NxtUltrasonicSensor..::..OnWithinThresholdDistanceCm
NxtUltrasonicSensor..::..Poll()()()()


OnWithinThresholdDistanceCm Event

[image]

MindSqualls v2.0 documentation
NxtUltrasonicSensor..::..OnWithinThresholdDistanceCm Event
NxtUltrasonicSensor Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This event is fired if the sensor detects an object within the threshold distance.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event NxtSensorEvent OnWithinThresholdDistanceCm
Visual Basic
Public Event OnWithinThresholdDistanceCm As NxtSensorEvent
Visual C++
public:
 event NxtSensorEvent^ OnWithinThresholdDistanceCm {
    void add (NxtSensorEvent^ value);
    void remove (NxtSensorEvent^ value);
}

See Also

NxtUltrasonicSensor Class
NKH.MindSqualls Namespace
NxtUltrasonicSensor..::..ThresholdDistanceCm
NxtUltrasonicSensor..::..OnOutsideThresholdDistanceCm
NxtUltrasonicSensor..::..Poll()()()()


NxtUsbConnection Class

[image]

MindSqualls v2.0 documentation
NxtUsbConnection Class
Members See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Class representing communication over an USB connection.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class NxtUsbConnection : NxtCommunicationProtocol
Visual Basic
Public Class NxtUsbConnection _
    Inherits NxtCommunicationProtocol
Visual C++
public ref class NxtUsbConnection : public NxtCommunicationProtocol

Remarks

Introduced with v2.0 of the framework.

Inheritance Hierarchy

System..::..Object
NKH.MindSqualls..::..NxtCommunicationProtocol
NKH.MindSqualls..::..NxtUsbConnection

See Also

NxtUsbConnection Members
NKH.MindSqualls Namespace
NKH.MindSqualls..::..NxtBluetoothConnection


NxtUsbConnection Members

[image] [image]

MindSqualls v2.0 documentation
NxtUsbConnection Members
NxtUsbConnection Class Constructors Methods Fields Properties See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtUsbConnection type exposes the following members.

Constructors

 | Name | Description
Public method | NxtUsbConnection | Initializes a new instance of the NxtUsbConnection class

Methods

 | Name | Description
Public method | BluetoothFactoryReset | BLUETOOTH FACTORY RESET COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | Boot | BOOT COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | Close | CLOSE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | CloseModuleHandle | CLOSE MODULE HANDLE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | Connect | This method has no function for an USB connection. (Overrides NxtCommunicationProtocol..::..Connect()()()().)
Public method | Delete | DELETE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | DeleteUserFlash | DELETE USER FLASH (Inherited from NxtCommunicationProtocol.)
Public method | Disconnect | This method has no function for an USB connection. (Overrides NxtCommunicationProtocol..::..Disconnect()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFirst | FIND FIRST (Inherited from NxtCommunicationProtocol.)
Public method | FindNext | FIND NEXT (Inherited from NxtCommunicationProtocol.)
Public method | GetBatteryLevel | GETBATTERYLEVEL (Inherited from NxtCommunicationProtocol.)
Public method | GetCurrentProgramName | GETCURRENTPROGRAMNAME (Inherited from NxtCommunicationProtocol.)
Public method | GetDeviceInfo | GET DEVICE INFO (Inherited from NxtCommunicationProtocol.)
Public method | GetFirmwareVersion | GET FIRMWARE VERSION (Inherited from NxtCommunicationProtocol.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInputValues | GETINPUTVALUES (Inherited from NxtCommunicationProtocol.)
Public method | GetOutputState | GETOUTPUTSTATE (Inherited from NxtCommunicationProtocol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KeepAlive | KEEPALIVE (Inherited from NxtCommunicationProtocol.)
Public method | LsGetStatus | LSGETSTATUS (Inherited from NxtCommunicationProtocol.)
Public method | LsRead | LSREAD (Inherited from NxtCommunicationProtocol.)
Public method | LsWrite | LSWRITE (Inherited from NxtCommunicationProtocol.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MessageRead | MESSAGEREAD (Inherited from NxtCommunicationProtocol.)
Public method | MessageWrite | MESSAGEWRITE (Inherited from NxtCommunicationProtocol.)
Public method | OpenAppendData | OPEN APPEND DATA COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenRead | OPEN READ COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenReadLinear | OPEN READ LINEAR COMMAND (INTERNAL COMMAND) (Inherited from NxtCommunicationProtocol.)
Public method | OpenWrite | OPEN WRITE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenWriteData | OPEN WRITE DATA COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenWriteLinear | OPEN WRITE LINEAR COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | PlaySoundfile | PLAYSOUNDFILE (Inherited from NxtCommunicationProtocol.)
Public method | PlayTone | PLAYTONE (Inherited from NxtCommunicationProtocol.)
Public method | PollCommand | POLL COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | PollCommandLength | POLL COMMAND LENGTH (Inherited from NxtCommunicationProtocol.)
Public method | Read | READ COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | ReadIoMap | READ IO MAP COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | RequestFirstModule | REQUEST FIRST MODULE (Inherited from NxtCommunicationProtocol.)
Public method | RequestNextModule | REQUEST NEXT MODULE (Inherited from NxtCommunicationProtocol.)
Public method | ResetInputScaledValue | RESETINPUTSCALEDVALUE (Inherited from NxtCommunicationProtocol.)
Public method | ResetMotorPosition | RESETMOTORPOSITION (Inherited from NxtCommunicationProtocol.)
Protected method | Send | Sends a request for the NXT brick, and if applicable, receive the reply. (Overrides NxtCommunicationProtocol..::..Send(array<Byte>[]()[][]).)
Public method | SetBrickName | SET BRICK NAME COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | SetInputMode | SETINPUTMODE (Inherited from NxtCommunicationProtocol.)
Public method | SetOutputState | SETOUTPUTSTATE (Inherited from NxtCommunicationProtocol.)
Public method | StartProgram | STARTPROGRAM (Inherited from NxtCommunicationProtocol.)
Public method | StopProgram | STOPPROGRAM (Inherited from NxtCommunicationProtocol.)
Public method | StopSoundPlayback | STOPSOUNDPLAYBACK (Inherited from NxtCommunicationProtocol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | WRITE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | WriteIoMap | WRITE IO MAP COMMAND (Inherited from NxtCommunicationProtocol.)

Fields

 | Name | Description
Public field | ReplyRequired | Flag indicating if a reply should always be recieved. (Inherited from NxtCommunicationProtocol.)

Properties

 | Name | Description
Public property | IsConnected | Indicates if connected to the NXT brick. (Overrides NxtCommunicationProtocol..::..IsConnected.)

See Also

NxtUsbConnection Class


NxtUsbConnection Constructor

[image]

MindSqualls v2.0 documentation
NxtUsbConnection Constructor
NxtUsbConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot
Initializes a new instance of the NxtUsbConnection class

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NxtUsbConnection()
Visual Basic
Public Sub New
Visual C++
public:
NxtUsbConnection()

See Also

NxtUsbConnection Class


NxtUsbConnection Fields

[image] [image]

MindSqualls v2.0 documentation
NxtUsbConnection Fields
NxtUsbConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtUsbConnection type exposes the following members.

Fields

 | Name | Description
Public field | ReplyRequired | Flag indicating if a reply should always be recieved. (Inherited from NxtCommunicationProtocol.)

See Also

NxtUsbConnection Class


NxtUsbConnection Methods

[image] [image]

MindSqualls v2.0 documentation
NxtUsbConnection Methods
NxtUsbConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtUsbConnection type exposes the following members.

Methods

 | Name | Description
Public method | BluetoothFactoryReset | BLUETOOTH FACTORY RESET COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | Boot | BOOT COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | Close | CLOSE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | CloseModuleHandle | CLOSE MODULE HANDLE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | Connect | This method has no function for an USB connection. (Overrides NxtCommunicationProtocol..::..Connect()()()().)
Public method | Delete | DELETE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | DeleteUserFlash | DELETE USER FLASH (Inherited from NxtCommunicationProtocol.)
Public method | Disconnect | This method has no function for an USB connection. (Overrides NxtCommunicationProtocol..::..Disconnect()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFirst | FIND FIRST (Inherited from NxtCommunicationProtocol.)
Public method | FindNext | FIND NEXT (Inherited from NxtCommunicationProtocol.)
Public method | GetBatteryLevel | GETBATTERYLEVEL (Inherited from NxtCommunicationProtocol.)
Public method | GetCurrentProgramName | GETCURRENTPROGRAMNAME (Inherited from NxtCommunicationProtocol.)
Public method | GetDeviceInfo | GET DEVICE INFO (Inherited from NxtCommunicationProtocol.)
Public method | GetFirmwareVersion | GET FIRMWARE VERSION (Inherited from NxtCommunicationProtocol.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInputValues | GETINPUTVALUES (Inherited from NxtCommunicationProtocol.)
Public method | GetOutputState | GETOUTPUTSTATE (Inherited from NxtCommunicationProtocol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KeepAlive | KEEPALIVE (Inherited from NxtCommunicationProtocol.)
Public method | LsGetStatus | LSGETSTATUS (Inherited from NxtCommunicationProtocol.)
Public method | LsRead | LSREAD (Inherited from NxtCommunicationProtocol.)
Public method | LsWrite | LSWRITE (Inherited from NxtCommunicationProtocol.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MessageRead | MESSAGEREAD (Inherited from NxtCommunicationProtocol.)
Public method | MessageWrite | MESSAGEWRITE (Inherited from NxtCommunicationProtocol.)
Public method | OpenAppendData | OPEN APPEND DATA COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenRead | OPEN READ COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenReadLinear | OPEN READ LINEAR COMMAND (INTERNAL COMMAND) (Inherited from NxtCommunicationProtocol.)
Public method | OpenWrite | OPEN WRITE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenWriteData | OPEN WRITE DATA COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | OpenWriteLinear | OPEN WRITE LINEAR COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | PlaySoundfile | PLAYSOUNDFILE (Inherited from NxtCommunicationProtocol.)
Public method | PlayTone | PLAYTONE (Inherited from NxtCommunicationProtocol.)
Public method | PollCommand | POLL COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | PollCommandLength | POLL COMMAND LENGTH (Inherited from NxtCommunicationProtocol.)
Public method | Read | READ COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | ReadIoMap | READ IO MAP COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | RequestFirstModule | REQUEST FIRST MODULE (Inherited from NxtCommunicationProtocol.)
Public method | RequestNextModule | REQUEST NEXT MODULE (Inherited from NxtCommunicationProtocol.)
Public method | ResetInputScaledValue | RESETINPUTSCALEDVALUE (Inherited from NxtCommunicationProtocol.)
Public method | ResetMotorPosition | RESETMOTORPOSITION (Inherited from NxtCommunicationProtocol.)
Protected method | Send | Sends a request for the NXT brick, and if applicable, receive the reply. (Overrides NxtCommunicationProtocol..::..Send(array<Byte>[]()[][]).)
Public method | SetBrickName | SET BRICK NAME COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | SetInputMode | SETINPUTMODE (Inherited from NxtCommunicationProtocol.)
Public method | SetOutputState | SETOUTPUTSTATE (Inherited from NxtCommunicationProtocol.)
Public method | StartProgram | STARTPROGRAM (Inherited from NxtCommunicationProtocol.)
Public method | StopProgram | STOPPROGRAM (Inherited from NxtCommunicationProtocol.)
Public method | StopSoundPlayback | STOPSOUNDPLAYBACK (Inherited from NxtCommunicationProtocol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | WRITE COMMAND (Inherited from NxtCommunicationProtocol.)
Public method | WriteIoMap | WRITE IO MAP COMMAND (Inherited from NxtCommunicationProtocol.)

See Also

NxtUsbConnection Class


Connect Method

[image]

MindSqualls v2.0 documentation
NxtUsbConnection..::..Connect Method
NxtUsbConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This method has no function for an USB connection.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Connect()
Visual Basic
Public Overrides Sub Connect
Visual C++
public:
virtual void Connect() override

See Also

NxtUsbConnection Class


Disconnect Method

[image]

MindSqualls v2.0 documentation
NxtUsbConnection..::..Disconnect Method
NxtUsbConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

This method has no function for an USB connection.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Disconnect()
Visual Basic
Public Overrides Sub Disconnect
Visual C++
public:
virtual void Disconnect() override

See Also

NxtUsbConnection Class


Send Method

[image]

MindSqualls v2.0 documentation
NxtUsbConnection..::..Send Method
NxtUsbConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Sends a request for the NXT brick, and if applicable, receive the reply.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override byte[] Send(
    byte[] request
)
Visual Basic
Protected Overrides Function Send ( _
    request As Byte() _
) As Byte()
Visual C++
protected:
virtual array<unsigned char>^ Send(
    array<unsigned char>^ request
) override

Parameters

request
Type: array< System..::..Byte >[]()[][]
The request

Return Value

The reply as a byte-array, or null

See Also

NxtUsbConnection Class


NxtUsbConnection Properties

[image] [image]

MindSqualls v2.0 documentation
NxtUsbConnection Properties
NxtUsbConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

The NxtUsbConnection type exposes the following members.

Properties

 | Name | Description
Public property | IsConnected | Indicates if connected to the NXT brick. (Overrides NxtCommunicationProtocol..::..IsConnected.)

See Also

NxtUsbConnection Class


IsConnected Property

[image]

MindSqualls v2.0 documentation
NxtUsbConnection..::..IsConnected Property
NxtUsbConnection Class See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Indicates if connected to the NXT brick.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool IsConnected { get; }
Visual Basic
Public Overrides ReadOnly Property IsConnected As Boolean
    Get
Visual C++
public:
virtual property bool IsConnected {
    bool get () override;
}

See Also

NxtUsbConnection Class


Polled Delegate

[image]

MindSqualls v2.0 documentation
Polled Delegate
See Also Send Feedback
MindSqualls is a .Net 4.0 library for the LEGO MINDSTORMS NXT robot

Delegate used when a motor or sensor is polled.

Namespace: NKH.MindSqualls
Assembly: NKH.MindSqualls (in NKH.MindSqualls.dll) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public delegate void Polled(
    NxtPollable polledItem
)
Visual Basic
Public Delegate Sub Polled ( _
    polledItem As NxtPollable _
)
Visual C++
public delegate void Polled(
    NxtPollable^ polledItem
)

Parameters

polledItem
Type: NKH.MindSqualls..::..NxtPollable
The motor/sensor.

See Also

NKH.MindSqualls Namespace

Send comments on this topic to niels@mindsqualls.net

The legal stuff